Project

General

Profile

action #120405

Failed log file tests are transferred from Leap to Tumbleweed for s390x size:M

Added by AdaLovelace 3 months ago. Updated 2 months ago.

Status:
Resolved
Priority:
High
Assignee:
Category:
Concrete Bugs
Target version:
Start date:
2022-11-14
Due date:
% Done:

0%

Estimated time:
Difficulty:

Description

Observation

Thank you for fixing the test issue for openSUSE Leap on s390x.
We hve got the same issue on openSUSE Tumbleweed for s390x and with textmode now:
https://openqa.opensuse.org/tests/2876172#step/logs_from_installation_system/13

It seems, that the test issue with failed log file uploads has been transferred with the fix for openSUSE Leap. :(

Acceptance criteria

  • AC1: s390 tests do not fail uploading log files

Suggestions


Related issues

Related to openQA Project - action #119713: Leap tests are failing because of failed log file uploading in multiple tests on s390x size:MResolved2022-11-01

History

#1 Updated by okurz 3 months ago

  • Category set to Concrete Bugs
  • Priority changed from Normal to High
  • Target version set to Ready

#2 Updated by AdaLovelace 3 months ago

It seems, that there is a problem with the parallelization of running tests in openQA. Leap has got this issue also again.
2 days ago, it was possible to resolve these failed tests with rerunning tests one after the next one:
https://openqa.opensuse.org/tests/overview?distri=opensuse&version=15.5&build=327.1&groupid=50

#3 Updated by mkittler 2 months ago

How was this solved before (for Leap specifically)? A little bit context wouldn't hurt. Otherwise I'm not sure I'm following what the problem is. If it is about fixing problems with tests itself then I'm wondering why it falls into the tools team backlog.

Your last comment sounds like there are there might be multiple openQA worker instances running that use the same s390x "VM" in the background. However, judging by /opt/s390x_rebel_replacement/workers.ini on openqaworker1 and the services running there I don't think there's such a conflict.

#4 Updated by AdaLovelace 2 months ago

I can not link the issue to here:
https://progress.opensuse.org/issues/119713

#5 Updated by okurz 2 months ago

  • Related to action #119713: Leap tests are failing because of failed log file uploading in multiple tests on s390x size:M added

#6 Updated by mkittler 2 months ago

The fix done for that ticket is independent from the system being tested (whether it is Leap or Tumbleweed). So maybe the fix is just not deployed everywhere?

#7 Updated by cdywan 2 months ago

  • Subject changed from Failed log file tests are transferred from Leap to Tumbleweed for s390x to Failed log file tests are transferred from Leap to Tumbleweed for s390x size:M
  • Description updated (diff)
  • Status changed from New to Workable

#8 Updated by AdaLovelace 2 months ago

If the fix is not deployed anywhere, I am surprised that fistly only Leap was affected and now both. From my point of view, the whole accepted openQA code should be applied for our openQA tests at openSUSE.

#9 Updated by dheidler 2 months ago

  • Status changed from Workable to In Progress
  • Assignee set to dheidler

The patch from #119713 doesn't seem to have been applied to the containers, yet.

#10 Updated by dheidler 2 months ago

  • Status changed from In Progress to Feedback

Updated the containers to use the new image which has the patch included.
Let's see if it helps: https://openqa.opensuse.org/tests/2912624#live

#11 Updated by dheidler 2 months ago

  • Status changed from Feedback to Resolved

Also available in: Atom PDF