Project

General

Profile

action #111416

[tools] Firefox: new screen for total cookie protection

Added by dimstar about 1 month ago. Updated 30 days ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
Bugs in existing tests
Target version:
Start date:
2022-05-22
Due date:
% Done:

0%

Estimated time:
Difficulty:

Description

Observation

Firefox shows a new screen - sometimes.

Seems there is she A/B testing in progress and Firefox apparently randomly receives the new dialog.

Rerunning the test most of the time passes, as the dialog is not consistently sitting up (yet) - but those reruns are wasting time and resources

openQA test in scenario opensuse-Tumbleweed-NET-x86_64-upgrade_Leap_42.2_kde@64bit fails in
firefox

Test suite description

Maintainer: lnussel@suse.de

20180309 -- lnussel -- switched to last available 42.2 image 20180205. And back to opensuse-42.2-x86_64-GM-kde@64bit.qcow2 with https://progress.opensuse.org/issues/44546 .

Reproducible

Fails since (at least) Build 20220521 (current job)

Expected result

Last good: 20220520 (or more recent)

Further details

Always latest result in this scenario: latest


Related issues

Related to openQA Project - action #111545: openQA-in-openQA test fails in search due to new Firefox pop-ups. Can Firefox be asked to not create any pop-ups? auto_review:"(?s)openQA/login.pm:6 called testapi::assert_and_click.*match=openqa-login timed out" size:MResolved2022-05-24

History

#1 Updated by maritawerner about 1 month ago

  • Subject changed from Firefox: new screen for total cookie protection to [qe-core] Firefox: new screen for total cookie protection

szarate I assign it to your team, please reassign if this is the wrong team.

#2 Updated by okurz about 1 month ago

  • Related to action #111545: openQA-in-openQA test fails in search due to new Firefox pop-ups. Can Firefox be asked to not create any pop-ups? auto_review:"(?s)openQA/login.pm:6 called testapi::assert_and_click.*match=openqa-login timed out" size:M added

#3 Updated by jbaier_cz about 1 month ago

  • Status changed from New to In Progress
  • Assignee set to jbaier_cz

#4 Updated by jbaier_cz about 1 month ago

  • Status changed from In Progress to Feedback

Pull request created: https://github.com/os-autoinst/os-autoinst-distri-opensuse/pull/14994

For now, it only targets the openSUSE tests (SLE is not using x11/firefox it has more regression tests in x11/firefox/*).

#5 Updated by okurz about 1 month ago

I hope that x11/firefox is still used within SLE tests but that shouldn't influence the solution.

#6 Updated by jbaier_cz about 1 month ago

It was a little bit harder to find it, but finally I discovered at least qam-allpatterns+addons. On the other places, there is usually the more advanced set of firefox tests. I will try to clone some test to verify.

#7 Updated by jbaier_cz about 1 month ago

  • Status changed from Feedback to Resolved

The problem with firefox should be gone.

#8 Updated by okurz 30 days ago

  • Subject changed from [qe-core] Firefox: new screen for total cookie protection to [tools] Firefox: new screen for total cookie protection
  • Target version set to Ready

Also available in: Atom PDF