Project

General

Profile

Actions

action #107497

closed

coordination #80142: [saga][epic] Scale out: Redundant/load-balancing deployments of openQA, easy containers, containers on kubernetes

coordination #109659: [epic] More remote workers

[qe-tools] openqaworker14 (and openqa15) - developer mode fails size:M

Added by osukup over 2 years ago. Updated over 1 year ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
Regressions/Crashes
Target version:
Start date:
2022-02-24
Due date:
% Done:

0%

Estimated time:
Tags:

Description

Observation

in live view developer mode fails and reports fail every 2 sec

from browser javascript console:

Establishing ws connection to wss://openqa.suse.de/liveviewhandler/tests/8210859/developer/ws-proxy/status
Received message via ws proxy: {"data":null,"type":"info","what":"connecting to os-autoinst command server at ws:\/\/10.100.96.68:20043\/OX0bG6w17OkxmWt_\/ws"}
Received message via ws proxy: {"data":null,"type":"error","what":"unable to upgrade ws to command server"}
Error from ws proxy: unable to upgrade ws to command server
Connection to livehandler lost

the connection between osd and workers works without problems and IP address of worker is also correct

Acceptance criteria

  • AC1: Developer mode on openqaworker14.qa.suse.cz works reliably as part of the productive OSD infrastructure

Suggestions


Files


Related issues 1 (0 open1 closed)

Related to openQA Infrastructure - action #104970: Add two OSD workers (openqaworker14+openqaworker15) specifically for sap-application testing size:MResolvedmkittler2022-01-17

Actions
Actions #1

Updated by okurz over 2 years ago

  • Category set to Regressions/Crashes
  • Target version set to Ready
Actions #2

Updated by okurz over 2 years ago

  • Related to action #104970: Add two OSD workers (openqaworker14+openqaworker15) specifically for sap-application testing size:M added
Actions #3

Updated by livdywan over 2 years ago

  • Subject changed from [qe-tools] openqaworker14 and openqa15 - developer mode fails to [qe-tools] openqaworker14 and openqa15 - developer mode fails size:M
  • Description updated (diff)
  • Status changed from New to Workable
Actions #4

Updated by okurz about 2 years ago

  • Status changed from Workable to Blocked
  • Assignee set to okurz

blocked by #104970

Actions #5

Updated by okurz about 2 years ago

  • Parent task set to #109659
Actions #6

Updated by okurz about 2 years ago

  • Status changed from Blocked to Workable
  • Assignee deleted (okurz)
Actions #7

Updated by okurz about 2 years ago

  • Target version changed from Ready to future
Actions #8

Updated by okurz about 2 years ago

  • Subject changed from [qe-tools] openqaworker14 and openqa15 - developer mode fails size:M to [qe-tools] openqaworker14 (and openqa15) - developer mode fails size:M
  • Description updated (diff)
Actions #9

Updated by okurz about 2 years ago

  • Target version changed from future to Ready
Actions #10

Updated by mkittler about 2 years ago

  • Assignee set to mkittler
Actions #11

Updated by mkittler about 2 years ago

  • Status changed from Workable to Resolved

The developer mode is working. I've checked several tests which are currently running on openqaworker14, e.g. https://openqa.suse.de/tests/8821312#live, https://openqa.suse.de/tests/8821350#live and https://openqa.suse.de/tests/8822624#live. Maybe it didn't work when you initially set those workers up but the problem has apparently been fixed in the meantime. (Maybe when I applied salt again in order to fix the MM setup.)

Note that openqaworker15 is not used on OSD anymore.

Actions #12

Updated by okurz over 1 year ago

  • Tags set to infra
Actions

Also available in: Atom PDF