Project

General

Profile

action #105768

nginx fails to reload (new test)

Added by dimstar 10 months ago. Updated 10 months ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
Bugs in existing tests
Target version:
-
Start date:
2022-01-31
Due date:
% Done:

0%

Estimated time:
Difficulty:
Tags:

Description

Observation

New test introduced with https://github.com/os-autoinst/os-autoinst-distri-opensuse/pull/14082

openQA test in scenario opensuse-Tumbleweed-DVD-x86_64-textmode@64bit fails in
nginx

Jan 31 11:35:39 susetest systemd[1]: Started The nginx HTTP and reverse proxy server.
Jan 31 11:35:39 susetest nginx[19056]: nginx: [emerg] bind() to 0.0.0.0:80 failed (98: Address already in use)
Jan 31 11:35:40 susetest nginx[19056]: nginx: [emerg] bind() to 0.0.0.0:80 failed (98: Address already in use)
Jan 31 11:35:40 susetest nginx[19056]: nginx: [emerg] bind() to 0.0.0.0:80 failed (98: Address already in use)
Jan 31 11:35:41 susetest nginx[19056]: nginx: [emerg] bind() to 0.0.0.0:80 failed (98: Address already in use)
Jan 31 11:35:41 susetest nginx[19056]: nginx: [emerg] bind() to 0.0.0.0:80 failed (98: Address already in use)
Jan 31 11:35:42 susetest nginx[19056]: nginx: [emerg] still could not bind()

Test suite description

Installation in textmode and selecting the textmode "desktop" during installation.

Reproducible

Fails since (at least) Build 20220130 (current job)

Expected result

Last good: 20220129 (or more recent)

Further details

Always latest result in this scenario: latest


Related issues

Related to openQA Tests - action #105786: [qem] test fails in nginx zypp install on all sles versions Resolved2022-02-01

History

#1 Updated by ph03nix 10 months ago

Pretty sure the reason is that apache is already running: https://openqa.opensuse.org/tests/2167877#step/apache/168

#2 Updated by maritawerner 10 months ago

  • Tags set to qac

#3 Updated by pdostal 10 months ago

  • Status changed from New to In Progress

#5 Updated by pdostal 10 months ago

This seems to be fixed. Please feel free to reopen if you notice something unusual.

#6 Updated by pdostal 10 months ago

  • Status changed from In Progress to Resolved

#7 Updated by pdostal 10 months ago

  • Related to action #105786: [qem] test fails in nginx zypp install on all sles versions added

Also available in: Atom PDF