Project

General

Profile

action #104619

openqa_from_containers needs adapted post_fail_hook (was: tests fails due to openSUSE mirror problems with can't locate Mojo/Base.pm in INC in script/client)

Added by cdywan 4 months ago. Updated 3 months ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
Concrete Bugs
Target version:
Start date:
2021-12-29
Due date:
% Done:

0%

Estimated time:
Difficulty:

Description

Observation

https://openqa.opensuse.org/tests/2121659#step/build/8 failed:

Repository: devel_open0 Hey Fingerprin A99A 72E3 06F2 0929 E6E E378 5B12 1667 CHF 5E8F Hey Mame: d7LzenflA OBS Project alevel:open08build.opensuse.org> Hey Algorithm: RS Hey Created: Sun Oct 31 15:07:46 2021 Hey Expires: Ti.m Jan 9 15:07:46 2024 Rpm Mame: gpg-pubkey-cbdf5e8f-617eb142 
Mote: A GPG pubkey is clearly identified by it's finger int. Do not rely the keys name. If you are not sure whether the presented key is authentic, ask the repository provider or check his web site. Mkny provider maintain a web page showing the fingerprints of the GPG keys they are using. .doneI uilding repository ,..el_openOW cache I....done, :Irl,i,7,gilerg7ZgrYcleZe.1,,ZWL7P.ca:Ia`r.Lt3e' etrieving repository 'Update repository of openSUSE Backports' metadata I.doneI uilding repository 'Update repository of openSUSE Backports' cache I....done, etrieving repository 'Mon-OSS Repository' metadata I. .doneI uilding repository 'Mon-OSS Repository' cache I....done, etrieving repository 'Main Repository' metadata I...done, uilding repository 'Main Repository' cache I....done, etrieving repository 'Update repository with updates from SUSE Linux Enterprise 15' metadata I  
.usetest:- I 1114.2957601f 1.28841 docker0: port 1(yethccb3970) entered disabled state 1114.3639051f 1.23961 yetla6c0b95: renamed from etIM 1114.476911H 1.23961 docker0: port 1(yethccb3970) entered disabled state 1114.5418231f 1.23961 device yethccb3970 left promiscumm mode 1114.5438471f 1.23961 docker0: port 1(yethccb3970) entered disabled state /root/opnflA, eclm > /dev/ttyS0 .usetest:-/open0 script/client jobs; eclm W-s,_ > /dev/ttyS0 an't locate Mojo/Base.pm in OINC (you may need to install the Mojo::Base module) ORINC contains: /root/openflA/script/../lib /us ,lib/per15/site_per1/5.34.0/x86_64 linux thread multi /usr/lib/per15/site_per34.0 /usr/lib/per15/yendor_pr1/5.34.0/x86_64- linux-thread-multi /usr/lib/per15yedor_per1/5.34.0 /usr/lib/per15/5.34.0/x86_64 linux thread multi /usr/lib/per15/5.34.0 /usr/ lib/per15/site_perl) at /root/openflA/script/../lib/OpenflA/Script/Client.pm line 6. ,EGIN failed--compilation aborted at /root/openflA/script/../libOpenflA/Script/Client.pm line 6. ompilation failed in require at at line 160. ,EGIN failed-compilation aborted at script/client line 160. .usetest:-/open0 

# Test died: command 'for i in {1..3}; do docker build openQA/container/webui -t openqa_webui && break; done' timed out at openqa//tests/containers/build.pm line 8.

See tests/containers/build.pm:8.

Suggestions

  • Investigate what changed in the meantime e.g. dependencies, code changes

Related issues

Related to openQA Project - action #104517: Connections to download.opensuse.org affecting openQA CI and o3Resolved2021-12-30

Copied to openQA Project - action #104622: Provide copy-able text output for failures in openqa_from_containers tests New2021-12-292022-01-13

History

#1 Updated by cdywan 4 months ago

12343

#2 Updated by cdywan 4 months ago

  • Copied to action #104622: Provide copy-able text output for failures in openqa_from_containers tests added

#3 Updated by cdywan 4 months ago

  • Copied from deleted (action #104499: s390 tests fail with backend died: unable to extract assets: Too many arguments for subroutine 'backend::baseclass::do_extract_assets)

#4 Updated by cdywan 4 months ago

  • Subject changed from openqa_from_containers tests fail to openqa_from_containers tests fail with can't locate Mojo/Base.pm in INC in script/client

#5 Updated by okurz 4 months ago

  • Related to action #104517: Connections to download.opensuse.org affecting openQA CI and o3 added

#6 Updated by okurz 4 months ago

  • Project changed from openQA Tests to openQA Project
  • Subject changed from openqa_from_containers tests fail with can't locate Mojo/Base.pm in INC in script/client to openqa_from_containers needs adapted post_fail_hook (was: tests fails due to openSUSE mirror problems with can't locate Mojo/Base.pm in INC in script/client)
  • Due date deleted (2022-01-13)
  • Category set to Concrete Bugs
  • Status changed from New to Blocked
  • Assignee set to okurz

So the openQA job fails in https://openqa.opensuse.org/tests/2121659#step/build/5 because of problems to build the containers. This is just #104517 and friends again. The script/client call is from the post-fail-hook which was never adapted for the container variant of os-autoinst-distri-openQA. It does not make sense to call openqa-client jobs when the containers are built to run in a separate environment, not "localhost" per se

#7 Updated by cdywan 4 months ago

  • Status changed from Blocked to Feedback

okurz wrote:

The script/client call is from the post-fail-hook which was never adapted for the container variant of os-autoinst-distri-openQA. It does not make sense to call openqa-client jobs when the containers are built to run in a separate environment, not "localhost" per se

It seems odd that a network issue would ever cause a compilation aborted, though? Even if for the sake of argument the call is wrong, I would expect a clear error.

#8 Updated by okurz 4 months ago

I think it's better if I explain to you while sharing screen. Please remind me about this ticket in one of our upcoming meetings.

#9 Updated by cdywan 4 months ago

okurz wrote:

I think it's better if I explain to you while sharing screen. Please remind me about this ticket in one of our upcoming meetings.

So https://openqa.opensuse.org/tests/2121659#step/build/3 shows this, and the issue is really that zypper times out:

Retrieving repository "Update repository with updates from SUSE Linux Enterprise 15" metadata [......................................................................................................................

#10 Updated by okurz 3 months ago

  • Status changed from Feedback to Resolved

I think openSUSE admins did improve the situation and downloads don't seem to show such problems lately. We could theoretically fix all the other mentioned points but I consider the ROI too low right now. The current history of https://openqa.opensuse.org/tests/latest?arch=x86_64&distri=openqa&flavor=dev&machine=64bit-2G&test=openqa_from_containers&version=Tumbleweed#next_previous shows a rather high stability so we should be ok.

Also available in: Atom PDF