Project

General

Profile

action #104499

s390 tests fail with backend died: unable to extract assets: Too many arguments for subroutine 'backend::baseclass::do_extract_assets

Added by cdywan 5 months ago. Updated 5 months ago.

Status:
Resolved
Priority:
High
Assignee:
Category:
Concrete Bugs
Target version:
Start date:
2021-12-29
Due date:
2022-01-13
% Done:

0%

Estimated time:
Difficulty:

Description

Observation

https://openqa.suse.de/tests/7917723 started failing. This looks to be a regression.

Suggestions


Related issues

Copied to openQA Project - action #104520: Move svirt extract_asset code from os-autoinst-distri-opensuse to os-autoinst/backend/svirt.pm size:M auto_review:"unable to extract assets: Can't call method.+name.+on an undefined value":retryWorkable2021-12-29

History

#1 Updated by cdywan 5 months ago

  • Status changed from Workable to In Progress

cdywan wrote:

https://github.com/os-autoinst/os-autoinst/pull/1892 merged, next steps fixing the signature and looking into the gap in our test coverage based on the code path exercised by mru-install-minimal-with-addons@s390x-kvm-sle12

#2 Updated by cdywan 5 months ago

cdywan wrote:

cdywan wrote:

https://github.com/os-autoinst/os-autoinst/pull/1892 merged, next steps fixing the signature and looking into the gap in our test coverage based on the code path exercised by mru-install-minimal-with-addons@s390x-kvm-sle12

Quite simply svirt doesn't implement do_extract_assets: https://github.com/os-autoinst/os-autoinst/pull/1895 and we don't require all backends to either - maybe that simply needs to change before we can drop the unless QEMU?

#3 Updated by tinita 5 months ago

Here's a PR to add coverage for the 'unimplemented' methods: https://github.com/os-autoinst/os-autoinst/pull/1894 (merged)

#4 Updated by cdywan 5 months ago

cdywan wrote:

Quite simply svirt doesn't implement do_extract_assets: https://github.com/os-autoinst/os-autoinst/pull/1895 and we don't require all backends to either - maybe that simply needs to change before we can drop the unless QEMU?

Alternatively we could return based on having assets or not: https://github.com/os-autoinst/os-autoinst/pull/1897

#5 Updated by openqa_review 5 months ago

  • Due date set to 2022-01-13

Setting due date based on mean cycle time of SUSE QE Tools

#6 Updated by cdywan 5 months ago

cdywan wrote:

Alternatively we could return based on having assets or not: https://github.com/os-autoinst/os-autoinst/pull/1897

Discussed it briefly with Tina. With the fix for the 'unimplemented' methods we actually have a pretty clear error message visible in the reason, and Tina will check with Marcelo if it's clear enough.

So the remaining point would be to 1) drop the unless QEMU 2) add a unit test hitting the "not implemented" error if PUBLISH_HDD_1 was set but do_extract_assets isn't implemented.

#7 Updated by tinita 5 months ago

I had a closer look at the test code, and it's clear now why the test had set PUBLISH_HDD_1.
The svirt_upload_assets implements extract_assets itself, and it does this using the same special variable name as os-autoinst:
https://github.com/os-autoinst/os-autoinst-distri-opensuse/blob/master/tests/shutdown/svirt_upload_assets.pm

This only worked because PUBLISH_HDD_ was simply ignored for anthing but qemu so far.

The code above should be moved to backend::svirt, and after that we can hopefully remove the check for qemu.

#8 Updated by tinita 5 months ago

  • Copied to action #104520: Move svirt extract_asset code from os-autoinst-distri-opensuse to os-autoinst/backend/svirt.pm size:M auto_review:"unable to extract assets: Can't call method.+name.+on an undefined value":retry added

#9 Updated by cdywan 5 months ago

  • Status changed from In Progress to Feedback

I'm thinking we can consider this done, since tests are passing again and #104520 covers the backend changes needed to solve the problems with os-autoinst/os-autoinst/pull/1741

#10 Updated by cdywan 5 months ago

  • Copied to action #104619: openqa_from_containers needs adapted post_fail_hook (was: tests fails due to openSUSE mirror problems with can't locate Mojo/Base.pm in INC in script/client) added

#11 Updated by cdywan 5 months ago

  • Copied to deleted (action #104619: openqa_from_containers needs adapted post_fail_hook (was: tests fails due to openSUSE mirror problems with can't locate Mojo/Base.pm in INC in script/client))

#12 Updated by cdywan 5 months ago

  • Status changed from Feedback to Resolved

Also available in: Atom PDF