Project

General

Profile

Actions

action #104517

closed

Connections to download.opensuse.org affecting openQA CI and o3

Added by livdywan about 2 years ago. Updated almost 2 years ago.

Status:
Resolved
Priority:
Low
Assignee:
Category:
Regressions/Crashes
Target version:
Start date:
2021-12-30
Due date:
% Done:

0%

Estimated time:

Description

Motivation

I'm observing more issues with download.opensuse.org and I need something I can refer to. Regardless of wether it's an issue on our end or somewhere else.

Observation

On some GHA jobs:

Error: ing: libsndfile1-1.0.31-2.2.x86_64.rpm [error]
Download (curl) error for 'http://download.opensuse.org/tumbleweed/repo/oss/x86_64/libsndfile1-1.0.31-2.2.x86_64.rpm':
Abort, retry, ignore? [a/r/i/...? shows all options] (a): a
Error code: Curl error 55
Error message: Connection died, tried 5 times before giving up

Error: ing: fontconfig-2.13.1-2.12.x86_64.rpm [error]
Download (curl) error for 'http://download.opensuse.org/tumbleweed/repo/oss/x86_64/fontconfig-2.13.1-2.12.x86_64.rpm':
Abort, retry, ignore? [a/r/i/...? shows all options] (a): a
Error code: Curl error 55
Error message: Connection died, tried 5 times before giving up

On some openQA tests on o3:

https://openqa.opensuse.org/tests/2111949#step/openqa_worker/3
https://openqa.opensuse.org/tests/2111960#step/openqa_webui/9

Needles with the error messages attached.


Files

2111949.png (39.2 KB) 2111949.png livdywan, 2021-12-30 11:13
2111960.png (72.7 KB) 2111960.png livdywan, 2021-12-30 11:13

Related issues 1 (0 open1 closed)

Related to openQA Project - action #104619: openqa_from_containers needs adapted post_fail_hook (was: tests fails due to openSUSE mirror problems with can't locate Mojo/Base.pm in INC in script/client)Resolvedokurz2021-12-29

Actions
Actions #1

Updated by tinita about 2 years ago

I just looked into https://github.com/os-autoinst/os-autoinst/actions/workflows/ci_extended.yml and this problem started apparently on December 13.
Just that we usually don't see it in pull requests because it is only executed on push events, where only the repo admin(s) get a notification.

Actions #2

Updated by okurz about 2 years ago

  • Category set to Regressions/Crashes
  • Status changed from New to Blocked
  • Assignee set to okurz
  • Priority changed from Normal to Low
  • Target version set to Ready
Actions #3

Updated by okurz about 2 years ago

Also see https://suse.slack.com/archives/C028VS8TM2B/p1640669383254300 and https://gist.github.com/luc14n0/1a0b36badf5c3ce1304ff09c3475a05c and https://github.com/openSUSE/zypper/issues/399

TL;DR: Might be a curl regression, investigation is ongoing. Suggested workaround is to use dnf with a high number of retries configured replacing zypper.

Actions #4

Updated by okurz about 2 years ago

  • Related to action #104619: openqa_from_containers needs adapted post_fail_hook (was: tests fails due to openSUSE mirror problems with can't locate Mojo/Base.pm in INC in script/client) added
Actions #5

Updated by okurz about 2 years ago

https://github.com/openSUSE/zypper/issues/399#issuecomment-1010465696 confirms that the main issue seems to be a curl regression or change of behaviour.

Actions #6

Updated by okurz almost 2 years ago

  • Status changed from Blocked to Resolved

mirror infrastructure has improved since then so currently less or no problems. This can re-appear anytime as zypper is still mediocre at handling retries, see the related issues on github.

Actions

Also available in: Atom PDF