Project

General

Profile

action #101941

[qe-core] test fails in libreoffice_recent_documents

Added by mgrifalconi 3 months ago. Updated about 1 month ago.

Status:
Resolved
Priority:
High
Assignee:
Category:
Bugs in existing tests
Target version:
Start date:
2021-11-04
Due date:
% Done:

0%

Estimated time:
Difficulty:

Description

Observation

Cursor stay visible and causes the needle to fail. We could either understand why the cursor now appears and/or decrease the needle % for the check.

openQA test in scenario sle-15-SP2-Desktop-DVD-Updates-x86_64-qam-regression-documentation@64bit fails in
libreoffice_recent_documents

Test suite description

Testsuite maintained at https://gitlab.suse.de/qa-maintenance/qam-openqa-yml.

Reproducible

Fails since (at least) Build 20211104-1

Expected result

Last good: 20211103-1 (or more recent)

Further details

Always latest result in this scenario: latest

History

#1 Updated by mgrifalconi 3 months ago

#2 Updated by dzedro 3 months ago

There was always mouse_hide(200); but I guess it was broken init_desktop_runner called by x11_start_program ?

Pass

[2021-11-03T06:07:49.489085+01:00] [debug] <<< testapi::mouse_hide(border_offset=200)
[2021-11-03T06:07:49.489693+01:00] [debug] send_pointer_event 0, 1018, 762, 1
[2021-11-03T06:07:49.489861+01:00] [debug] mouse_move 1023, 767
[2021-11-03T06:07:49.489914+01:00] [debug] send_pointer_event 0, 1023, 767, 1

Fail

[2021-11-04T05:29:16.002709+01:00] [debug] <<< testapi::mouse_hide(border_offset=200)
[2021-11-04T05:29:16.003239+01:00] [debug] mouse_move 823, 567
[2021-11-04T05:29:16.003325+01:00] [debug] send_pointer_event 0, 823, 567, 1

https://github.com/os-autoinst/os-autoinst-distri-opensuse/pull/13624

#3 Updated by tjyrinki_suse about 2 months ago

  • Status changed from New to Resolved
  • Assignee set to dzedro

#4 Updated by szarate about 1 month ago

  • Target version set to QE-Core: Ready

Also available in: Atom PDF