Project

General

Profile

action #98817

[qe-core] Tomcat test is running a full blown installation

Added by szarate 11 months ago. Updated 10 months ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
Bugs in existing tests
Target version:
Start date:
Due date:
% Done:

0%

Estimated time:
Difficulty:

Description

This ticket was originally about a failing test, but the test now passes and the original ticket also mentioned the core problem of doing a full SLE installation for a single test.

Acceptance Criteria

AC1: Reuse an existing HDD for Tomcat test instead of doing a full installation

Original failing test description

Observation

openQA test in scenario sle-15-SP4-Online-x86_64-tomcat@64bit fails in
tomcat

Switch tomcat test (where possible) to use an already existing HDD image.

Test suite description

Maintainer: zluo add tomcat to SLE15-SP3

Reproducible

Fails since (at least) Build 31.2

Expected result

Last good: 29.1 (or more recent)

Further details

Always latest result in this scenario: latest


Related issues

Related to openQA Tests - coordination #95935: [epic][qe-core] Limit installation tests by depending more on the create_hdd_* jobs.New

Related to openQA Tests - action #99033: [qe-core][qem] test fails in tomcatResolved

History

#1 Updated by szarate 11 months ago

  • Related to coordination #95935: [epic][qe-core] Limit installation tests by depending more on the create_hdd_* jobs. added

#2 Updated by tjyrinki_suse 11 months ago

  • Related to action #99033: [qe-core][qem] test fails in tomcat added

#3 Updated by tjyrinki_suse 10 months ago

  • Subject changed from [qe-core] test fails in tomcat - Tomcat test is running a full blown installation to [qe-core] Tomcat test is running a full blown installation
  • Description updated (diff)
  • Status changed from New to Workable
  • Target version set to QE-Core: Ready
  • Start date deleted (2021-09-17)
  • Parent task set to #97514

#4 Updated by zluo 10 months ago

  • Status changed from Workable to In Progress
  • Assignee set to zluo

take over.

#6 Updated by zluo 10 months ago

  • Status changed from In Progress to Resolved

https://openqa.suse.de/tests/7369657# shows yaml schedule is in place however this failed because of issue reported in #96611.

But this is a different issue, investigating and close this ticket.

Also available in: Atom PDF