Project

General

Profile

action #97004

[yast] mru-install-minimal-with-addons boots to desktop instead of console

Added by mgrifalconi 3 months ago. Updated 3 months ago.

Status:
Resolved
Priority:
Urgent
Assignee:
Category:
Bugs in existing tests
Target version:
-
Start date:
2021-08-17
Due date:
% Done:

0%

Estimated time:
Difficulty:

Description

Observation

Multiple tests are likely affected by this. The following is one example. Please see in the comments more info about the yast problem.

openQA test in scenario sle-15-SP3-Server-DVD-Updates-x86_64-mau-qa_kernel_kexec@64bit fails in
kernel_kexec

Test suite description

Reproducible

Fails since (at least) Build 20210813-1

Expected result

Last good: 20210805-1 (or more recent)

Further details

Always latest result in this scenario: latest


Related issues

Related to openQA Tests - action #97007: [qa-core] test fails in dracut_enhancedBlocked2021-08-17

History

#1 Updated by pcervinka 3 months ago

  • Subject changed from [kernel] test fails in kernel_kexec to Test fails in kernel_kexec

It is image preparation issue in parent job, image now boots to desktop instead of console.
https://openqa.suse.de/tests/6867184#step/first_boot/1

Last boot to console happened in build 20210805-1 https://openqa.suse.de/tests/6652905#step/first_boot/1 .
It started to boot to desktop 20210806-1 and it was failing that time and someone fixed it in bad way.

#2 Updated by mgrifalconi 3 months ago

  • Subject changed from Test fails in kernel_kexec to [qe-core] Test fails in kernel_kexec

#3 Updated by pcervinka 3 months ago

Incorrect needle first_boot-emergency-mode-20210813 which matches desktop was created:

commit b8743d420902d48ec87d76d9155af29e8074fc14
Author:
Date: Fri Aug 13 15:29:37 2021 +0200
first_boot-emergency-mode-20210813 for sle-15-SP3-Server-DVD-Updates-x86_64-Build20210813-1-mru-install-minimal-with-addons@64bit

#4 Updated by pcervinka 3 months ago

  • Subject changed from [qe-core] Test fails in kernel_kexec to [qe-core] mru-install-minimal-with-addons boots to desktop instead if console

We need to check why image is booting to desktop since build 20210806-1, it is incorrect behavior, it should boot to console.

#5 Updated by pcervinka 3 months ago

  • Subject changed from [qe-core] mru-install-minimal-with-addons boots to desktop instead if console to [qe-core] mru-install-minimal-with-addons boots to desktop instead of console

#6 Updated by punkioudi 3 months ago

  • Related to action #97007: [qa-core] test fails in dracut_enhanced added

#7 Updated by mgrifalconi 3 months ago

From Martin: https://chat.suse.de/channel/kernel-qa?msg=useRpqKnDoBut6x6W

The boot failure is caused by YaST bug. When the test selects the X Window System in module selection, the module list does not scroll so the selected item is invisible and the needle fails to match:
https://openqa.suse.de/tests/6867184#step/select_patterns/57

This is what the screenshot above should look like: https://openqa.suse.de/tests/6652905#step/select_patterns/57

I strongly recommend changing the select_patterns module to either match a selected item, or an unselected one. If it doesn't find either, it should fail.

#8 Updated by mgrifalconi 3 months ago

  • Priority changed from Normal to Urgent

#9 Updated by mgrifalconi 3 months ago

  • Description updated (diff)

#10 Updated by mgrifalconi 3 months ago

  • Subject changed from [qe-core] mru-install-minimal-with-addons boots to desktop instead of console to [yast] mru-install-minimal-with-addons boots to desktop instead of console

#12 Updated by pcervinka 3 months ago

PR for kexec to use serial terminal https://github.com/os-autoinst/os-autoinst-distri-opensuse/pull/13088 to avoid issues caused by incorrect installation.

#14 Updated by JERiveraMoya 3 months ago

  • Status changed from New to Feedback

#15 Updated by JERiveraMoya 3 months ago

  • Status changed from Feedback to Resolved
  • Assignee set to JERiveraMoya

Also available in: Atom PDF