Project

General

Profile

coordination #93501

openqa-bootstrap fails to guess a value for platform on Leap 15.3

Added by simotek about 2 months ago. Updated about 1 month ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
Concrete Bugs
Target version:
Start date:
2021-06-07
Due date:
% Done:

0%

Estimated time:
Difficulty:

Description

Observation

Unable to guess a value for .
Please use obs:///
Example: obs://server:http/openSUSE_11.3

/usr/share/openqa/script/openqa-bootstrap --help also gives no clear example on how to do this.

Steps to reproduce

for i in http://download.opensuse.org/repositories/devel:openQA/openSUSE_Leap_15.3 https://download.opensuse.org/repositories/devel:/openQA:/Leap:/15.3/openSUSE_Leap_15.3/; do zypper ar -p 95 $i; done
zypper -n in openQA-bootstrap
/usr/share/openqa/script/openqa-bootstrap

Workaround

Install openQA manually following http://open.qa/docs/#_installation or try on a Tumbleweed machine without any additional repositories as this is also a setup that is automatically tested for each Tumbleweed snapshot.


Related issues

Copied to openQA Project - coordination #93609: [epic] openqa-bootstrap support on Leap 15.3Blocked2021-06-072021-08-31

History

#1 Updated by okurz about 2 months ago

#2 Updated by okurz about 2 months ago

  • Tracker changed from action to coordination
  • Description updated (diff)
  • Status changed from New to Feedback
  • Assignee set to okurz
  • Target version set to Ready

There seem to be multiple problems with openqa-bootstrap on Leap 15.3 . I created #93609 to fix the problems I have seen and improve the overall situation. However I could not reproduce the problem Unable to guess a value for .. I tried for example

podman run --rm -it registry.opensuse.org/opensuse/leap:15.3 sh -c 'zypper -n in curl && curl -s https://raw.githubusercontent.com/os-autoinst/openQA/master/script/openqa-bootstrap | bash -x'

as well as

podman run --rm -it registry.opensuse.org/opensuse/leap:15.3 sh -c 'zypper -n in openQA-bootstrap && /usr/share/openqa/script/openqa-bootstrap'

simotek do you have "steps to reproduce" for me?

#3 Updated by simotek about 2 months ago

I followed the installation instructions for bare metal, on my leap machine I have the following repo's enabled

http://download.opensuse.org/repositories/devel:openQA/openSUSE_Leap_15.3
https://download.opensuse.org/repositories/devel:/openQA:/Leap:/15.3/openSUSE_Leap_15.3/

I then have openQA-bootstrap installed from devel:openQA and hit the failure there.

#4 Updated by okurz about 2 months ago

  • Description updated (diff)
  • Status changed from Feedback to Workable
  • Assignee deleted (okurz)

ok, I see. thx. Updated "steps to reproduce" in the ticket description.

As workaround you can either install openQA manually following http://open.qa/docs/#_installation or try on a Tumbleweed machine without any additional repositories as this is also a setup that is automatically tested for each Tumbleweed snapshot.

#5 Updated by mkittler about 1 month ago

  • Assignee set to mkittler

#6 Updated by mkittler about 1 month ago

  • Status changed from Workable to Feedback

#7 Updated by cdywan about 1 month ago

  • This almost looks like a duplicate of #93609
  • As this is a bug report there's no need for tests. But the epic is actually wrongly posing as a bug report and should be more generic.
  • Hypothetical ACs:
    • AC1: It's possible to run openqa-bootstrap on Leap 15.3

#8 Updated by mkittler about 1 month ago

  • Status changed from Feedback to Resolved

simotek The PR has been merged so the issue with the repository URL should be fixed now. I'm marking this ticket as resolved. okurz created another ticket (#93609) with more explicit acceptance criteria anyways so if anything is missing you can also comment there.

Also available in: Atom PDF