Project

General

Profile

action #93080

[qe-core][qem][maint][postfix] test fails in 1_postfix on SLE15-SP3

Added by vsvecova 8 months ago. Updated 8 months ago.

Status:
Resolved
Priority:
High
Assignee:
-
Category:
Bugs in existing tests
Target version:
-
Start date:
Due date:
% Done:

0%

Estimated time:
Difficulty:

Description

1_postfix fails on SLE15-SP3

Observation

openQA test in scenario sle-15-SP3-Server-DVD-Updates-x86_64-mau-qa_userspace_postfix@64bit fails in
1_postfix

It has never passed on 15-SP3. The testcases send, send_to_nonexistent, send_attachment and send_to_alias are failing as seen as QADB entry http://qadb2.suse.de/qadb/result.php?submission_id=3156836&search=1&testsuite_id=164

Logs attached also here. Somehow at least required files are missing.

It would seem like this test suite got updated in 2019 https://build.suse.de/package/show/QA:Head/qa_test_postfix (also in 2020 but says no source changes)

Successful run on 15-SP2 looks like this http://qadb2.suse.de/qadb/submission.php?submission_id=3158364

See https://chat.suse.de/channel/testing/thread/TqjxT7RQF3XJacKvB

It is developed in git at https://github.com/SUSE/qa-testsuites

Test suite description

Reproducible

Fails since (at least) Build 20210505-1

Expected result

Last good: (unknown) (or more recent)

Further details

Always latest result in this scenario: latest

See https://chat.suse.de/channel/testing/thread/TqjxT7RQF3XJacKvB for background related to these old tests.

Acceptance Criteria

AC1: Either test passes on 15-SP3, is deemed ok to disable, or a product bug is filed. Requires figuring out whether the change is intended upstream behavior change, a test (environment) problem or a product problem. The test is very old, and it can be evaluated whether it's worthsome to keep it enabled.
AC2: If test is disabled, contact PO or file a new ticket about implementing a new test for the utility.

send (202 Bytes) send tjyrinki_suse, 2021-05-26 06:31
send_attachment (1.14 KB) send_attachment tjyrinki_suse, 2021-05-26 06:31
send_to_alias (565 Bytes) send_to_alias tjyrinki_suse, 2021-05-26 06:31
send_to_nonexistent (275 Bytes) send_to_nonexistent tjyrinki_suse, 2021-05-26 06:31

History

#1 Updated by tjyrinki_suse 8 months ago

  • Subject changed from [qem][maint][postfix] test fails in 1_postfix on SLE15-SP3 to [qe-core][qem][maint][postfix] test fails in 1_postfix on SLE15-SP3
  • Status changed from New to Workable
  • Priority changed from Normal to High
  • Start date deleted (2021-05-25)

#2 Updated by tjyrinki_suse 8 months ago

  • Description updated (diff)

#4 Updated by tjyrinki_suse 8 months ago

  • Description updated (diff)

#5 Updated by tjyrinki_suse 8 months ago

  • Description updated (diff)

#7 Updated by tjyrinki_suse 8 months ago

  • Description updated (diff)

#8 Updated by tjyrinki_suse 8 months ago

  • Description updated (diff)

#10 Updated by tjyrinki_suse 8 months ago

  • Status changed from Workable to Resolved

Also available in: Atom PDF