Project

General

Profile

action #91461

Test is missing webui results and fail despite all tests passed

Added by dzedro 3 months ago. Updated 3 months ago.

Status:
Resolved
Priority:
Urgent
Assignee:
Category:
Concrete Bugs
Target version:
Start date:
2021-04-21
Due date:
2021-05-06
% Done:

0%

Estimated time:
Difficulty:

Description

All tests finished properly but test ended with Result: failed
There are many such tests e.g. https://openqa.suse.de/tests/5867468

[2021-04-21T08:04:52.107 CEST] [debug] ||| finished libreoffice_open_specified_file x11/libreoffice at 2021-04-21 06:04:52 (372 s)
[2021-04-21T08:04:52.111 CEST] [debug] stopping autotest process 9832
[2021-04-21T08:04:52.121 CEST] [debug] [autotest] process exited: 0
[2021-04-21T08:04:52.222 CEST] [debug] done with autotest process
[2021-04-21T08:04:52.222 CEST] [debug] stopping command server 9821 because test execution ended
[2021-04-21T08:04:52.222 CEST] [debug] isotovideo: informing websocket clients before stopping command server: http://127.0.0.1:20123/vlcUXvfHIQWHNouy/broadcast
[2021-04-21T08:04:52.238 CEST] [debug] commands process exited: 0
[2021-04-21T08:04:52.338 CEST] [debug] done with command server
[2021-04-21T08:04:52.338 CEST] [debug] isotovideo done
[2021-04-21T08:04:52.339 CEST] [debug] EVENT {"data":{"path":"\/machine\/peripheral-anon\/device[2]\/virtio-backend"},"event":"NIC_RX_FILTER_CHANGED","timestamp":{"microseconds":825742,"seconds":1618983499}}
[2021-04-21T08:04:52.339 CEST] [debug] EVENT {"data":{"client":{"family":"ipv4","host":"127.0.0.1","service":"47856","websocket":false},"server":{"auth":"none","family":"ipv4","host":"0.0.0.0","service":"6002","websocket":false}},"event":"VNC_DISCONNECTED","timestamp":{"microseconds":734600,"seconds":1618984629}}
[2021-04-21T08:04:52.340 CEST] [debug] EVENT {"data":{"client":{"family":"ipv4","host":"127.0.0.1","service":"40970","websocket":false},"server":{"auth":"none","family":"ipv4","host":"0.0.0.0","service":"6002","websocket":false}},"event":"VNC_CONNECTED","timestamp":{"microseconds":735384,"seconds":1618984629}}
[2021-04-21T08:04:52.340 CEST] [debug] EVENT {"data":{"client":{"family":"ipv4","host":"127.0.0.1","service":"40970","websocket":false},"server":{"auth":"none","family":"ipv4","host":"0.0.0.0","service":"6002","websocket":false}},"event":"VNC_INITIALIZED","timestamp":{"microseconds":738847,"seconds":1618984629}}
[2021-04-21T08:04:52.340 CEST] [debug] QEMU status is not 'shutdown', it is 'running'
[2021-04-21T08:04:52.341 CEST] [debug] backend shutdown state: 
[2021-04-21T08:04:52.341 CEST] [info] ::: OpenQA::Qemu::Proc::save_state: Saving QEMU state to qemu_state.json
[2021-04-21T08:04:53.402 CEST] [debug] Passing remaining frames to the video encoder
[2021-04-21T08:04:53.406 CEST] [debug] Waiting for video encoder to finalize the video
[2021-04-21T08:04:53.406 CEST] [debug] The built-in video encoder (pid 10088) terminated
[2021-04-21T08:04:53.407 CEST] [debug] QEMU: qemu-system-x86_64: terminating on signal 15 from pid 9961 (/usr/bin/isotovideo: backen)
[2021-04-21T08:04:53.407 CEST] [debug] sending magic and exit
[2021-04-21T08:04:53.408 CEST] [debug] received magic close
[2021-04-21T08:04:53.442 CEST] [debug] backend process exited: 0
[2021-04-21T08:04:53.542 CEST] [debug] stopping backend process 9961
[2021-04-21T08:04:53.543 CEST] [debug] done with backend process
9816: EXIT 0
[2021-04-21T08:04:53.0609 CEST] [info] [pid:7312] Isotovideo exit status: 0
[2021-04-21T08:04:53.0643 CEST] [info] [pid:7312] +++ worker notes +++
[2021-04-21T08:04:53.0643 CEST] [info] [pid:7312] End time: 2021-04-21 06:04:53
[2021-04-21T08:04:53.0643 CEST] [info] [pid:7312] Result: done
[2021-04-21T08:04:53.0653 CEST] [info] [pid:26923] Uploading vars.json
[2021-04-21T08:04:53.0694 CEST] [info] [pid:26923] Uploading autoinst-log.txt

Related issues

Related to openQA Project - action #90152: module results missing on quick job (on auto-restarting worker)Resolved2021-03-16

Copied to openQA Project - action #91494: [epic] work on #90152 caused deployment problem and no monitoring alertNew2021-04-21

History

#1 Updated by dzedro 3 months ago

  • Description updated (diff)

#2 Updated by okurz 3 months ago

  • Related to action #90152: module results missing on quick job (on auto-restarting worker) added

#3 Updated by okurz 3 months ago

  • Project changed from openQA Infrastructure to openQA Project
  • Category set to Concrete Bugs
  • Target version set to Ready

Hi dzedro, could you please fill the details according to https://progress.opensuse.org/projects/openqav3/wiki/#Defects , e.g. how often you saw this or just once, steps to reproduce, link to latest, etc.

#4 Updated by mkittler 3 months ago

  • Assignee set to mkittler

#5 Updated by okurz 3 months ago

  • Priority changed from Normal to Urgent

Triggered a rollback of OSD.

mkittler please also rollback o3.

Created https://github.com/os-autoinst/openQA/pull/3854 with a revert of https://github.com/os-autoinst/openQA/pull/3849 which we consider the likely cause

#6 Updated by okurz 3 months ago

  • Copied to action #91494: [epic] work on #90152 caused deployment problem and no monitoring alert added

#8 Updated by openqa_review 3 months ago

  • Due date set to 2021-05-06

Setting due date based on mean cycle time of SUSE QE Tools

#9 Updated by mkittler 3 months ago

  • Status changed from New to Feedback

I deployed the fix on o3 workers yesterday and haven't seen any of such failures anymore (by checking some random failures). I would assume the fix worked.

#10 Updated by mkittler 3 months ago

  • Status changed from Feedback to Resolved

The fixed version has been deployed on OSD since Friday. I couldn't find such failures anymore after a brief check so I suppose it works now again.

Also available in: Atom PDF