Project

General

Profile

Actions

action #91275

closed

[qe-core][qem] test fails in oomath

Added by osukup almost 3 years ago. Updated over 2 years ago.

Status:
Resolved
Priority:
Urgent
Assignee:
Category:
Bugs in existing tests
Target version:
Start date:
2021-04-16
Due date:
% Done:

100%

Estimated time:
Difficulty:

Description

Observation

looks like oomath changed behaviour when closing unsaved documents.

openQA test in scenario sle-15-SP2-Server-DVD-Updates-x86_64-qam-allpatterns+addons@64bit fails in
oomath

Test suite description

All modules defined in SCC_ADDONS
#20201124: added chrony-pool-openSUSE due to 15SP1 QU5 failure https://openqa.suse.de/tests/5060854

Reproducible

Fails since (at least) Build 20210415-1

Expected result

Last good: 20210414-1 (or more recent)

Further details

Always latest result in this scenario: latest

Actions #1

Updated by coolo almost 3 years ago

  • Priority changed from Normal to Urgent
Actions #2

Updated by coolo almost 3 years ago

This is due to https://build.suse.de/request/show/239369 being released without aligning the test.

Actions #3

Updated by dzedro almost 3 years ago

coolo wrote:

This is due to https://build.suse.de/request/show/239369 being released without aligning the test.

Isn't that bug ? oomath should ask if you want to save the document, same as oowriter does.

Actions #4

Updated by dzedro almost 3 years ago

  • Status changed from New to In Progress
  • Assignee set to dzedro

TW does still ask https://openqa.opensuse.org/tests/1704140#step/oomath/5
I will open bug for it and update code.

Actions #5

Updated by coolo almost 3 years ago

dzedro wrote:

coolo wrote:

This is due to https://build.suse.de/request/show/239369 being released without aligning the test.

Isn't that bug ? oomath should ask if you want to save the document, same as oowriter does.

You're not helping the arguments if QEM even released a regression :(

Actions #6

Updated by tjyrinki_suse almost 3 years ago

  • Subject changed from [qem] test fails in oomath to [qe-core][qem] test fails in oomath
Actions #7

Updated by dzedro almost 3 years ago

coolo wrote:

dzedro wrote:

coolo wrote:

This is due to https://build.suse.de/request/show/239369 being released without aligning the test.

Isn't that bug ? oomath should ask if you want to save the document, same as oowriter does.

You're not helping the arguments if QEM even released a regression :(

https://www.youtube.com/watch?v=VFb1-NpH9vw&t=14s :)

Actions #8

Updated by dzedro almost 3 years ago

Georg pointed me to issue which should not happen!
RR log [1] does reference osd link which does not contain the update.
This would be at least one reason why QEM released regression.

[1] https://qam.suse.de/testreports/SUSE:Maintenance:19067:239369/log

Actions #9

Updated by dzedro almost 3 years ago

  • Status changed from In Progress to Blocked
Actions #10

Updated by dzedro over 2 years ago

  • Status changed from Blocked to In Progress
Actions #11

Updated by dzedro over 2 years ago

  • Status changed from In Progress to Resolved
  • % Done changed from 0 to 100

Bug is fixed and workaround removed.

Actions #12

Updated by szarate over 2 years ago

  • Target version set to QE-Core: Ready
Actions

Also available in: Atom PDF