Project

General

Profile

action #89966

[qe-core] Test kernel_multipath tries to install fixed version of mdadm

Added by pcervinka 6 months ago. Updated 6 months ago.

Status:
Resolved
Priority:
Immediate
Assignee:
Category:
Bugs in existing tests
Target version:
Start date:
2021-03-12
Due date:
% Done:

100%

Estimated time:
Difficulty:

Description

Observation

openQA test in scenario sle-15-SP3-Online-x86_64-qa_kernel_multipath@64bit fails in
kernel_multipath

Test suite description

Maintainer: pcervinka@suse.com

Reproducible

Fails since (at least) Build 160.2

Expected result

Last good: 159.1 (or more recent)

Further details

Always latest result in this scenario: latest

# Test died: 'zypper -n in -f mdadm-4.1-15.20.1' failed with code 104 (ZYPPER_EXIT_INF_CAP_NOT_FOUND)

Related zypper logs:
2021-03-12 02:03:10 <1> susetest(7447) [zypper:req++] SolverRequester.cc(pkg_spec_to_poolquery):76 query: kinds: package 
2021-03-12 02:03:10 <1> susetest(7447) [zypper:req++] SolverRequester.cc(pkg_spec_to_poolquery):76 repos: ALL
2021-03-12 02:03:10 <1> susetest(7447) [zypper:req++] SolverRequester.cc(pkg_spec_to_poolquery):76 version: ANY 
2021-03-12 02:03:10 <1> susetest(7447) [zypper:req++] SolverRequester.cc(pkg_spec_to_poolquery):76 status: ALL
2021-03-12 02:03:10 <1> susetest(7447) [zypper:req++] SolverRequester.cc(pkg_spec_to_poolquery):76 string match flags: GLOB|SKIP_KIND
2021-03-12 02:03:10 <1> susetest(7447) [zypper:req++] SolverRequester.cc(pkg_spec_to_poolquery):76 strings: 
2021-03-12 02:03:10 <1> susetest(7447) [zypper:req++] SolverRequester.cc(pkg_spec_to_poolquery):76 attributes: 
2021-03-12 02:03:10 <1> susetest(7447) [zypper:req++] SolverRequester.cc(pkg_spec_to_poolquery):76 predicated: 
2021-03-12 02:03:10 <1> susetest(7447) [zypper:req++] SolverRequester.cc(pkg_spec_to_poolquery):76 * solvable:name: "mdadm"{OTHER(15)} +(SolvableRange == 4.1-15.20.1 "")
2021-03-12 02:03:10 <1> susetest(7447) [zypper:req++] SolverRequester.cc(pkg_spec_to_poolquery):76 last attribute matcher compiled: 
2021-03-12 02:03:10 <1> susetest(7447) [zypper:req++] SolverRequester.cc(pkg_spec_to_poolquery):76 not yet compiled
2021-03-12 02:03:10 <1> susetest(7447) [zypper:req++] SolverRequester.cc(pkg_spec_to_poolquery):76 
2021-03-12 02:03:10 <2> susetest(7447) [zypper:req] SolverRequester.cc(install):310 mdadm-4.1-15.20.1 cap:mdadm == 4.1-15.20.1 (mod) not found
2021-03-12 02:03:10 <5> susetest(7447) [zypp] Exception.cc(log):166 installremove.cc(handleFeedback):41 THROW:    name or capability not found
2021-03-12 02:03:10 <5> susetest(7447) [zypp] Exception.cc(log):166 basecommand.cc(run):274 CAUGHT:   name or capability not found at sle/lib/utils.pm line 564.

Caused by https://github.com/os-autoinst/os-autoinst-distri-opensuse/pull/12104

History

#1 Updated by pcervinka 6 months ago

  • Subject changed from [qe-core] Test kernel_multipath tries to install mdadm to [qe-core] Test kernel_multipath tries to install fixed version of mdadm

#2 Updated by pcervinka 6 months ago

  • Priority changed from Normal to Immediate

mdadm version in 15-sp3 is:

susetest:~ # zypper se -s mdadm
Refreshing service 'Basesystem_Module_15_SP3_x86_64'.
Refreshing service 'Desktop_Applications_Module_15_SP3_x86_64'.
Refreshing service 'Development_Tools_Module_15_SP3_x86_64'.
Refreshing service 'Python_2_Module_15_SP3_x86_64'.
Refreshing service 'SUSE_Linux_Enterprise_Server_15_SP3_x86_64'.
Refreshing service 'Server_Applications_Module_15_SP3_x86_64'.
Loading repository data...
Reading installed packages...

S | Name  | Type    | Version   | Arch   | Repository
--+-------+---------+-----------+--------+------------------------------------
i | mdadm | package | 4.1-21.19 | x86_64 | SLE-Module-Basesystem15-SP3-Pool
i | mdadm | package | 4.1-21.19 | x86_64 | SLE-Module-Basesystem15-SP3-Updates

#3 Updated by geor 6 months ago

  • Status changed from New to In Progress
  • Assignee set to geor

#4 Updated by geor 6 months ago

  • Status changed from In Progress to Resolved
  • % Done changed from 0 to 100

PR merged

#5 Updated by mgrifalconi 6 months ago

  • Status changed from Resolved to In Progress

Hello, sorry for jumping in!

The PR seems to have broken a few other tests and we are going to revert it to see if the issues get fixed. More info on the original PR

#6 Updated by dzedro 6 months ago

First PR should better be reverted, the breaking chain just continues.

#7 Updated by geor 6 months ago

  • Status changed from In Progress to Resolved
  • Target version set to QE-Core: Ready

Also available in: Atom PDF