Project

General

Profile

action #81310

[sporadic][timeboxed:10h] test fails in mediacheck on svirt uefi

Added by syrianidou_sofia 10 months ago. Updated 9 months ago.

Status:
Resolved
Priority:
Normal
Assignee:
Target version:
Start date:
2020-12-23
Due date:
% Done:

0%

Estimated time:

Description

Observation

We need to investigate what happens, as we already saw some issues with unexpected reboots of the VMs.

@Joaquin should be able to help to find the bug entry ;)

It seems like the function "select_bootmenu_more" doesn't select the expected item in the grub menu. For UEFI, there are some additional steps in the function:

    if (get_var('UEFI')) {
        send_key 'e';
        send_key 'down' for (1 .. 4);
        send_key 'end';
        # newer versions of qemu on arch automatically add 'console=ttyS0' so
        # we would end up nowhere. Setting console parameter explicitly
        # See https://bugzilla.suse.com/show_bug.cgi?id=1032335 for details
        push @params, 'console=tty1' if get_var('MACHINE') =~ /aarch64/;
        # Hyper-V defaults to 1280x1024, we need to fix it here
        push @params, get_hyperv_fb_video_resolution if check_var('VIRSH_VMM_FAMILY', 'hyperv');
        type_boot_parameters(" @params ");
        save_screenshot;
        send_key 'f10';
    }       

All look good until f10 is pressed. The mediacheck is supposed to start at this point, but instead, the grub menu appears.

related ticket : https://progress.opensuse.org/issues/70228

openQA test in scenario sle-15-SP3-Online-x86_64-mediacheck@svirt-hyperv-uefi fails in
mediacheck

Test suite description

Select the mediacheck option from the installation menu and assert a successful media check.

Reproducible

Fails since (at least) Build 114.1 (current job)

Expected result

Last good: 109.1 (or more recent)

Further details

Always latest result in this scenario: latest

History

#1 Updated by syrianidou_sofia 10 months ago

  • Project changed from openQA Tests to qe-yast
  • Category deleted (Bugs in existing tests)

#2 Updated by riafarov 10 months ago

  • Target version set to future

#3 Updated by riafarov 10 months ago

  • Subject changed from [sporadic] test fails in mediacheck on svirt uefi to [sporadic][timeboxed:10h] test fails in mediacheck on svirt uefi
  • Description updated (diff)
  • Status changed from New to Workable

#4 Updated by oorlov 9 months ago

  • Status changed from Workable to In Progress
  • Assignee set to oorlov

#5 Updated by oorlov 9 months ago

10933

I've investigated the issue and unfortunately it is not a problem of a test design. After hitting F10, hyperv seems to be crashed and just restarts again. I've noticed that on video from installation, "Hyper V" splash screen appears after the F10 is pressed Please, see the screenshot "mediacheck_hyperv_uefi_crash.png". I've found similar issue https://bugzilla.suse.com/show_bug.cgi?id=1178562.

So, this looks like Hyper V-related issue.

#6 Updated by oorlov 9 months ago

  • Status changed from Feedback to Resolved

Also available in: Atom PDF