Project

General

Profile

action #80840

coordination #76861: Adjust test code for the new partitioner UI

Implement setup for libyui REST API in the running system

Added by riafarov 10 months ago. Updated 9 months ago.

Status:
Closed
Priority:
Normal
Assignee:
Target version:
SUSE QA - SLE 15 SP3
Start date:
2020-12-08
Due date:
% Done:

0%

Estimated time:

Description

We have agreed to implement part to setup libyui REST API in the installed system.

It should require same steps as in installer, namely port forwarding on qemu + correct env parameters.

See #80272 as an example, as it's the scenario where we need this setup.

Acceptance criteria

  1. libyui REST API setup works in the installed system on qemu backend where yast2_storage_ng test module was scheduled

Related issues

Related to qe-yast - coordination #81028: [epic] Test YaST modules with OOP framework with yui-rest-client and validate its configurationIn Progress2021-02-01

Blocks qe-yast - action #80272: Adapt yast2_expert_partitioner (before: yast2_storage_ng) in ppc64le to use libyuiClosed2020-11-24

History

#1 Updated by riafarov 10 months ago

  • Blocks action #80272: Adapt yast2_expert_partitioner (before: yast2_storage_ng) in ppc64le to use libyui added

#2 Updated by riafarov 10 months ago

  • Description updated (diff)
  • Assignee deleted (riafarov)

#3 Updated by JERiveraMoya 10 months ago

  • Related to coordination #81028: [epic] Test YaST modules with OOP framework with yui-rest-client and validate its configuration added

#4 Updated by riafarov 10 months ago

  • Description updated (diff)
  • Status changed from New to Workable

#5 Updated by JERiveraMoya 10 months ago

  • Status changed from Workable to In Progress

#6 Updated by JERiveraMoya 10 months ago

  • Assignee set to JERiveraMoya

#8 Updated by JERiveraMoya 9 months ago

  • Status changed from In Progress to Feedback

#9 Updated by oorlov 9 months ago

Seems like the timeout, that is used in HttpClient is not enough sometimes (it failed on ppc64le with 2Gb RAM: https://openqa.suse.de/tests/5286209#step/yast2_expert_partitioner/15). Seems like the system is too slow when only 2Gb is used for RAM.

I'm not sure though if timeout increasing can help, or it is more complex issue. Should we include this issue to the current ticket or create another for investigations it's up to you.

#10 Updated by JERiveraMoya 9 months ago

oorlov wrote:

Seems like the timeout, that is used in HttpClient is not enough sometimes (it failed on ppc64le with 2Gb RAM: https://openqa.suse.de/tests/5286209#step/yast2_expert_partitioner/15). Seems like the system is too slow when only 2Gb is used for RAM.

I'm not sure though if timeout increasing can help, or it is more complex issue. Should we include this issue to the current ticket or create another for investigations it's up to you.

we have https://progress.opensuse.org/issues/80272 to act on ppc64le.

#14 Updated by JERiveraMoya 9 months ago

  • Status changed from Feedback to Closed

Also available in: Atom PDF