Project

General

Profile

action #78031

[qe-core] add golang regression testing

Added by hrommel1 6 months ago. Updated 5 months ago.

Status:
Resolved
Priority:
High
Assignee:
Category:
New test
Target version:
-
Start date:
Due date:
% Done:

0%

Estimated time:
Difficulty:

Description

Currently, every 6 month a new version of go(lang) is added to the common code base.
The latest two versions are fully supported on SLE.
Older versions drop out of support and don't need to be tested anymore.

(see https://confluence.suse.com/pages/viewpage.action?spaceKey=~msvec&title=Go)

References for go 1.14:

https://jira.suse.com/browse/SLE-12120
https://jira.suse.com/browse/ECO-1484

We need to add some basic test coverage for go(lang) and make sure that the latest two versions of go(lang) for each code stream are covered.

Suggestions

AC

  1. Both supported versions of Golang are tested within the same test module
  2. The mechanism to test both versions is not tied to the code but rather variables, since there are two Golang releases per year (Or the mechanism is easy enough that the modification of it can either be automated, or takes little time

History

#2 Updated by szarate 6 months ago

  • Project changed from SUSE QA tests to openQA Tests
  • Subject changed from [qe-core] to [qe-core] add golang regression testing
  • Description updated (diff)
  • Category set to New test

#3 Updated by szarate 6 months ago

  • Description updated (diff)

#4 Updated by tjyrinki_suse 6 months ago

  • Status changed from New to Workable
  • Priority changed from Normal to High
  • Start date deleted (2020-11-16)

#5 Updated by dheidler 6 months ago

  • Status changed from Workable to In Progress
  • Assignee set to dheidler

#6 Updated by dheidler 6 months ago

This would add the test for openSUSE and SLE, but I'm not sure how to schedule it properly for qam.
https://github.com/os-autoinst/os-autoinst-distri-opensuse/pull/11525

#7 Updated by dheidler 5 months ago

  • Status changed from In Progress to Feedback

#8 Updated by dheidler 5 months ago

  • Status changed from Feedback to Resolved

Also available in: Atom PDF