Project

General

Profile

action #75259

100% of powerpc tests incomplete auto_review:"(?s)Running on power8.*qemu-system-ppc64: Requested safe cache capability level not supported by kvm":retry

Added by dimstar 12 months ago. Updated 12 months ago.

Status:
Resolved
Priority:
Urgent
Assignee:
Target version:
Start date:
2020-10-25
Due date:
% Done:

0%

Estimated time:

Description

Observation

Currently, all powerpc tests end with result incomplete

E.g https://openqa.opensuse.org/tests/1448500

From the log:

[2020-10-25T08:55:26.0807 UTC] [info] +++ setup notes +++
[2020-10-25T08:55:26.0807 UTC] [info] Running on power8:6 (Linux 5.3.18-lp152.47-default #1 SMP Thu Oct 15 16:05:25 UTC 2020 (41f7396) ppc64le)
[2020-10-25T08:55:26.0810 UTC] [debug] Found ASSET_256, caching openSUSE-Tumbleweed-DVD-ppc64le-Snapshot20201024-Media.iso.sha256
[2020-10-25T08:55:26.0812 UTC] [info] Downloading openSUSE-Tumbleweed-DVD-ppc64le-Snapshot20201024-Media.iso.sha256, request #37952 sent to Cache Service
[2020-10-25T08:55:31.0853 UTC] [info] Download of openSUSE-Tumbleweed-DVD-ppc64le-Snapshot20201024-Media.iso.sha256 processed:
[info] [#37952] Cache size of "/var/lib/openqa/cache" is 600GiB, with limit 600GiB
[info] [#37952] Downloading "openSUSE-Tumbleweed-DVD-ppc64le-Snapshot20201024-Media.iso.sha256" from "http://openqa1-opensuse/tests/1448500/asset/other/openSUSE-Tumbleweed-DVD-ppc64le-Snapshot20201024-Media.iso.sha256"
[info] [#37952] Content of "/var/lib/openqa/cache/openqa1-opensuse/openSUSE-Tumbleweed-DVD-ppc64le-Snapshot20201024-Media.iso.sha256" has not changed, updating last use

[2020-10-25T08:55:31.0856 UTC] [debug] Found ISO, caching openSUSE-Tumbleweed-DVD-ppc64le-Snapshot20201024-Media.iso
[2020-10-25T08:55:31.0858 UTC] [info] Downloading openSUSE-Tumbleweed-DVD-ppc64le-Snapshot20201024-Media.iso, request #37957 sent to Cache Service
[2020-10-25T08:55:36.0899 UTC] [info] Download of openSUSE-Tumbleweed-DVD-ppc64le-Snapshot20201024-Media.iso processed:
[info] [#37957] Cache size of "/var/lib/openqa/cache" is 600GiB, with limit 600GiB
[info] [#37957] Downloading "openSUSE-Tumbleweed-DVD-ppc64le-Snapshot20201024-Media.iso" from "http://openqa1-opensuse/tests/1448500/asset/iso/openSUSE-Tumbleweed-DVD-ppc64le-Snapshot20201024-Media.iso"
[info] [#37957] Content of "/var/lib/openqa/cache/openqa1-opensuse/openSUSE-Tumbleweed-DVD-ppc64le-Snapshot20201024-Media.iso" has not changed, updating last use

[2020-10-25T08:55:36.0902 UTC] [info] Rsync from 'rsync://openqa1-opensuse/tests' to '/var/lib/openqa/cache/openqa1-opensuse', request #37961 sent to Cache Service
[2020-10-25T08:55:41.0954 UTC] [info] Output of rsync:
[info] [#37961] Calling: rsync -avHP rsync://openqa1-opensuse/tests/ --delete /var/lib/openqa/cache/openqa1-opensuse/tests/
receiving incremental file list

sent 1,713 bytes received 1,099,636 bytes 734,232.67 bytes/sec
total size is 4,532,146,856 speedup is 4,115.09

[2020-10-25T08:55:41.0954 UTC] [info] Finished to rsync tests
[2020-10-25T08:55:41.0958 UTC] [debug] +++ worker notes +++
[2020-10-25T08:55:42.377 UTC] [debug] Current version is 4.6.1603469837.f54bdeab [interface v20]
[2020-10-25T08:55:42.384 UTC] [debug] git hash in /var/lib/openqa/cache/openqa1-opensuse/tests/opensuse: c12d1da2e511d1cb87aeb302b752bc035a2c8c60
[2020-10-25T08:55:42.560 UTC] [debug] usingenv DESKTOP=kde
[2020-10-25T08:55:42.560 UTC] [debug] usingenv DISTRI=opensuse
[2020-10-25T08:55:42.560 UTC] [debug] usingenv QEMUCPU=host
[2020-10-25T08:55:42.560 UTC] [debug] usingenv QEMUCPUS=4
[2020-10-25T08:55:42.560 UTC] [debug] usingenv INSTLANG=en_US
[2020-10-25T08:55:42.560 UTC] [debug] usingenv DVD=1
[2020-10-25T08:55:42.560 UTC] [debug] usingenv KDE=1
[2020-10-25T08:55:42.560 UTC] [debug] usingenv ISO=/var/lib/openqa/pool/6/openSUSE-Tumbleweed-DVD-ppc64le-Snapshot20201024-Media.iso
[2020-10-25T08:55:42.561 UTC] [debug] usingenv ISO_MAXSIZE=4700372992
[2020-10-25T08:55:42.561 UTC] [debug] usingenv NOIMAGES=1
[2020-10-25T08:55:42.561 UTC] [debug] scheduling mediacheck tests/installation/mediacheck.pm
[2020-10-25T08:55:42.567 UTC] [info] cmdsrv: daemon reachable under http://*:20063/qL0cvoaoKR5zOTFr/
[2020-10-25T08:55:42.568 UTC] [debug] git hash in /var/lib/openqa/cache/openqa1-opensuse/tests/opensuse/products/opensuse/needles: 5482b32dfe22ba8e0376db50c26e07cc01ee56fb
[2020-10-25T08:55:42.568 UTC] [debug] init needles from /var/lib/openqa/cache/openqa1-opensuse/tests/opensuse/products/opensuse/needles
[2020-10-25T08:55:42.569 UTC] [info] Listening at "http://[::]:20063"
Web application available at http://[::]:20063
[2020-10-25T08:55:42.884 UTC] [debug] inst-console-20200224 contains inst-console twice
[2020-10-25T08:55:43.715 UTC] [debug] loaded 8201 needles
[2020-10-25T08:55:43.862 UTC] [debug] Blocking SIGTERM
[2020-10-25T08:55:43.884 UTC] [debug] Unblocking SIGTERM
[2020-10-25T08:55:43.981 UTC] [debug] Blocking SIGTERM
19934: channel_out 15, channel_in 14
[2020-10-25T08:55:44.000 UTC] [debug] Unblocking SIGTERM
19982: cmdpipe 13, rsppipe 16
[2020-10-25T08:55:44.001 UTC] [debug] started mgmt loop with pid 19982
remove_tree qemuscreenshot
[2020-10-25T08:55:44.025 UTC] [debug] qemu version detected: 4.2.1
[2020-10-25T08:55:44.026 UTC] [debug] running /usr/bin/chattr -f +C /var/lib/openqa/pool/6/raid
[2020-10-25T08:55:44.032 UTC] [debug] running /usr/bin/qemu-img info --output=json /var/lib/openqa/pool/6/openSUSE-Tumbleweed-DVD-ppc64le-Snapshot20201024-Media.iso
[2020-10-25T08:55:44.039 UTC] [debug] running /usr/bin/qemu-img create -f qcow2 /var/lib/openqa/pool/6/raid/hd0 20G
[2020-10-25T08:55:44.076 UTC] [debug] Formatting '/var/lib/openqa/pool/6/raid/hd0', fmt=qcow2 size=21474836480 cluster_size=65536 lazy_refcounts=off refcount_bits=16
[2020-10-25T08:55:44.076 UTC] [debug] running /usr/bin/qemu-img create -f qcow2 -b /var/lib/openqa/pool/6/openSUSE-Tumbleweed-DVD-ppc64le-Snapshot20201024-Media.iso /var/lib/openqa/pool/6/raid/cd0-overlay0 3745804288
[2020-10-25T08:55:44.119 UTC] [debug] Formatting '/var/lib/openqa/pool/6/raid/cd0-overlay0', fmt=qcow2 size=3745804288 backing_file=/var/lib/openqa/pool/6/openSUSE-Tumbleweed-DVD-ppc64le-Snapshot20201024-Media.iso cluster_size=65536 lazy_refcounts=off refcount_bits=16
[2020-10-25T08:55:44.120 UTC] [debug] starting: /usr/bin/qemu-system-ppc64 -g 1024x768 -vga std -only-migratable -chardev ringbuf,id=serial0,logfile=serial0,logappend=on -serial chardev:serial0 -audiodev none,id=snd0 -device intel-hda -device hda-output,audiodev=snd0 -global isa-fdc.driveA= -m 4096 -machine usb=off -cpu host -netdev user,id=qanet0 -device virtio-net,netdev=qanet0,mac=52:54:00:12:34:56 -boot once=d -device nec-usb-xhci -device usb-tablet -device usb-kbd -smp 4 -enable-kvm -no-shutdown -vnc :96,share=force-shared -device virtio-serial -chardev pipe,id=virtio_console,path=virtio_console,logfile=virtio_console.log,logappend=on -device virtconsole,chardev=virtio_console,name=org.openqa.console.virtio_console -chardev socket,path=qmp_socket,server,nowait,id=qmp_socket,logfile=qmp_socket.log,logappend=on -qmp chardev:qmp_socket -S -device virtio-scsi-pci,id=scsi0 -blockdev driver=file,node-name=hd0-file,filename=/var/lib/openqa/pool/6/raid/hd0,cache.no-flush=on -blockdev driver=qcow2,node-name=hd0,file=hd0-file,cache.no-flush=on -device virtio-blk,id=hd0-device,drive=hd0,serial=hd0 -blockdev driver=file,node-name=cd0-overlay0-file,filename=/var/lib/openqa/pool/6/raid/cd0-overlay0,cache.no-flush=on -blockdev driver=qcow2,node-name=cd0-overlay0,file=cd0-overlay0-file,cache.no-flush=on -device scsi-cd,id=cd0-device,drive=cd0-overlay0,serial=cd0
[2020-10-25T08:55:44.123 UTC] [debug] Waiting for 0 attempts
[2020-10-25T08:55:44.185 UTC] [debug] Waiting for 1 attempts
[2020-10-25T08:55:44.185 UTC] [debug] Backend process died, backend errors are reported below in the following lines:
QEMU terminated before QMP connection could be established at /usr/lib/os-autoinst/OpenQA/Qemu/Proc.pm line 444.

[2020-10-25T08:55:44.185 UTC] [info] ::: OpenQA::Qemu::Proc::save_state: Saving QEMU state to qemu_state.json
[2020-10-25T08:55:44.186 UTC] [debug] Passing remaining frames to the video encoder
[2020-10-25T08:55:44.187 UTC] [debug] Waiting for video encoder to finalize the video
[2020-10-25T08:55:44.187 UTC] [debug] The built-in video encoder (pid 20002) terminated
[2020-10-25T08:55:44.188 UTC] [debug] QEMU: QEMU emulator version 4.2.1 (openSUSE Leap 15.2)
[2020-10-25T08:55:44.188 UTC] [debug] QEMU: Copyright (c) 2003-2019 Fabrice Bellard and the QEMU Project developers
[2020-10-25T08:55:44.188 UTC] [debug] QEMU: Unknown host!
[2020-10-25T08:55:44.188 UTC] [debug] QEMU: Unknown host!
[2020-10-25T08:55:44.188 UTC] [debug] QEMU: Unknown host!
[2020-10-25T08:55:44.188 UTC] [debug] QEMU: qemu-system-ppc64: Requested safe cache capability level not supported by kvm, try appending -machine cap-cfpc=broken

Problem

This very likely happened due to the upgrade of the worker host to openSUSE Leap 15.2 in #73189

Suggestions

  • First consider rolling back the installation or maybe just the qemu version
  • Try the suggestion in the log file: "try appending -machine cap-cfpc=broken", to the qemu command line in jobs, then add that maybe in the openQA "machine" configuration?
  • Consider including the necessary setting in os-autoinst itself

Related issues

Related to openQA Infrastructure - action #73189: Upgrade o3 workers to openSUSE Leap 15.2 after openqa-aarch64 already doneResolved

Copied to openQA Infrastructure - action #76951: Check if new firmware for power8.o.o exists and remove os-autoinst workarounds again when according machine settings are applied when necessaryNew2020-10-25

History

#1 Updated by okurz 12 months ago

  • Description updated (diff)
  • Status changed from New to Workable
  • Target version set to Ready

#2 Updated by okurz 12 months ago

  • Related to action #73189: Upgrade o3 workers to openSUSE Leap 15.2 after openqa-aarch64 already done added

#3 Updated by okurz 12 months ago

  • Status changed from Workable to In Progress
  • Assignee set to okurz

grep 'install|qemu|' /var/log/zypp/history reveals:

2020-04-07 12:16:43|install|qemu|3.1.1.1-lp151.7.12.1|ppc64le||repo-update|8b47800ffb49b7264d2d3dd1e28110b21b5f29ac5eac3a275549de9b9d4839bd|
2020-06-02 12:17:31|install|qemu|3.1.1.1-lp151.7.15.2|ppc64le||repo-update|d73eb3b6a98363feb59bbfa5f2a9eaaff37fe1b59593f5cd119acbe6b21fb956|
2020-10-23 16:21:54|install|qemu|4.2.1-lp152.9.6.1|ppc64le||repo-update|a0139be34d5cf04e8dfbb960e9b9ea53cb0509afb4973cc289058d4249943755|

so qemu was upgraded from 3.1.1.1 to 4.2.1 during the openSUSE Leap 15.1->15.2 upgrade.

The root fs on power8 is ext4 so no snapper for easy rollback.

I tried manually on power8 with:

cd /var/lib/openqa/pool/6
curl http://openqa.opensuse.org/tests/1448500/file/vars.json > vars.json
isotovideo -d iso=/var/lib/openqa/cache/openqa1-opensuse/openSUSE-Tumbleweed-DVD-ppc64le-Snapshot20201024-Media.iso

which reproduced the error. Appending the suggested parameter shows a slightly different error messages. As it turns out we need to add multiple parameters, ending up with:

isotovideo -d iso=/var/lib/openqa/cache/openqa1-opensuse/openSUSE-Tumbleweed-DVD-ppc64le-Snapshot20201024-Media.iso qemumachine="cap-cfpc=broken,cap-sbbc=broken,cap-ibs=broken"

which shows a run succeeding to start qemu with:

[2020-10-25T15:36:21.491 UTC] [debug] Current version is 4.6.1603469837.f54bdeab [interface v20]
[2020-10-25T15:36:21.494 UTC] [debug] Setting forced test parameter ISO -> /var/lib/openqa/cache/openqa1-opensuse/openSUSE-Tumbleweed-DVD-ppc64le-Snapshot20201024-Media.iso
[2020-10-25T15:36:21.494 UTC] [debug] Setting forced test parameter QEMUMACHINE -> cap-cfpc=broken,cap-sbbc=broken,cap-ibs=broken
[2020-10-25T15:36:21.498 UTC] [debug] git hash in /var/lib/openqa/cache/openqa1-opensuse/tests/opensuse: c12d1da2e511d1cb87aeb302b752bc035a2c8c60
…
[2020-10-25T15:36:23.155 UTC] [debug] starting: /usr/bin/qemu-system-ppc64 -g 1024x768 -vga std -only-migratable -chardev ringbuf,id=serial0,logfile=serial0,logappend=on -serial chardev:serial0 -audiodev none,id=snd0 -device intel-hda -device hda-output,audiodev=snd0 -global isa-fdc.driveA= -m 4096 -machine cap-cfpc=broken,cap-sbbc=broken,cap-ibs=broken -cpu host -netdev user,id=qanet0 -device virtio-net,netdev=qanet0,mac=52:54:00:12:34:56 -boot once=d -device nec-usb-xhci -device usb-tablet -device usb-kbd -smp 4 -enable-kvm -no-shutdown -vnc :96,share=force-shared -device virtio-serial -chardev pipe,id=virtio_console,path=virtio_console,logfile=virtio_console.log,logappend=on -device virtconsole,chardev=virtio_console,name=org.openqa.console.virtio_console -chardev socket,path=qmp_socket,server,nowait,id=qmp_socket,logfile=qmp_socket.log,logappend=on -qmp chardev:qmp_socket -S -device virtio-scsi-pci,id=scsi0 -blockdev driver=file,node-name=hd0-file,filename=/var/lib/openqa/pool/6/raid/hd0,cache.no-flush=on -blockdev driver=qcow2,node-name=hd0,file=hd0-file,cache.no-flush=on -device virtio-blk,id=hd0-device,drive=hd0,serial=hd0 -blockdev driver=file,node-name=cd0-overlay0-file,filename=/var/lib/openqa/pool/6/raid/cd0-overlay0,cache.no-flush=on -blockdev driver=qcow2,node-name=cd0-overlay0,file=cd0-overlay0-file,cache.no-flush=on -device scsi-cd,id=cd0-device,drive=cd0-overlay0,serial=cd0
[2020-10-25T15:36:23.158 UTC] [debug] Waiting for 0 attempts
[2020-10-25T15:36:24.159 UTC] [debug] Waiting for 1 attempts
[2020-10-25T15:36:25.159 UTC] [debug] Finished after 2 attempts
[2020-10-25T15:36:25.159 UTC] [debug] QMP socket: 14
/usr/lib/os-autoinst/consoles/vnc_base.pm:62:{
  "port" => 5996,
  "connect_timeout" => 3,
  "hostname" => "localhost"
}
[2020-10-25T15:36:25.177 UTC] [debug] pointer type 0 0 640 480 -257
[2020-10-25T15:36:25.177 UTC] [debug] led state 0 1 1 -261
Start CPU
GOT GO

[2020-10-25T15:36:25.237 UTC] [debug] QEMU: QEMU emulator version 4.2.1 (openSUSE Leap 15.2)
[2020-10-25T15:36:25.237 UTC] [debug] QEMU: Copyright (c) 2003-2019 Fabrice Bellard and the QEMU Project developers
[2020-10-25T15:36:25.238 UTC] [debug] Snapshots are supported
[2020-10-25T15:36:25.239 UTC] [debug] ||| starting mediacheck tests/installation/mediacheck.pm
[2020-10-25T15:36:25.240 UTC] [debug] tests/installation/mediacheck.pm:23 called bootloader_setup::ensure_shim_import -> lib/bootloader_setup.pm:1063 called testapi::assert_screen
[2020-10-25T15:36:25.240 UTC] [debug] <<< testapi::assert_screen(mustmatch=[
  "inst-bootmenu",
  "bootloader-shim-import-prompt"
], timeout=30)
[2020-10-25T15:36:26.706 UTC] [debug] no match: 89.0s, best candidate: bootloader-tw-salt_installer-20190111 (0.29)
[2020-10-25T15:36:27.233 UTC] [debug] no change: 88.0s
[2020-10-25T15:36:28.466 UTC] [debug] no match: 87.0s, best candidate: bootloader-grub2-Kubic-boo1131693-20190405 (0.00)
[2020-10-25T15:36:29.458 UTC] [debug] no match: 86.0s, best candidate: bootloader-grub2-Kubic-boo1131693-20190405 (0.00)
[2020-10-25T15:36:31.052 UTC] [debug] WARNING: check_asserted_screen took 0.81 seconds for 17 candidate needles - make your needles more specific
[2020-10-25T15:36:31.052 UTC] [debug] no match: 85.0s, best candidate: bootloader-grub2-Kubic-boo1131693-20190405 (0.00)
[2020-10-25T15:36:31.575 UTC] [debug] >>> testapi::_handle_found_needle: found rescuesystem-20150721, similarity 1.00 @ 17/72
[2020-10-25T15:36:31.576 UTC] [debug] tests/installation/mediacheck.pm:24 called bootloader_setup::select_bootmenu_more -> lib/bootloader_setup.pm:598 called bootloader_setup::stop_grub_timeout -> lib/bootloader_setup.pm:79 called testapi::send_key
[2020-10-25T15:36:31.576 UTC] [debug] <<< testapi::send_key(key="up", do_wait=0, wait_screen_change=0)
[2020-10-25T15:36:31.978 UTC] [debug] tests/installation/mediacheck.pm:24 called bootloader_setup::select_bootmenu_more -> lib/bootloader_setup.pm:601 called testapi::check_screen
[2020-10-25T15:36:31.978 UTC] [debug] <<< testapi::check_screen(mustmatch="inst-submenu-more", timeout=0)
[2020-10-25T15:36:32.390 UTC] [debug] no match: -0.3s, best candidate: inst-submenu-more-20191210 (0.00)
[2020-10-25T15:36:32.554 UTC] [debug] >>> testapi::_check_backend_response: match=inst-submenu-more timed out after 0 (check_screen)
[2020-10-25T15:36:32.584 UTC] [debug] tests/installation/mediacheck.pm:24 called bootloader_setup::select_bootmenu_more -> lib/bootloader_setup.pm:605 called testapi::send_key_until_needlematch
[2020-10-25T15:36:32.584 UTC] [debug] <<< testapi::check_screen(mustmatch="inst-onmediacheck", timeout=3)
[2020-10-25T15:36:33.529 UTC] [debug] >>> testapi::_handle_found_needle: found mediacheck-20150610, similarity 1.00 @ 24/126
[2020-10-25T15:36:33.529 UTC] [debug] tests/installation/mediacheck.pm:24 called bootloader_setup::select_bootmenu_more -> lib/bootloader_setup.pm:624 called bootloader_setup::type_boot_parameters -> lib/bootloader_setup.pm:1330 called testapi::type_string
[2020-10-25T15:36:33.529 UTC] [debug] <<< testapi::type_string(string="    ", max_interval=4, wait_screen_changes=0, wait_still_screen=0, timeout=30, similarity_level=47)
[2020-10-25T15:36:36.040 UTC] [debug] tests/installation/mediacheck.pm:24 called bootloader_setup::select_bootmenu_more -> lib/bootloader_setup.pm:626 called testapi::send_key
[2020-10-25T15:36:36.040 UTC] [debug] <<< testapi::send_key(key="ret", wait_screen_change=0, do_wait=0)
[2020-10-25T15:36:36.441 UTC] [debug] tests/installation/mediacheck.pm:29 called testapi::assert_screen
[2020-10-25T15:36:36.441 UTC] [debug] <<< testapi::assert_screen(mustmatch=[
  "mediacheck-select-device",
  "mediacheck-ok",
  "mediacheck-checksum-wrong"
], timeout=3600)
[2020-10-25T15:36:36.492 UTC] [debug] no match: 10799.9s, best candidate: mediacheck-ok-20140903 (0.00)
^C[2020-10-25T15:36:36.557 UTC] [debug] isotovideo received signal INT
[2020-10-25T15:36:36.557 UTC] [debug] isotovideo received signal INT
[2020-10-25T15:36:36.557 UTC] [debug] stopping command server 25514 because test execution ended
[2020-10-25T15:36:36.557 UTC] [debug] QEMU: qemu-system-ppc64: terminating on signal 2
[2020-10-25T15:36:36.557 UTC] [debug] isotovideo: informing websocket clients before stopping command server: http://127.0.0.1:20063/qL0cvoaoKR5zOTFr/broadcast
[2020-10-25T15:36:36.558 UTC] [debug] commands process exited: 0
[2020-10-25T15:36:36.559 UTC] [debug] [autotest] process exited: 0
[2020-10-25T15:36:36.560 UTC] [debug] done with command server
[2020-10-25T15:36:36.560 UTC] [debug] stopping autotest process 25517
[2020-10-25T15:36:36.560 UTC] [debug] done with autotest process
[2020-10-25T15:36:36.560 UTC] [debug] isotovideo failed
[2020-10-25T15:36:36.560 UTC] [debug] stopping backend process 25537
[2020-10-25T15:36:36.561 UTC] [debug] backend got TERM
[2020-10-25T15:36:36.561 UTC] [info] ::: OpenQA::Qemu::Proc::save_state: Saving QEMU state to qemu_state.json
[2020-10-25T15:36:36.562 UTC] [debug] Passing remaining frames to the video encoder
[2020-10-25T15:36:36.563 UTC] [debug] Waiting for video encoder to finalize the video
[2020-10-25T15:36:36.563 UTC] [debug] The built-in video encoder (pid 25557) terminated
[2020-10-25T15:36:36.565 UTC] [debug] sending magic and exit
[2020-10-25T15:36:36.761 UTC] [debug] done with backend process
25510: EXIT 1

so we need to add "cap-cfpc=broken,cap-sbbc=broken,cap-ibs=broken" to the test setting QEMUMACHINE in case it is not already included:

    # newer qemu needs safe cache capability level quirk settings
    # https://progress.opensuse.org/issues/75259
    my $caps = ',cap-cfpc=broken,cap-sbbc=broken,cap-ibs=broken';
    $vars->{QEMUMACHINE} .= $caps if $self->{qemu_version} >= '4' && $vars->{QEMUMACHINE} !~ /$caps/;
I hotpatched that now on power8.

#4 Updated by okurz 12 months ago

  • Subject changed from 100% of powerpc tests incomplete to 100% of powerpc tests incomplete auto_review:"(?s)Running on power8.*qemu-system-ppc64: Requested safe cache capability level not supported by kvm":retry

#5 Updated by okurz 12 months ago

  • Status changed from In Progress to Feedback

https://openqa.opensuse.org/tests/1448862 passed

I called ./openqa-monitor-incompletes | ./openqa-label-known-issues from github.com/os-autoinst/scripts/ after I added the "auto_review" marker in the ticket subject line. Many ppc64le jobs are running now. Did ssh -J o3 root@power8 "cat /usr/lib/os-autoinst/backend/qemu.pm" > backend/qemu.pm to copy over to local working copy.

Created PR https://github.com/os-autoinst/os-autoinst/pull/1554

#6 Updated by okurz 12 months ago

  • Status changed from Feedback to Resolved

PR is merged and deployed on power8, tests are fine on power8, hotfix was replaced.

#7 Updated by AdamWill 12 months ago

FWIW, we ran into this in Fedora as well a while back. Upgrading the firmware on the worker host boxes may help. See https://bugzilla.redhat.com/show_bug.cgi?id=1768551 .

#8 Updated by AdamWill 12 months ago

...also this "fix" is kinda wrong because setting this is not necessary unless the machine has outdated firmware. All our ppc64le workers have sufficiently recent firmware (now) and work fine without this being necessary.

#9 Updated by okurz 12 months ago

You are right. This isn't a real fix. As the name of the option says, qemu is working around "broken" firmware behavior. Thanks for sharing your information. Maybe there is something we could do about firmware

#10 Updated by okurz 12 months ago

  • Copied to action #76951: Check if new firmware for power8.o.o exists and remove os-autoinst workarounds again when according machine settings are applied when necessary added

Also available in: Atom PDF