Project

General

Profile

action #71830

[y] Set default target based on the expectations

Added by ybonatakis 12 months ago. Updated 11 months ago.

Status:
Closed
Priority:
High
Assignee:
Target version:
SUSE QA - SLE 15 SP3
Start date:
2020-09-24
Due date:
2020-10-20
% Done:

0%

Estimated time:
2.00 h

Description

Observation

As it is explained in the https://bugzilla.suse.com/show_bug.cgi?id=1164556 this is expected as they depend on how system was installed.
This means that even if the "minimal" system role is selected the target is determined by the installed x11 packages and the xdm[0]
Also from the logs

2020-09-23 15:49:22 <1> redcurrant-1(4140) [Pkg] clients/default_target_proposal.rb:237 Pkg Builtin called: IsSelected
2020-09-23 15:49:22 <1> redcurrant-1(4140) [Pkg] Package.cc(IsSelected):505 Tag xdm provided by xdm is selected to install
2020-09-23 15:49:22 <1> redcurrant-1(4140) [Ruby] clients/default_target_proposal.rb:273 Systemd target detection says: X11 packages have been selected for installation
2020-09-23 15:49:22 <1> redcurrant-1(4140) [Ruby] clients/default_target_proposal.rb:268 Detected target proposal 'graphical'
2020-09-23 15:49:22 <1> redcurrant-1(4140) [Ruby] clients/default_target_proposal.rb:231 Setting systemd default target to graphical
2020-09-23 15:49:22 <1> redcurrant-1(4140) [Ruby] modules/services_manager_target.rb:118 New default target has been set: graphical
2020-09-23 15:49:22 <1> redcurrant-1(4140) [Ruby] clients/default_target_proposal.rb:193 Systemd default target is set to 'graphical'
2020-09-23 15:49:22 <1> redcurrant-1(4140) [Interpreter] installation/proposal_store.rb:480 Called YaST client returned.
2020-09-23 15:49:22 <0> redcurrant-1(4140) [Interpreter] installation/proposal_store.rb:480 Called YaST client returned: $["preformatted_proposal":"<ul><li>Graphical mode</li></ul>"]
2020-09-23 15:49:22 <0> redcurrant-1(4140) [Ruby] installation/proposal_store.rb:492 default_target_proposal MakeProposal() returns {"preformatted_proposal"=>"<ul><li>Graphical mode</li></ul>"}

So we need to fix the validation for the expected target in the system.

[0] https://github.com/yast/yast-services-manager/blob/master/src/modules/services_manager_target.rb#L126
openQA test in scenario sle-15-SP3-Online-ppc64le-minimal+role_minimal@ppc64le-hmc-4disk fails in
verify_default_target

Test suite description

Like default but explicitly select the system role "minimal". The resulting system should roughly correspond to an unregistered system but with access to modules for optional installation.

Reproducible

Fails since (at least) Build 14.2

Expected result

Last good: (unknown) (or more recent)

Further details

Always latest result in this scenario: latest

History

#1 Updated by ybonatakis 12 months ago

  • Priority changed from Normal to High

#2 Updated by riafarov 12 months ago

  • Due date set to 2020-10-20
  • Target version set to SLE 15 SP3

#3 Updated by riafarov 12 months ago

  • Status changed from New to Workable
  • Estimated time set to 2.00 h

#4 Updated by riafarov 12 months ago

  • Project changed from openQA Tests to qe-yast
  • Category deleted (Bugs in existing tests)

#5 Updated by JERiveraMoya 11 months ago

  • Status changed from Workable to In Progress
  • Assignee set to JERiveraMoya

#6 Updated by JERiveraMoya 11 months ago

  • Status changed from In Progress to Feedback

#7 Updated by JERiveraMoya 11 months ago

  • Status changed from Feedback to Closed

#8 Updated by okurz 11 months ago

This is an autogenerated message for openQA integration by the openqa_review script:

This bug is still referenced in a failing openQA test: minimal+role_minimal@ppc64le-hmc-4disk
https://openqa.suse.de/tests/4901167

To prevent further reminder comments one of the following options should be followed:

  1. The test scenario is fixed by applying the bug fix to the tested product or the test is adjusted
  2. The openQA job group is moved to "Released"
  3. The label in the openQA scenario is removed

Also available in: Atom PDF