Project

General

Profile

action #71608

[y] post_fail_hooks fails with script timeout, no logs collected

Added by ybonatakis 12 months ago. Updated 11 months ago.

Status:
Closed
Priority:
High
Assignee:
Target version:
SUSE QA - SLE 15 SP3
Start date:
2020-09-21
Due date:
2020-10-20
% Done:

0%

Estimated time:
5.00 h

Description

Observation

there are a few tests that failed in the current build 36.5 but their logs are not presented in the logs&assets
~~the reason (at least in the allmodules+allpatterns+registration seems to be a timeout

[2020-09-17T15:35:54.176 CEST] [debug] post_fail_hook failed: script timeout: dmesg | grep "Out of memory" at /usr/lib/os-autoinst/testapi.pm line 1121.

The post_fail_hook should never fail, ideally, at least not fatal and it should continue even if some of the commands fail.~~

Problem was with sysrq command, which got fixed with https://github.com/os-autoinst/os-autoinst-distri-opensuse/pull/11054/files
But we don't switch to log console for whatever reason, and next step fails, we even don't see it typed properly and somehow byebug is called.

openQA test in scenario sle-15-SP3-Full-x86_64-allmodules+allpatterns+registration@64bit fails in
addon_products_sle

Test suite description

Full Medium installation that covers the following cases:
1. Additional modules enabled using SCC (Legacy, Development Tools, Web and
Scripting, Containers, Desktop Applications);
2. All patterns installed;
3. System registration is skipped during installation;
4. Installation is validated by successful boot and that YaST does not
report any issues;
5. Registration is performed on the installed system.

Reproducible

Fails since (at least) Build 34.1

Expected result

Last good: 33.1 (or more recent)

Further details

Always latest result in this scenario: latest

History

#1 Updated by riafarov 12 months ago

  • Description updated (diff)
  • Due date set to 2020-10-20
  • Priority changed from Normal to High
  • Target version set to SLE 15 SP3

#2 Updated by riafarov 12 months ago

  • Description updated (diff)

#3 Updated by riafarov 12 months ago

  • Subject changed from [y] post_fail_hooks fails with script timeout to [y] post_fail_hooks fails with script timeout, no logs collected
  • Description updated (diff)
  • Status changed from New to Workable
  • Estimated time set to 5.00 h

#4 Updated by riafarov 12 months ago

  • Project changed from openQA Tests to qe-yast
  • Category deleted (Enhancement to existing tests)

#5 Updated by riafarov 11 months ago

  • Assignee set to riafarov

#6 Updated by riafarov 11 months ago

  • Status changed from Workable to In Progress

#7 Updated by riafarov 11 months ago

So problem is here:

sub show_tasks_in_blocked_state {
    # sending sysrqs doesn't work for svirt
    if (has_ttys) {
        send_key 'alt-sysrq-t';
        send_key 'alt-sysrq-w';
        # info will be sent to serial tty
        wait_serial(qr/sysrq\s*:\s+show\s+blocked\s+state/i, 1);
        send_key 'ret';    # ensure clean shell prompt
    }
}

That last send_key 'ret' presses yes in exception window starting byebug.

#9 Updated by riafarov 11 months ago

  • Status changed from In Progress to Closed

Also available in: Atom PDF