Project

General

Profile

action #71116

coordination #69394: [y][epic] Add test for the YaST 1-click install

[y] Add OpenQA test for OneClickInstall

Added by syrianidou_sofia about 1 year ago. Updated 12 months ago.

Status:
Closed
Priority:
Normal
Assignee:
Target version:
SUSE QA - SLE 15 SP3
Start date:
2020-09-08
Due date:
% Done:

0%

Estimated time:
5.00 h

Description

Packages can be installed via .YMP files that contain the necessary information in XML form, using OneclickInstall.
As root run
#OneClickInstallCLI
and verify that the package is installed successfully. Accordingly, test the OneClickInstall UI
#OneClickInstallUI

YMP URL example: https://software.opensuse.org/ymp/openSUSE:Factory/standard/vim.ymp?base=openSUSE%3AFactory&query=vim

The test can run on both SLE and Tumbleweed, but with different YMP URLs, but only 64-bit for a start.

History

#1 Updated by okurz about 1 year ago

We had a test for OneClickInstall which was removed in https://github.com/os-autoinst/os-autoinst-distri-opensuse/pull/6655 against my suggestion. Maybe you want to bring it back.

#2 Updated by syrianidou_sofia about 1 year ago

okurz wrote:

We had a test for OneClickInstall which was removed in https://github.com/os-autoinst/os-autoinst-distri-opensuse/pull/6655 against my suggestion. Maybe you want to bring it back.

Interesting, thanks Oliver.

#3 Updated by riafarov about 1 year ago

  • Due date set to 2020-10-06
  • Target version set to SLE 15 SP3

#4 Updated by riafarov about 1 year ago

  • Description updated (diff)
  • Status changed from New to Workable
  • Estimated time set to 5.00 h

#5 Updated by riafarov about 1 year ago

  • Description updated (diff)

#6 Updated by JERiveraMoya about 1 year ago

  • Assignee set to JERiveraMoya

#7 Updated by riafarov about 1 year ago

  • Due date changed from 2020-10-06 to 2020-10-20

#8 Updated by riafarov about 1 year ago

  • Status changed from Workable to In Progress

#9 Updated by JERiveraMoya about 1 year ago

Test module onclick_install is already running in Tumbleweed.

yast2-metapackage-handler is available in Package Hub, which does not have a consolidated state in distribution under development, so we should discard SLE. For the same reason there are .ymp files for previous distributions SLE-15-SP1, SLE-15-SP2 but not for SLE-15-SP3.

#10 Updated by JERiveraMoya about 1 year ago

  • Status changed from In Progress to Feedback

#11 Updated by JERiveraMoya about 1 year ago

  • Status changed from Feedback to Resolved

#12 Updated by riafarov about 1 year ago

  • Status changed from Resolved to Closed

#13 Updated by JERiveraMoya about 1 year ago

  • Status changed from Closed to Workable

#14 Updated by JERiveraMoya about 1 year ago

  • Status changed from Workable to Closed

#15 Updated by riafarov about 1 year ago

  • Project changed from openQA Tests to qe-yast

#16 Updated by riafarov 12 months ago

  • Due date deleted (2020-10-20)

Also available in: Atom PDF