Project

General

Profile

action #69655

[y][timeboxed:12h] Modify check in autoyast installation test

Added by syrianidou_sofia about 1 year ago. Updated about 1 year ago.

Status:
Resolved
Priority:
Normal
Assignee:
Target version:
SUSE QA - SLE 15 SP3
Start date:
2020-08-06
Due date:
2020-10-06
% Done:

0%

Estimated time:

Description

Related to https://progress.opensuse.org/issues/64325

After implementing the

described in above ticket, there was a malfunction noticed only on one local machine ( http://falafel.suse.cz/tests/875#step/installation/1 ). The above failure is the reason why the check only records failure and doesn't kill the test. It looks like the worker can't reach the uploaded autoyast profile, but the SUT can.

Recently, the same failure was noticed in production:
https://openqa.opensuse.org/tests/1352380#step/installation/1
Here, AUTOYAST was set to the sle autoyast profile instead of the opensuse one but still that doesn't explain why the head($url) failed. The wrong profile was uploaded and should be reachable.

We should get more runs and see how often issue occurs.

Acceptance criteria:

  • Root cause is identified for the failures described above.
  • If safe, modify the check in autoyast installation in order to kill the test in case of failure.

History

#1 Updated by riafarov about 1 year ago

  • Due date set to 2020-09-08
  • Category set to Enhancement to existing tests
  • Target version set to SLE 15 SP3

#2 Updated by riafarov about 1 year ago

  • Due date changed from 2020-09-08 to 2020-09-22

#3 Updated by riafarov about 1 year ago

  • Subject changed from [y] Modify check in autoyast installation test to [y][timeboxed:12h] Modify check in autoyast installation test
  • Description updated (diff)
  • Status changed from New to Workable

#4 Updated by ybonatakis about 1 year ago

  • Assignee set to ybonatakis

#5 Updated by riafarov about 1 year ago

  • Due date changed from 2020-09-22 to 2020-10-06
  • Assignee deleted (ybonatakis)

#6 Updated by riafarov about 1 year ago

  • Assignee set to ybonatakis

#7 Updated by ybonatakis about 1 year ago

  • Status changed from Workable to In Progress

#8 Updated by ybonatakis about 1 year ago

  • Status changed from In Progress to Feedback

So the reason is on particular workers. Specifically

On those workers you can see that there is a Premature connection close error which probably says that the connection is closed in the time of the request when the request is happening.

[2020-09-24T10:21:28.0755 CEST] [error] REST-API error (POST http://openqa1-opensuse/api/v1/jobs/1404726/status): Connection error: Premature connection close (remaining tries: 59)

No idea why as i could not make it into the system and the time have passed.

I tried to provide a patch which will repeat the request for a number of times and report the http status but it was behaving weird and due to the time limit of this ticket i will resolve it and create another for the "enhancement" of the subroutine.

#9 Updated by riafarov about 1 year ago

  • Project changed from openQA Tests to qe-yast
  • Category deleted (Enhancement to existing tests)

#10 Updated by ybonatakis about 1 year ago

https://progress.opensuse.org/issues/72277 followup ticket for some enhancement to deal with false error in those workers

#11 Updated by riafarov about 1 year ago

  • Status changed from Feedback to Resolved

Follow-up ticket created: #72277 to implement retry mechanism.

Also available in: Atom PDF