Project

General

Profile

Actions

action #64325

closed

[functional][y] Add check in autoyast installation test with wrong autoyast profile path

Added by syrianidou_sofia over 4 years ago. Updated about 4 years ago.

Status:
Resolved
Priority:
Normal
Category:
Enhancement to existing tests
Target version:
-
Start date:
2020-03-09
Due date:
2020-05-05
% Done:

0%

Estimated time:
3.00 h
Difficulty:

Description

When users manually provide the path for the autoyast profile, there can be typos. After the system displays an error that the profile cannot be found, changing the path to the correct one, should work.

(Recently, I tried the above action manually and faced some unexpected warning messages. See https://bugzilla.suse.com/show_bug.cgi?id=1165464 )

Challenge with implementing the above check in openQA is that if the given autoyast profile path is not correct, openQA will not proceed to run the test.

use LWP::Simple 'head' can be used

Acceptance criteria

  1. Accessibility of the autoyast profile is validated before test is executed
Actions #1

Updated by riafarov over 4 years ago

  • Due date set to 2020-04-07
  • Category set to Enhancement to existing tests
Actions #2

Updated by riafarov about 4 years ago

  • Due date changed from 2020-04-07 to 2020-04-21
Actions #3

Updated by riafarov about 4 years ago

  • Description updated (diff)
  • Status changed from New to Workable
  • Estimated time set to 3.00 h
Actions #4

Updated by syrianidou_sofia about 4 years ago

  • Assignee set to syrianidou_sofia
Actions #5

Updated by syrianidou_sofia about 4 years ago

  • Status changed from Workable to In Progress
Actions #6

Updated by riafarov about 4 years ago

  • Due date changed from 2020-04-21 to 2020-05-05
Actions #7

Updated by riafarov about 4 years ago

  • Status changed from In Progress to Resolved
Actions

Also available in: Atom PDF