Project

General

Profile

action #69313

When using refspec for ppc for a particular job, PRODUCTDIR is set wrong

Added by syrianidou_sofia over 1 year ago. Updated about 1 year ago.

Status:
Resolved
Priority:
Low
Assignee:
Category:
Feature requests
Target version:
Start date:
2020-07-24
Due date:
% Done:

0%

Estimated time:
Difficulty:
easy

Description

While attempting to run refspecs for test "autoyast_reinstall" job on various architectures, I faced an issue specifically on ppc64le. The PRODUCTDIR needs to be set manually like following:
openqa-clone-custom-git-refspec https://github.com/sofiasyria/os-autoinst-distri-opensuse/tree/ac68803 https://openqa.suse.de/tests/4427385 ASSET_1="04427383-autoinst.xml" YAML_TEST_DATA=test_data/yast/autoyast_reinstall/autoyast_reinstall_ppc64le-hmc.yaml PRODUCTDIR="os-autoinst-distri-opensuse/products/sle"

If the above command is used without the PRODUCTDIR specification, the variable gets the value "os-autoinst-distri-opensuseos-autoinst-distri-opensuse/products/sle" which leads to test failure as here:
https://openqa.suse.de/tests/4482090

The particular test suite runs for ppc64le-2g, ppc64le-hmc-single-disk, 64bit, s390x and aarch64. For both the ppc machines, the PRODUCTDIR needs to be set manually. For rest of them, it's not necessary.

I have unsuccessfully tried to reproduce the issue with other jobs on ppc.

History

#1 Updated by okurz over 1 year ago

  • Project changed from openQA Tests to openQA Project
  • Subject changed from [tools] When using refspec for ppc for a particular job, PRODUCTDIR is set wrong to When using refspec for ppc for a particular job, PRODUCTDIR is set wrong
  • Category changed from Infrastructure to Feature requests
  • Status changed from New to Workable
  • Target version set to Ready
  • Difficulty set to easy

#2 Updated by okurz about 1 year ago

  • Priority changed from Normal to Low

#3 Updated by Xiaojing_liu about 1 year ago

  • Status changed from Workable to In Progress
  • Assignee set to Xiaojing_liu

#4 Updated by Xiaojing_liu about 1 year ago

  • Status changed from In Progress to Feedback

pr has been merged

#5 Updated by syrianidou_sofia about 1 year ago

I just tried to run "autoyast_reinstall" on ppc64le. PRODUCTDIR seems to be correct now.

#6 Updated by mkittler about 1 year ago

  • Status changed from Feedback to Resolved

Then I'm closing the ticket as resolved.

Also available in: Atom PDF