Project

General

Profile

action #69154

action #68350: Improve package and base OS version support

Improve package and base OS version support: Bump versions to Leap 15.2

Added by okurz over 1 year ago. Updated about 1 year ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
Organisational
Target version:
Start date:
2020-07-21
Due date:
% Done:

0%

Estimated time:
Difficulty:

Description


Related issues

Related to openQA Infrastructure - action #75235: container image devel:openQA:ci/base is unresolvable with "nothing provides this-is-only-for-build-envs needed by cmake-mini"Resolved2020-10-24

History

#1 Updated by okurz over 1 year ago

  • Status changed from In Progress to Feedback

https://github.com/os-autoinst/os-autoinst/pull/1481 for os-autoinst references, https://github.com/os-autoinst/openQA/pull/3276 . I have added openSUSE Leap 15.2 to https://build.opensuse.org/projects/devel:openQA:ci/meta but need yet to change the "containers" repo we can agree that this is the right time to switch.

#2 Updated by okurz over 1 year ago

  • Status changed from Feedback to Workable

https://github.com/os-autoinst/os-autoinst/pull/1481 was merged. Need to provide some package links and maintenance updates according to https://github.com/os-autoinst/openQA/pull/3276#issuecomment-662437408

#3 Updated by cdywan over 1 year ago

  • Status changed from Workable to In Progress

#4 Updated by okurz over 1 year ago

  • Status changed from In Progress to Workable

why did you set this to "In Progress" when I was in vacation so obviously did not work on this?

#5 Updated by cdywan over 1 year ago

okurz wrote:

why did you set this to "In Progress" when I was in vacation so obviously did not work on this?

You did. But you weren't ;-) The PR is in progress as far as I can tell. I'm not aware that we have a policy of resetting all tickets when people take days off.

#6 Updated by cdywan over 1 year ago

I see you already reverted the status - can you clarify what the status of the PR is, then?

#7 Updated by okurz about 1 year ago

okurz wrote:

Need to provide some package links and maintenance updates according to https://github.com/os-autoinst/openQA/pull/3276#issuecomment-662437408

#8 Updated by okurz about 1 year ago

  • Status changed from Workable to Feedback

one problem is: https://build.opensuse.org/package/show/devel:openQA:Leap:15.2/perl-Mojolicious-Plugin-Status:

nothing provides perl(File::Temp) >= 0.2308, (got version 0.2304 provided by perl-File-Temp), (got version 0.2304 provided by perl-base)

So I created https://build.opensuse.org/request/show/814747 to bump the version within openSUSE:Leap:15.2 but that got rejected because perl-File-Temp is provided by SLE packages so I created https://build.suse.de/request/show/222141 internally for SLE referencing a bug https://bugzilla.opensuse.org/show_bug.cgi?id=1174050 which was declined because we would need to have an ECO which IMHO is an effort we want to avoid.

Based on test results in https://github.com/os-autoinst/openQA/pull/3276 like https://app.circleci.com/pipelines/github/os-autoinst/openQA/4249/workflows/64cdf150-77b6-4633-af73-a02f0828b019/jobs/40689 did

for i in perl-File-Temp perl-Devel-Cover perl-Selenium-Remote-Driver perl-TAP-Harness-JUnit; do osc linkpac openSUSE:Factory $i devel:openQA:Leap:15.2 ; done

https://build.opensuse.org/project/show/devel:openQA:Leap:15.2 is all green now.

Waiting for circleCI results

#9 Updated by okurz about 1 year ago

  • Status changed from Feedback to Blocked

PR is ready but for now we prefer to have #68095 done first so that we can upgrade all our CI setup and infrastructure together.

#10 Updated by okurz about 1 year ago

  • Status changed from Blocked to In Progress

https://github.com/os-autoinst/openQA/pull/3276 merged as well as updated https://build.opensuse.org/projects/devel:openQA:ci/meta

EDIT: Also needed to add "Prefer: openSUSE-release-appliance-docker" to https://build.opensuse.org/projects/devel:openQA:ci/prjconf to fix a problem with "have choices for …" in OBS.

#11 Updated by okurz about 1 year ago

  • Related to action #75235: container image devel:openQA:ci/base is unresolvable with "nothing provides this-is-only-for-build-envs needed by cmake-mini" added

#12 Updated by okurz about 1 year ago

  • Status changed from In Progress to Resolved

#75235 could be caused by this or maybe it was in already in before. With this there are no more references to 15.1 in our documentation in git or source code except for "example code".

Also available in: Atom PDF