Project

General

Profile

Actions

action #65579

closed

openQA backend died when check a needle that only has one area and its type is ocr

Added by Xiaojing_liu about 4 years ago. Updated almost 4 years ago.

Status:
Resolved
Priority:
Low
Assignee:
Category:
Regressions/Crashes
Target version:
Start date:
2020-04-13
Due date:
% Done:

0%

Estimated time:

Description

Observation

Users create a needle that only has one item in area and its type is ocr.


links-connect-suse-webpage-20200411.json                                                                                                                     
 {
   "area": [
     {
       "xpos": 20,
       "ypos": 415,
       "width": 155,
       "height": 16,
       "type": "ocr"
     }
   ],
   "properties": [],
   "tags": [
     "links-connect-suse-webpage"
   ]
 }

Then openQA backend died when load this needle, the error message is


[2020-04-13T04:14:05.713 CEST] [debug] <<< testapi::assert_screen(mustmatch="links-connect-suse-webpage", timeout=30)
[2020-04-13T04:14:05.746 CEST] [debug] Backend process died, backend errors are reported below in the following lines:
Illegal division by zero at /usr/lib/perl5/vendor_perl/5.26.1/x86_64-linux-thread-multi/tinycv.pm line 49.

Failed job: https://openqa.nue.suse.com/tests/4114680/file/autoinst-log.txt

Open points

1. if the needle json file is valid?
2. if there is no `type: match` area in a needle json file, the backend should not died with this error message.

Suggestions

  • Alternatives: Add caution hint in help text on the web page or catch single OCR and fail with error shown to user

Workaround

Users already created a ticket to fix this needle file. here is the poo: https://progress.opensuse.org/issues/65573


Related issues 2 (0 open2 closed)

Is duplicate of openQA Project - action #12858: "ocr" was never properly tested and is not completeRejectedokurz2016-07-25

Actions
Copied from openQA Project - action #65576: openQA backend died when check a needle that only has one area and its type is ocr Rejected2020-04-13

Actions
Actions #1

Updated by Xiaojing_liu about 4 years ago

  • Copied from action #65576: openQA backend died when check a needle that only has one area and its type is ocr added
Actions #2

Updated by okurz about 4 years ago

  • Is duplicate of action #12858: "ocr" was never properly tested and is not complete added
Actions #3

Updated by okurz about 4 years ago

  • Status changed from New to Rejected
  • Priority changed from Normal to Low
  • Target version set to future

If anyone cares to fix it then it's the same as #12858 which I don't see on our agenda even though it's not nice to have a crash like this. If you can solve this in few minutes or hours not more, go ahead.

Actions #4

Updated by okurz about 4 years ago

  • Description updated (diff)
  • Status changed from Rejected to Workable

Discussed some ideas that should be easy to implement as a first step

Actions #5

Updated by Xiaojing_liu about 4 years ago

  • Status changed from Workable to In Progress
  • Assignee set to Xiaojing_liu
  • Target version changed from future to Current Sprint
Actions #7

Updated by Xiaojing_liu about 4 years ago

  • Status changed from In Progress to Feedback

PR has been merged

Actions #8

Updated by livdywan almost 4 years ago

  • Status changed from Feedback to Resolved

With the implemented changes, OCR-only needles cause a failure with an explicit message saying Cannot create a needle with only OCR areas.

Actions

Also available in: Atom PDF