Project

General

Profile

action #65001

SUT will stay in shutdown after reboot command on s390 svirt backend

Added by pcervinka over 1 year ago. Updated 11 months ago.

Status:
Rejected
Priority:
Normal
Assignee:
-
Category:
Infrastructure
Target version:
QE Kernel - QE Kernel Done
Start date:
2020-03-30
Due date:
% Done:

0%

Estimated time:
Difficulty:

Description

Observation

openQA test in scenario sle-15-SP2-Online-s390x-pressure_stall_information@s390x-kvm-sle15 fails in
pressure_stall_information

Test suite description

Starting with SLE15-SP2 PSI is compiled into the kernel, but disabled by
default. It can be enabled by setting psi=1 on the kernel command line. This
is just a smoke test; checking that PSI really detects stalls is beyond the
scope of our team's testing. jira#SLE-9282

Reproducible

Fails since (at least) Build 156.8

Expected result

Last good: 155.1 (or more recent)

Further details

Always latest result in this scenario: latest

Test started to fail recently with error:
Test died: Could not find login prompt at /var/lib/openqa/cache/openqa.suse.de/tests/sle/lib/utils.pm line 140

It basically means that system didn't boot properly and information about that is missing in console.

Console for backend is get by following command, but it is empty at the end.
pty=virsh dumpxml openQA-SUT-2 2>/dev/null | grep \"console type=\" | sed \"s/'/ /g\" | awk '{ print \$5 }'

I did manual experiment, paused execution of the test in openQA, connected to SUT and kvm machine.

Checked status on the machine where openQA vm should be started:

s390p8:~ # virsh list --all
 Id    Name                           State
----------------------------------------------------
 723   openQA-SUT-7                   running

Connected to SUT itself via ssh and did reboot.

Checked status on the machine:

s390p8:~ # virsh list --all
 Id    Name                           State
----------------------------------------------------
 -     openQA-SUT-7                   shut off

SUT stayed in shutdown mode, this is the reason for the failure which we observe during regular openQA execution.

Journal contains:
Mar 30 13:10:09 s390p8 systemd-machined[97014]: Machine qemu-725-openQA-SUT-7 terminated


Related issues

Is duplicate of openQA Tests - action #62240: [functional][u][s390x-kvm-sle12] test fails in reboot_gnome - timeout, SUT takes long time to rebootRejected2020-01-17

History

#1 Updated by pcervinka over 1 year ago

  • Description updated (diff)

#3 Updated by pvorel over 1 year ago

Matthias, thanks for info.

BTW: our test failed already in 156.8
https://openqa.suse.de/tests/4038277#next_previous

But there are that many failures for autoyast_reinstall, that I'm not able to compare
https://openqa.suse.de/tests/4013548#next_previous

#4 Updated by pcervinka over 1 year ago

  • Is duplicate of action #62240: [functional][u][s390x-kvm-sle12] test fails in reboot_gnome - timeout, SUT takes long time to reboot added

#5 Updated by pcervinka over 1 year ago

  • Category changed from Bugs in existing tests to Infrastructure
  • Target version set to 445

Issue is already known and reported.

#6 Updated by pcervinka over 1 year ago

  • Status changed from New to Rejected

#7 Updated by metan over 1 year ago

  • Target version changed from 445 to 457

#8 Updated by pcervinka 11 months ago

  • Target version changed from 457 to QE Kernel Done

Also available in: Atom PDF