Project

General

Profile

action #64463

[functional][y] test fails in live_installation on Tumbleweed

Added by ggardet_arm 4 months ago. Updated 6 days ago.

Status:
Resolved
Priority:
Low
Assignee:
Category:
Bugs in existing tests
Target version:
Start date:
2020-03-12
Due date:
2020-07-14
% Done:

0%

Estimated time:
5.00 h
Difficulty:
Duration: 89

Description

Observation

openQA test in scenario opensuse-Tumbleweed-KDE-Live-aarch64-kde_live_upgrade_leap_15.0@aarch64 fails in
live_installation

Instead of clicking the 'Upgrade' icon, it shows a bar on top of the screen to add widgets.

So problem is that when we do assert_and_click mouse click is hold for too long, so this overlay appears.
We could either act on overlay and retry starting upgrade or apply workaround and start upgrade from the kde desktop runner similarly to what we have on L51: https://github.com/os-autoinst/os-autoinst-distri-opensuse/pull/10474/files#diff-747319ea64cbca8d795af5d9a97e2163

Test suite description

Uses the live installer on the kde live media for upgrading the system.

+QEMURAM=2048 is necessary as the HDD_1 is only available for aarch64/64-bit and more RAM is necessary.

Reproducible

Fails since (at least) Build 20200309

Expected result

Last good: 20200226 (or more recent)

Further details

Always latest result in this scenario: latest

History

#1 Updated by okurz 4 months ago

This is an autogenerated message for openQA integration by the openqa_review script:

This bug is still referenced in a failing openQA test: kde_live_upgrade_leap_15.0
https://openqa.opensuse.org/tests/1211561

To prevent further reminder comments one of the following options should be followed:

  1. The test scenario is fixed by applying the bug fix to the tested product or the test is adjusted
  2. The openQA job group is moved to "Released"
  3. The label in the openQA scenario is removed

#2 Updated by riafarov 14 days ago

  • Subject changed from test fails in live_installation on Tumbleweed to [functional][y] test fails in live_installation on Tumbleweed
  • Due date set to 2020-07-14
  • Priority changed from Normal to Low
  • Target version set to future

More recent failure: https://openqa.opensuse.org/tests/1299354#
Issue is sporadic, and doesn't happen too often as per history of runs in openQA. So let's check what we can do in order to stabilize test execution.

#3 Updated by riafarov 14 days ago

  • Description updated (diff)
  • Status changed from New to Workable
  • Estimated time set to 5.00 h

#4 Updated by oorlov 6 days ago

  • Status changed from Workable to In Progress
  • Assignee set to oorlov

Also available in: Atom PDF