Project

General

Profile

action #63235

[qam] [maint] test fails in patch_and_reboot - dependency issue during aws-cli installation

Added by vsvecova over 2 years ago. Updated over 2 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
Bugs in existing tests
Target version:
-
Start date:
2020-02-07
Due date:
% Done:

0%

Estimated time:
Difficulty:

Description

Observation

mau-extratests-publiccloud testsuite started failing in patch_and_reboot due to a dependency/requirement mismatch.
The test has been failing since S:M:13632:210450 (aws-cli).

openQA test in scenario sle-15-SP1-EC2-BYOS-Updates-x86_64-mau-extratests-publiccloud@ec2_t2.large fails in
patch_and_reboot

Test suite description

Run mau-extratests on public cloud instances

Reproducible

Fails since (at least) Build 20200201-2

Expected result

Last good: 20200201-1 (or more recent)

Further details

Always latest result in this scenario: latest

History

#1 Updated by okurz over 2 years ago

This is an autogenerated message for openQA integration by the openqa_review script:

This bug is still referenced in a failing openQA test: mau-extratests-publiccloud@ec2_t2.large
https://openqa.suse.de/tests/3913288

To prevent further reminder comments one of the following options should be followed:

  1. The test scenario is fixed by applying the bug fix to the tested product or the test is adjusted
  2. The openQA job group is moved to "Released"
  3. The label in the openQA scenario is removed

#2 Updated by openqa_review over 2 years ago

This is an autogenerated message for openQA integration by the openqa_review script:

This bug is still referenced in a failing openQA test: mau-extratests-publiccloud@ec2_t2.large
https://openqa.suse.de/tests/3913288

To prevent further reminder comments one of the following options should be followed:

  1. The test scenario is fixed by applying the bug fix to the tested product or the test is adjusted
  2. The openQA job group is moved to "Released"
  3. The label in the openQA scenario is removed

#3 Updated by pdostal over 2 years ago

  • Status changed from New to Resolved

The update was rejected.

#4 Updated by msmeissn over 2 years ago

  • Status changed from Resolved to New

my first take it was a dependency issue,
but I think it is a problem with the test.

It does not seem to transfer the Public Cloud Module content of the test.

#5 Updated by msmeissn over 2 years ago

The problem is the testcase I think.

tests/publiccloud/transfer_repos.pm

does
$args->{my_instance}->run_ssh_command(cmd => "sudo find /tmp/repos/ -name *.repo -exec zypper ar '{}' \;");

however, all *.repo files from SUSE:Maintenance:13632 have:
[SUSE_Maintenance_13632]
...

So the basesystem, public cloud module, python2 etc ... all have the same repository alias "SUSE_Maintenance_13632"

Only the first module will be added, likely alphabetically this will be Basesystem, the other zypper ar will just report error as the alias is taken already.

#6 Updated by pdostal over 2 years ago

  • Status changed from New to Resolved

I fixed those problems by PR#9579.

Also available in: Atom PDF