Project

General

Profile

action #60245

[kernel][aarch64] Change NIC name between openQA jobs leads to missing NIC config

Added by pvorel almost 2 years ago. Updated 11 months ago.

Status:
Resolved
Priority:
High
Assignee:
Category:
Bugs in existing tests
Target version:
QE Kernel - QE Kernel Done
Start date:
2019-11-25
Due date:
% Done:

0%

Estimated time:
Difficulty:

Description

There is NIC rename between openQA jobs. create_hdd_minimal_base+sdk [1] see eth0, so it creates config /etc/sysconfig/network/ifcfg-eth0. But some jobs (at least install_ltp on aarch64 [2] and maybe iscsi_ibft on intel [3]), which use this qcow2 image have eth1, so it fails due NIC not configured.

Workaround for this issue is to move LTP networks specific config [5] to some common place.

High priority as it breaks SLE15-SP2 testing on aarch64.

NOTE: previously it looked as yast bug (see https://bugzilla.suse.com/1157896)
NOTE: it looked wicked tests are also affected [4], but according to different tags at history it probably not.

[1] https://openqa.suse.de/tests/3658114
[2] https://openqa.suse.de/tests/3661934
[3] https://openqa.suse.de/tests/3662282#step/hostname/10
[4] https://openqa.suse.de/tests/3625067#step/wicked/3
[5] https://github.com/os-autoinst/os-autoinst-distri-opensuse/blob/master/tests/kernel/boot_ltp.pm#L108

History

#1 Updated by pvorel almost 2 years ago

  • Project changed from SUSE QA to openQA Tests
  • Category set to Bugs in existing tests
  • Target version set to 445

#2 Updated by riafarov almost 2 years ago

As per our discussion, I still believe that this is a bug in a product, because configuring network with linuxrc is required for unattended installations only. So I would confirm if this regression is expected.

#3 Updated by pvorel almost 2 years ago

according to riafarov it's likely to be yast installer (or somewhere in between wicked and yast issue), continue tracking as https://bugzilla.suse.com/1157896 because

#4 Updated by pvorel almost 2 years ago

according to riafarov it's likely to be yast installer (or somewhere in between wicked and yast issue), continue tracking as https://bugzilla.suse.com/1157896 because

#5 Updated by pvorel almost 2 years ago

  • Status changed from New to Feedback
  • Assignee set to pvorel

#6 Updated by pvorel almost 2 years ago

  • Description updated (diff)

#7 Updated by pvorel almost 2 years ago

  • Subject changed from Missing install parameter ifcfg=*=dhcp for installer jobs to [yast] Missing install parameter ifcfg=*=dhcp for installer jobs

#8 Updated by pvorel almost 2 years ago

  • Description updated (diff)

#9 Updated by pvorel almost 2 years ago

  • Subject changed from [yast] Missing install parameter ifcfg=*=dhcp for installer jobs to [yast][aarch64] Missing install parameter ifcfg=*=dhcp for installer jobs

#10 Updated by pvorel almost 2 years ago

  • Status changed from Feedback to In Progress

While wainting for bsc#1157896 to be fixed, implementing workaround: moving LTP fix to sle15_workarounds.pm
https://github.com/pevik/os-autoinst-distri-opensuse/tree/workaround-for-bsc1157896

#12 Updated by pvorel almost 2 years ago

  • Subject changed from [yast][aarch64] Missing install parameter ifcfg=*=dhcp for installer jobs to [kernel][aarch64] Change NIC name between openQA jobs leads to missing NIC config
  • Description updated (diff)

#13 Updated by pvorel almost 2 years ago

  • Description updated (diff)

#14 Updated by pvorel almost 2 years ago

Hm, after finding, that openQA is to blame, it's obvious that fix cannot be in create_hdd_minimal_base+sdk, but in jobs after.
Do we want to fix root cause (force openQA to keep eth0 for jobs?) or use LTP workaround [5]?

If we decide to use workaround, where to put it? Ideally it should be run in each test. That'd probably require for modules to load sle15_workarounds.pm, which I wouldn't like (it's console test, which requires root-console because console tests uses needles) and also all tests which needs it would have to load this module :(.

#15 Updated by pvorel almost 2 years ago

  • Status changed from In Progress to Feedback

Workaround ready: https://github.com/os-autoinst/os-autoinst-distri-opensuse/pull/9078

NOTE: this is just a workaround, better would be to force QEMU to always use eth0 (as a separate ticket).

#16 Updated by pvorel almost 2 years ago

Also tip from Jozef Pupava: trying to use DROP_PERSISTENT_NET_RULES=1

#17 Updated by pvorel almost 2 years ago

  • Status changed from Feedback to In Progress

Hm, in the end it's udev thing (removing /etc/udev/rules.d/70-persistent-net.rules with DROP_PERSISTENT_NET_RULES=1). Solved by dzedro without needed code change: he added DROP_PERSISTENT_NET_RULES=1 to https://openqa.suse.de/tests/3666119 (create_hdd_minimal_base+sdk@aarch64-virtio) and then restarted install_ltp@ (https://openqa.suse.de/tests/3666153) which passed.

Closing https://github.com/os-autoinst/os-autoinst-distri-opensuse/pull/9078 and add going to add another PR where I remove LTP fallback code.

#19 Updated by pvorel almost 2 years ago

PR LTP: Remove workaround for missing NIC configuration
https://github.com/os-autoinst/os-autoinst-distri-opensuse/pull/9083

#20 Updated by pvorel almost 2 years ago

  • Status changed from In Progress to Feedback

PR merged, should be fixed in build after 101.1.

#21 Updated by pvorel almost 2 years ago

  • Status changed from Feedback to Resolved

#22 Updated by pvorel over 1 year ago

  • Target version changed from 445 to 457

#23 Updated by pcervinka 11 months ago

  • Target version changed from 457 to QE Kernel Done

Also available in: Atom PDF