Project

General

Profile

action #57743

[functional][y][timeboxed:8h] test tries to reboot when poweroff is given in shutdown

Added by ybonatakis about 2 years ago. Updated about 2 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
Bugs in existing tests
Target version:
SUSE QA - Milestone 29
Start date:
2019-10-07
Due date:
2019-10-22
% Done:

0%

Estimated time:
Difficulty:

Description

Observation

openQA test in scenario sle-15-SP2-Installer-DVD-s390x-cryptlvm@s390x-zVM-hsi-l2 fails in
shutdown

The shutdown module makes a call to the power_action to poweroff. I think the type_string "$action\n"; is not reach in power_action which makes the flow to check the else statement. from there it should drop into the poweroff_x11. Maybe it would be better to pass the textmode parameter explicitly in to the power_action.

This is cause by the change that we start testing gnome on s390x again and therefore use gnome menu to shutdown the system.
Console way of shutting down worked fine: https://openqa.suse.de/tests/3305529#step/shutdown/6

We need to investigate why gnome way doesn't work (maybe we don't press authenticate button).
If problem is not resolved, we need follow-up ticket to apply the solution.

Test suite description

Maintainers: okurz

Conduct installation with encrypted LVM selected during installation. Generated disk image used in downstream jobs.

(crypt-)LVM installations can take longer, especially on non-x86_64 architectures.

YAML_SCHEDULE=schedule/yaml/cryptlvm/cryptlvm_sle.yaml

Reproducible

Fails since (at least) Build 36.1

Expected result

Last good: 27.1 (or more recent)

Further details

Always latest result in this scenario: latest


Related issues

Related to openQA Tests - action #58127: [functional][y][timeboxed:16h] Fix shutdown from GUI on s390x backendResolved2019-10-142019-11-05

History

#1 Updated by riafarov about 2 years ago

  • Due date set to 2019-10-22
  • Target version set to Milestone 29

#2 Updated by riafarov about 2 years ago

  • Subject changed from [functional][y]test tries to reboot when poweroff is given in shutdown to [functional][y][timeboxed:8h] test tries to reboot when poweroff is given in shutdown
  • Description updated (diff)
  • Status changed from New to Workable

#3 Updated by oorlov about 2 years ago

  • Status changed from Workable to In Progress
  • Assignee set to oorlov

#4 Updated by oorlov about 2 years ago

  • Related to action #58127: [functional][y][timeboxed:16h] Fix shutdown from GUI on s390x backend added

#5 Updated by oorlov about 2 years ago

  • Status changed from In Progress to Resolved

Also available in: Atom PDF