Project

General

Profile

tickets #56189

susepaste command from openSUSE shell logins is failing with "Paste failed :-("

Added by mrmazda about 2 years ago. Updated 6 months ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
Servers hosted by community
Target version:
-
Start date:
2019-08-31
Due date:
% Done:

100%

Estimated time:

Description

Multiple people in forums since yesterday have been unable to upload to susepaste.org via cmdline. https://forums.opensuse.org/showthread.php/537339-GRUB-mashed-up-after-latest-Windows-10-Pro-update-(dual-boot-uefi)?p=2912905 has one. When I try I with two different 15.1 installations I repeatedly get "Paste failed :-(". I noticed when yesterday having trouble connecting to B.O.O., forums and elsewhere on opensuse.org, among the delay messages was "waiting for www.suse.com" that just sat unchanged in the status bar.

History

#1 Updated by cboltz about 2 years ago

  • Category set to Servers hosted by community
  • Assignee set to _miska_
  • Private changed from Yes to No

#2 Updated by cboltz about 2 years ago

The problem still exists, and gets discussed on the opensuse@o.o mailinglist currently.

One user reported that replacing http with https in the susepaste script helps, but a) I can't reproduce that and b) susepaste in tumbleweed was changed and got the -s parameter.

Funnily creating the paste actually works (you'll find it if you check on https://paste.opensuse.org/lists ) - but the script tells you "Paste failed :-("

Some testing (adding an "echo") indicates that $URL seems to be empty, while I'd expect it to be set from the curl ... | sed ... call.

If I drop the sed call, the curl result includes

< location: https://susepaste.org/73245968

but the script does

sed -n 's|<\ Location:\ ||p'

with an uppercase L in Location, and unsurprisingly that doesn't match the lowercase location header.

Do you have any idea why the server returns lowercase header names and, more important, can you please fix that? ;-)

#3 Updated by mrmazda over 1 year ago

#4 Updated by cboltz over 1 year ago

  • Status changed from New to Feedback

Felix, your last comment indicates that the fix needs to be done in the susepaste script. Can you please open a bugreport for susepaste?

#5 Updated by lrupp over 1 year ago

  • Status changed from Feedback to Closed
  • % Done changed from 0 to 100

No feedback after over a month. Closing here.
Feel free to reopen by replying to this Email.

#7 Updated by lrupp over 1 year ago

  • Status changed from Closed to In Progress
  • % Done changed from 100 to 20

mrmazda wrote:

https://bugzilla.opensuse.org/show_bug.cgi?id=1166669 reported

Thanks. FYI: Added links to the bug and this issue at
https://build.opensuse.org/package/show/devel:tools/susepaste

Let's wait a few days for the developers...

#8 Updated by hellcp 6 months ago

  • Status changed from In Progress to Resolved
  • % Done changed from 20 to 100

At this point I see this is stuck at maintenance/release managers with Leap 15.1, nothing we can really do or assist with, it's done from our side

Also available in: Atom PDF