Project

General

Profile

action #55751

Formatting for <br> and <code> tags in job description and group comments broken

Added by rpalethorpe over 3 years ago. Updated about 3 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
Concrete Bugs
Target version:
Start date:
2019-08-20
Due date:
% Done:

0%

Estimated time:
Difficulty:

Description

Previously we could write to force a line break in comments. Also we could use tags.

It seems these are now ignored or filtered. See:
https://openqa.suse.de/group_overview/155

and https://openqa.suse.de/tests/3262174#comment-195942

hint Look at the raw text

For job group descriptions we can switch to using Markdown style code sections if that works. However we need the tags for comments because they are submitted as a single line of text to the openqa cli. Of course someone could fix the cli and newline handling in comments.

History

#1 Updated by okurz over 3 years ago

  • Category set to Concrete Bugs
  • Assignee changed from okurz to kraih

kraih you worked on the comment rendering so I guess you can take this

#2 Updated by coolo over 3 years ago

  • Category changed from Concrete Bugs to Feature requests
  • Assignee deleted (kraih)
  • Priority changed from High to Normal

See the following mail:

[openqa] Changes to Markdown comments

#3 Updated by rpalethorpe over 3 years ago

  • Category deleted (Feature requests)

We definitely don't need raw html. So looks like kraih will solve the problem with posting comments with new lines.

I can replace blocks with markdown code blocks. Only issue is there is no syntax highlighting for TOML, but this is not important. On the other hand, the blocks were displayed in pink, whereas the markdown triple quote blocks are not, which might be a regression. I personally don't care much about that, just pointing it out.

#4 Updated by kraih over 3 years ago

  • Status changed from New to In Progress
  • Assignee set to kraih

I've opened a pull request to fix newline handling in openqa-client. https://github.com/os-autoinst/openQA/pull/2272

#6 Updated by rpalethorpe over 3 years ago

So it appears to be fixed in the package from devel, however Factory and Leap15.1 seem to need updating.

#7 Updated by rpalethorpe over 3 years ago

Installing just openqa-client from devel on a fresh Leap15.1 install I get:

Can't locate IPC/Run.pm in @INC (you may need to install the IPC::Run module) (@INC contains: /usr/share/openqa/script/../lib /usr/lib/perl5/site_perl/5.28.1/x86_64-linux-thread-multi /usr/lib/perl5/site_perl/5.28.1 /usr/lib/perl5/vendor_perl/5.28.1/x86_64-linux-thread-multi /usr/lib/perl5/vendor_perl/5.28.1 /usr/lib/perl5/5.28.1/x86_64-linux-thread-multi /usr/lib/perl5/5.28.1 /usr/lib/perl5/site_perl) at /usr/share/openqa/script/../lib/OpenQA/Utils.pm line 22.
BEGIN failed--compilation aborted at /usr/share/openqa/script/../lib/OpenQA/Utils.pm line 22.
Compilation failed in require at /usr/share/openqa/script/../lib/OpenQA/Parser.pm line 32.
BEGIN failed--compilation aborted at /usr/share/openqa/script/../lib/OpenQA/Parser.pm line 32.
Compilation failed in require at /usr/share/openqa/script/../lib/OpenQA/Parser/Results.pm line 22.
BEGIN failed--compilation aborted at /usr/share/openqa/script/../lib/OpenQA/Parser/Results.pm line 22.
Compilation failed in require at /usr/share/openqa/script/../lib/OpenQA/Parser/Result.pm line 22.
BEGIN failed--compilation aborted at /usr/share/openqa/script/../lib/OpenQA/Parser/Result.pm line 22.
Compilation failed in require at /usr/lib/perl5/vendor_perl/5.28.1/Mojo/Base.pm line 133.
BEGIN failed--compilation aborted at /usr/share/openqa/script/../lib/OpenQA/File.pm line 18.
Compilation failed in require at /usr/share/openqa/script/../lib/OpenQA/Client/Upload.pm line 21.
BEGIN failed--compilation aborted at /usr/share/openqa/script/../lib/OpenQA/Client/Upload.pm line 21.
Compilation failed in require at /usr/share/openqa/script/../lib/OpenQA/Client.pm line 20.
BEGIN failed--compilation aborted at /usr/share/openqa/script/../lib/OpenQA/Client.pm line 20.
Compilation failed in require at /usr/bin/openqa-client line 144.
BEGIN failed--compilation aborted at /usr/bin/openqa-client line 144.

Didn't happen before when installing from the main repo.

#8 Updated by okurz over 3 years ago

that should be fixed with https://github.com/os-autoinst/openQA/pull/2290 in devel:openQA. The package in openSUSE Leap 15.1 will most likely not be updated until 15.2 however feel free to provide a maintenance request (for a bug report) to update the package. The Tumbleweed package is currently not updated due to #54467

#9 Updated by kraih over 3 years ago

  • Status changed from In Progress to Feedback

#10 Updated by coolo about 3 years ago

  • Category set to Concrete Bugs
  • Status changed from Feedback to Resolved
  • Target version set to Done

I consider this done

Also available in: Atom PDF