action #55571

openQA Infrastructure - action #55178: ** PROBLEM Service Alert: openqa.suse.de/fs_/var/lib/openqa is WARNING **

action #55556: [epic][osd][functional][u] osd: Untracked assets that most likely should be tracked

[osd][staging][sle] Untracked assets that most likely should be tracked: SLE staging

Added by okurz about 1 month ago. Updated about 1 month ago.

Status:ResolvedStart date:15/08/2019
Priority:HighDue date:
Assignee:andriinikitin% Done:

0%

Category:Bugs in existing tests
Target version:-
Difficulty:
Duration:

Description

Observation

The space available on osd is limited. https://openqa.suse.de/admin/assets reveals some assets as "untracked" but probably they should be tracked by jobs, for example the following subset:

iso/SLE12-SP5-Staging:P-Test-Server-DVD-x86_64-BuildP.33.1-Media.iso 3.85 GiB
iso/SLE12-SP5-Staging:P-Test-Server-DVD-x86_64-BuildP.32.1-Media.iso 3.85 GiB
iso/SLE12-SP5-Staging:P-Test-Server-DVD-x86_64-BuildP.31.1-Media.iso 3.84 GiB

History

#1 Updated by okurz about 1 month ago

  • Copied from action #55568: [jeos][osd] Untracked assets that most likely should be tracked: JeOS added

#2 Updated by okurz about 1 month ago

  • Assignee set to andriinikitin

@andriinikitin am I right to assume that by now the syncing and triggering of SLE staging is done by OBS trigger? So then you are the right person to contact. See http://open.qa/docs/#_asset_handling for details regarding asset handling. The mentioned assets need to be accounted for by according jobs using them, e.g. using the ISO variable or ISO_1.

#3 Updated by okurz about 1 month ago

  • Copied from deleted (action #55568: [jeos][osd] Untracked assets that most likely should be tracked: JeOS)

#4 Updated by okurz about 1 month ago

  • Parent task set to #55556

#5 Updated by okurz about 1 month ago

  • Copied to action #55574: [osd][sle][functional][y] Untracked assets that most likely should be tracked: s390x iso files that are not used (should be not even synced) added

#6 Updated by okurz about 1 month ago

  • Copied to deleted (action #55574: [osd][sle][functional][y] Untracked assets that most likely should be tracked: s390x iso files that are not used (should be not even synced))

#7 Updated by riafarov about 1 month ago

So, we have not found any traces of staging:P, there is no run in openQA, there are no logs and naming pattern we have in obs sync plugin is different: SLE-15-SP2-Staging:C-Installer-DVD-x86_64-BuildC.14.1-Media1.iso

Also, I can see that we have [2019-08-12T16:56:19.0131 CEST] [info] Registering asset repo/SLE-15-SP2-Staging:C-Module-RT-POOL-x86_64--Media1 in the openQA logs, but there is not run in openQA with such setting.
Looks like those were triggered by someone else, not even sure where. @okurz, feel fancy to do some queries in DB on osd?

#8 Updated by andriinikitin about 1 month ago

riafarov wrote:

So, we have not found any traces of staging:P

Just to clarify this - all what Obs Rsync plugin does should be visible at https://openqa.suse.de/admin/obs_rsync/ and Staging:P is not there. So it really looks that something else triggered the build

#9 Updated by okurz about 1 month ago

alright. Do you plan to look into this as you are still assigned?

#10 Updated by okurz about 1 month ago

To make it clear: We are running the rsync.pl process on osd and this one is syncing staging:P:

root     25040  0.0  0.0  73896  4352 ?        S    17:44   0:00  \_ /usr/sbin/CRON -n
geekote+ 25043  0.0  0.0  11872  2548 ?        Ss   17:44   0:00      \_ /bin/sh -c /opt/openqa-scripts/openqa-iso-sync-staging >> /var/log/openqa_rsync_staging.log 2>&1
geekote+ 25044  0.0  0.0  11872  2604 ?        S    17:44   0:00          \_ /bin/bash /opt/openqa-scripts/openqa-iso-sync-staging
geekote+ 25051 10.2  0.3 130168 49500 ?        R    17:44   0:17              \_ /usr/bin/perl -w /opt/openqa-scripts/rsync.pl --host openqa.suse.de --verbose sle12_sp5_staging

#11 Updated by andriinikitin about 1 month ago

okurz wrote:

To make it clear: We are running the rsync.pl process on osd and this one is syncing staging:P:

Yes, @okurz - it looks Staging:P is not mentioned in job template https://openqa.suse.de/admin/job_templates/50
Can it be the reason?

#12 Updated by okurz about 1 month ago

well, when it's not necessary it should not be mentioned. The problem is that it's synced when it shouldn't be. Will you handle this?

#13 Updated by andriinikitin about 1 month ago

okurz wrote:

well, when it's not necessary it should not be mentioned. The problem is that it's synced when it shouldn't be. Will you handle this?

Ah, ok. Then I believe it needs some negative filter for Staging:P in sle_12 settings around https://gitlab.suse.de/openqa/scripts/blob/master/rsync_sle.pm#L70 or some other hack. I don't really modify those scripts often, but if you think I am the best person to look at it - I will give a try tomorrow of Wednesday.

#14 Updated by okurz about 1 month ago

I'm just asking what your plans are. If you can manage this, great, otherwise feel free to ask me or assign the ticket to me.

#15 Updated by andriinikitin about 1 month ago

This should work in my understanding, at least --dry --verbose mode doesn't mention Staging:P anymore:
https://gitlab.suse.de/openqa/scripts/merge_requests/379

#16 Updated by andriinikitin about 1 month ago

  • Status changed from New to Closed

#17 Updated by okurz about 1 month ago

  • Status changed from Closed to Resolved

Please use just "Resolved", see https://progress.opensuse.org/projects/openqav3/wiki/#ticket-workflow for details. I have deleted one more iso file manually, should be good now.

Also available in: Atom PDF