Project

General

Profile

tickets #53699

need a VM for running apache+vbulletin

Added by pjessen almost 3 years ago. Updated about 2 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
Project work
Target version:
-
Start date:
2019-07-02
Due date:
% Done:

100%

Estimated time:

Description

To replace the forums setup in Provo.
Requirements - maybe 4Gb of memory, plus space for a database of 20Gb.
Not urgent - can wait until August 2-3 when I'm back from summer hols.

History

#1 Updated by pjessen almost 3 years ago

  • Private changed from Yes to No

#2 Updated by pjessen over 2 years ago

I have received a tarball with the vBulletin stuff (thank you Kim Groneman), am now waiting for a database dump.

#3 Updated by pjessen over 2 years ago

Karol, when you've got a moment -

the machine needs an external IP address, IPv6 would be nice too. The intention is to run apache with vbulletin, mariadb, postfix and inn.
All self-contained for 'forums.o.o'.

Still waiting for a database dump.

#4 Updated by lrupp over 2 years ago

  • Category set to Project work

Is this still on todo?

#5 Updated by kbabioch over 2 years ago

  • Assignee changed from kbabioch to pjessen

I guess it depends on whom you ask. Some people had serious concerns and don't like to run vbulletin at all.

pjessen what is your take on this? Will you still need such a VM?

#6 Updated by pjessen over 2 years ago

I still don't have a database dump, but yes, eventually I will need a machine to run the forums. I also don't care much for vBulletin, but that is what we currently have to work with. (anything else only means more work).

#7 Updated by lrupp over 2 years ago

  • Status changed from New to Feedback

What database are we talking about?
We have a MySQL cluster and PostgreSQL machines up and running that we can use.

about the dedicated host for the application: I guess the main blocker is currently.the name of the machine ;-)
I hope forums.infra.o.o is ok?
In that case, I will setup the machine in the next hours for you.

Regards,
Lars

#8 Updated by lrupp over 2 years ago

lrupp wrote:

In that case, I will setup the machine in the next hours for you.

Machine is ready and waiting for admins... ;-)

#9 Updated by lrupp over 2 years ago

lrupp wrote:

Machine is ready and waiting for admins... ;-)

JFYI: machine is now also in Salt.

#10 Updated by pjessen over 2 years ago

  • Status changed from Feedback to In Progress

Thanks Lars - yes, it makes more sense to use our database cluster, certainly.
I still have not received any database dump from Provo, and when I do, it'll be 2 months out of date ....

forums.infra.o.o is fine.

#11 Updated by pjessen over 2 years ago

  • Status changed from In Progress to Feedback

For the moment, I see only:

forum.infra.o.o = 192.168.47.76, forums.infra.o.o does not resolve.

I can't log on to forum.infra.o.o. am I missing something?

#12 Updated by cboltz over 2 years ago

Looks like nobody did the initial salt highstate to configure the base system (which includes SSH logins via FreeIPA accounts).

I just did that, therefore you should be able to login as user now. However, sudo is not configured yet - my proposal would be to setup a group "forum-admins" (only with you?) , and to add a sudo rule for that group via salt. I'm looking forward for your MR for the sudo config ;-)

#13 Updated by pjessen over 2 years ago

  • Priority changed from Low to Normal

cboltz wrote:

Looks like nobody did the initial salt highstate to configure the base system (which includes SSH logins via FreeIPA accounts).
I just did that, therefore you should be able to login as user now.

Thanks Christian, yep, I'm in.

However, sudo is not configured yet - my proposal would be to setup a group "forum-admins" (only with you?) , and to add a
sudo rule for that group via salt. I'm looking forward for your MR for the sudo config ;-)

I was able to "sudo -i", which is sufficient for me.

Slight problem - afaict, vBulletin 4.2.2 is not compatible with php 7.2, only (apparently) php 7.1. Without a database, I have not been able to verify this.

#14 Updated by pjessen over 2 years ago

Any chance of getting Leap42.3 installed on a VM ? That way we can:

  1. now: get the vBulletin setup moved over
  2. later: work on improving or moving the setup.

SLE12 might be an alternative, I'm just not familiar with the contents.

#15 Updated by pjessen over 2 years ago

How about SLE12SP5 ? which is still under maintenance.

#16 Updated by lrupp over 2 years ago

  • Status changed from Feedback to In Progress
  • Assignee changed from pjessen to opensuse-admin

pjessen wrote:

How about SLE12SP5 ? which is still under maintenance.

This sounds more reasonable to me. If nobody else is faster, I will overwrite the current forums.i.o.o machine with a SLE12SP5 image next week. Stay tuned, please.

#17 Updated by lrupp over 2 years ago

  • Status changed from In Progress to Feedback
  • Assignee changed from opensuse-admin to cboltz

#19 Updated by pjessen over 2 years ago

  • Status changed from Feedback to In Progress

I installed redis, to be a little bit prepared for discourse, you can ignore it.

#21 Updated by lrupp about 2 years ago

  • Status changed from In Progress to Closed
  • % Done changed from 0 to 100

Closing this ticket, as we can use 15.1 with the new software license bought (by the board?).

Also available in: Atom PDF