Project

General

Profile

action #51944

[opensuse][functional][u] test fails in dolphin -- "kdialog --getopenfilename" fails to start

Added by StefanBruens over 2 years ago. Updated almost 2 years ago.

Status:
Rejected
Priority:
Normal
Assignee:
Category:
Bugs in existing tests
Target version:
SUSE QA - Milestone 28
Start date:
2019-05-23
Due date:
% Done:

0%

Estimated time:
42.00 h
Difficulty:

Description

Observation

openQA test in scenario opensuse-Tumbleweed-DVD-x86_64-kde@64bit fails in
dolphin

Test fails in all scenarios (Regular system, live, new install, upgrade ...).

Test suite description

TIMEOUT_SCALE property is added to avoid sporadic shutdown fails in kde@USBboot_64 scenario.

Added by : oorlov;

Related ticket: poo#37000

Reproducible

Fails since (at least) Build 20190522 (current job)

Expected result

Last good: 20190521 (or more recent)

Further details

Always latest result in this scenario: latest


Related issues

Related to openQA Tests - action #53045: [opensuse][kde][sporadic] krunner suggestions check is racyNew2019-06-13

Related to openQA Tests - action #35589: [functional][u][opensuse][sporadic][medium] test fails in kontact - needs workaround for boo#1105207, then akregator not closedRejected2018-04-26

History

#1 Updated by StefanBruens over 2 years ago

This seems to be a problem in krunner, as it fails to start any program on first attempt, watch the video starting here:

https://openqa.opensuse.org/tests/940920/file/video.ogv#t=715.21,715.25

And according to the journal, krunner wants to tell us something:

May 23 14:33:19 susetest krunner[1588]: 
May 23 14:34:06 susetest krunner[1588]: 
May 23 14:34:53 susetest krunner[1588]: 
May 23 14:35:39 susetest krunner[1588]:  

https://openqa.opensuse.org/tests/940920/file/dolphin-journal.log

#3 Updated by SLindoMansilla over 2 years ago

  • Subject changed from test fails in dolphin -- "kdialog --getopenfilename" fails to start to [opensuse] test fails in dolphin -- "kdialog --getopenfilename" fails to start

As a result of backlog triaging (see https://progress.opensuse.org/projects/openqatests/wiki#ticket-backlog-triaging for more information).

Please, feel free to adjust the category or the "[label]" if you think different.

#5 Updated by StefanBruens over 2 years ago

I wouldn't consider "Tries to start 10 times, fails 10 times, and falls through" "fine". There are at least 5 test cases (oowriter, oocalc, oomath, dolphin, amarok) which are affected by this (25 minutes wasted for this scenario alone).

https://openqa.opensuse.org/tests/latest?flavor=DVD&version=Tumbleweed&test=kde&arch=x86_64&distri=opensuse&machine=64bit

#6 Updated by okurz over 2 years ago

  • Related to action #53045: [opensuse][kde][sporadic] krunner suggestions check is racy added

#7 Updated by okurz over 2 years ago

  • Related to action #35589: [functional][u][opensuse][sporadic][medium] test fails in kontact - needs workaround for boo#1105207, then akregator not closed added

#8 Updated by zluo almost 2 years ago

  • Subject changed from [opensuse] test fails in dolphin -- "kdialog --getopenfilename" fails to start to [opensuse][functional][u] test fails in dolphin -- "kdialog --getopenfilename" fails to start
  • Status changed from New to In Progress
  • Assignee set to zluo
  • Target version set to Milestone 28
  • Estimated time set to 42.00 h

take over and check

#9 Updated by zluo almost 2 years ago

  • Status changed from In Progress to Rejected

https://openqa.opensuse.org/tests/1109749#next_previous shows this issue got gone.
reject for now.

Also available in: Atom PDF