Project

General

Profile

action #51725

[s390x][kvm] test fails in bootloader_zkvm

Added by osukup about 1 year ago. Updated 12 months ago.

Status:
Resolved
Priority:
Immediate
Assignee:
Category:
Bugs in existing tests
Target version:
SUSE QA tests - Done - kernel&network
Start date:
2019-05-21
Due date:
% Done:

30%

Estimated time:
Difficulty:
Duration:

Description

Observation

culprit : https://github.com/os-autoinst/os-autoinst/commit/0c2b93ad018ad2ba6b653a614c194640ca84e55f

openQA test in scenario sle-15-Installer-DVD-QR-s390x-btrfs@s390x-kvm-sle15 fails in
bootloader_zkvm

Test suite description

Maintainers: okurz

Test installation with explicit selection of btrfs filesystem during installation. Tests installation only.

Reproducible

Fails since (at least) Build 0024

Expected result

Last good: 0023 (or more recent)

Further details

Always latest result in this scenario: latest

s390zp13.suse.de.openQA-SUT-2.xml (813 Bytes) s390zp13.suse.de.openQA-SUT-2.xml /var/lib/libvirt/images/openQA-SUT-2.xm from s390zp13.suse.de pvorel, 2019-05-21 11:46
s390zp13.suse.de.openQA-SUT-2.dumped.xml (2.26 KB) s390zp13.suse.de.openQA-SUT-2.dumped.xml Dumped xml from working job on s390zp13.suse.de pvorel, 2019-05-21 11:46

History

#1 Updated by SLindoMansilla about 1 year ago

  • Subject changed from test fails in bootloader_zkvm to [s390x][kvm] test fails in bootloader_zkvm
  • Status changed from New to Workable
  • Assignee set to michalnowak
  • Priority changed from Normal to Immediate

Hi Michal,

Could you take a look at this?

If this cannot be fixed today, I will need to revert that PR to unblock people working on s390x-kvm while it is fixed.

#2 Updated by pvorel about 1 year ago

Hm, strange, it works well on openqa instance we share with osukup
http://quasar.suse.cz/tests/2655

used packages on quasar:
os-autoinst-distri-opensuse-deps-1.1558352460.ea728ae13-12.1.noarch
http://quasar.suse.cz/tests/2655/file/autoinst-log.txt
[2019-05-21T11:28:36.562 CEST] [debug] Current version is 4.5.1557827957.ce72694e [interface v14]

qemu-x86-2.11.2-9.25.1.x86_64
libvirt-4.0.0-9.19.4.x86_64

Broken version on osd:
https://openqa.suse.de/tests/2907761/file/autoinst-log.txt
[2019-05-21T09:02:29.401 CEST] [debug] Current version is 4.5.1557391016.927f3d85 [interface v14]
=> 927f3d85 already has required changes in os-autoinst.

Error on osd:
https://openqa.suse.de/tests/2907761/file/autoinst-log.txt

error: Failed to define domain from /var/lib/libvirt/images/openQA-SUT-2.xml
error: unsupported configuration: Only the first console can be a serial port
[2019-05-21T09:02:53.159 CEST] [debug] Command executed: 'virsh  define /var/lib/libvirt/images/openQA-SUT-2.xml', ret=1

I'll dig into logs more, but it'd help me to have access to osd.

#3 Updated by pvorel about 1 year ago

It'd have helped a lot if failing libvirt xml file (/var/lib/libvirt/images/openQA-SUT-2.xml here) was uploaded into assets (or printed to logs) and reported libvirt version (or anything else which can affect it). Too late now, but we should implement it later. At least QEMU reports it's version.

#4 Updated by pvorel about 1 year ago

Error message from libvirt
https://libvirt.org/git/?p=libvirt.git;a=blob;f=src/conf/domain_conf.c;h=a3a514136b58458f290e9a4c3813b83bb800bb07;hb=HEAD#l4507

vas added long time ago in v1.0.5-rc1 (2013), I guess it'll be affected by some setup, not libvirt version.
https://libvirt.org/git/?p=libvirt.git;a=commitdiff;h=482e5f159c24ba8b25b195de92b7266bb2a92820;hp=46becc18ba125d0fbe2b39c054a105fe9c97c5ab

It'd really help me to see the config /var/lib/libvirt/images/openQA-SUT-2.xml.

#5 Updated by pvorel about 1 year ago

Sending configs from s390zp13.suse.de, which is used on my openQA devel machine and it's working (http://quasar.suse.cz/tests/2655)

#6 Updated by pvorel about 1 year ago

OK, didn't realize that credentials are available in test assets :).

#7 Updated by pvorel about 1 year ago

  • Assignee changed from michalnowak to pvorel
  • Target version set to Current Sprint - kernel

#8 Updated by pvorel about 1 year ago

libvirt configuration was tested on s390zp13.suse.de, which has SLES 12-SP3 (libvirt 3.3.0-5.25.1, qemu 2.9.1-6.28.1), but osd runs on s390p7.suse.de, which has SLE 15 (libvirt 4.0.0-9.3.1, qemu 2.11.2-9.9.1). So I need to find config, which will run on both or do different config according to working class (s390-kvm-sle12 vs. s390-kvm-sle15).

#9 Updated by pvorel about 1 year ago

It looks like it's just about correct order of elements:
sclp must be the second:

<console type="pty">
  <target port="1"/>
</console>
<console type="pty">
  <target type="sclp" port="0"/>
</console>

#10 Updated by pvorel about 1 year ago

PR for debugging (not solving the problem):
https://github.com/os-autoinst/os-autoinst/pull/1154

#11 Updated by pvorel about 1 year ago

  • Status changed from Workable to In Progress

#12 Updated by pvorel about 1 year ago

pvorel wrote:

It looks like it's just about correct order of elements:
sclp must be the second:

<console type="pty">
  <target port="1"/>
</console>
<console type="pty">
  <target type="sclp" port="0"/>
</console>

Actually xml needs to be different, WIP to find correct one for SLE15.

#13 Updated by pvorel about 1 year ago

  • % Done changed from 0 to 30

#14 Updated by SLindoMansilla about 1 year ago

  • Blocks action #33388: [functional][u][easy][pvm] Implement proper split from other backends added

#15 Updated by pvorel about 1 year ago

As a solution might take more time, we agreed with mgriessmeier, that I'll create a PR for testing repository, which temporarily disables svirt serial backend.

#16 Updated by pvorel about 1 year ago

Fix temporarily reverting it (so we have GMC3 fixed):
https://github.com/os-autoinst/os-autoinst-distri-opensuse/pull/7524

#17 Updated by pvorel about 1 year ago

Created fix, which enables svirt serial backend.
TL;DR: missing attribute type="virtio" in tag (thus newer libvirt versions taken default type="sclp" which is already used).

https://github.com/os-autoinst/os-autoinst-distri-opensuse/pull/7529

Run quite a lot of tests (see verification run) + much more on http://quasar.suse.cz/tests.

Could anyone double check verification run jobs, that my assumptions are correct?
I'd be for merging soon, but you probably prefer to do it after GM.

#18 Updated by zluo almost 1 year ago

  • Blocks deleted (action #33388: [functional][u][easy][pvm] Implement proper split from other backends)

#19 Updated by pvorel 12 months ago

  • Status changed from In Progress to Resolved

Fixed in this PR https://github.com/os-autoinst/os-autoinst-distri-opensuse/pull/7529
There are still some issues with install_ltp.pm, but that can be workarounded with SERIAL_CONSOLE=0 settings.

#20 Updated by jlausuch 12 months ago

  • Target version changed from Current Sprint - kernel to Done - kernel&network

Also available in: Atom PDF