action #51635

[network] test fails in t08_setup_second_card

Added by dimstar 5 months ago. Updated 2 months ago.

Status:ResolvedStart date:20/05/2019
Priority:NormalDue date:
Assignee:okurz% Done:

0%

Category:Bugs in existing tests
Target version:-
Difficulty:
Duration:

Description

Observation

openQA test in scenario opensuse-Tumbleweed-DVD-x86_64-wicked_basic_sut@64bit fails in
t08_setup_second_card

Test suite description

Include basic sanity checks of wicked network framework
Maintainer: asmorodskyi@suse.de

Reproducible

Fails since (at least) Build 20190517

Expected result

Last good: 20190421 (or more recent)

Further details

Always latest result in this scenario: latest

This test has never passed on Tumbleweed: for a while, the 'parent job' did not pass, which made the child not start at all. The last time it ran, this test was not yet active


Related issues

Related to openQA Tests - action #52499: [aarch64] Proper multi-machine test setup and wicked_basi... Resolved 03/06/2019
Blocked by openQA Tests - action #52559: [network] test fails in t01_basic to ping the other node Resolved 04/06/2019

History

#1 Updated by SLindoMansilla 5 months ago

  • Subject changed from test fails in t08_setup_second_card to [network] test fails in t08_setup_second_card

#2 Updated by asmorodskyi 5 months ago

  • Status changed from New to In Progress
  • Assignee set to asmorodskyi

#3 Updated by asmorodskyi 5 months ago

  • Status changed from In Progress to Feedback

new test added to wicked_basic requires additional variable which would enable second interface in VM . Missed to add this variable .
Variable added waiting for re-run test to make sure that issue is fixed

#4 Updated by asmorodskyi 5 months ago

  • Status changed from Feedback to Workable

looks like o3 infra not ready to support test with two NICs https://openqa.opensuse.org/tests/938212/file/autoinst-log.txt

needs to setup extra tap devices

#5 Updated by okurz 4 months ago

  • Related to action #52499: [aarch64] Proper multi-machine test setup and wicked_basic successfully tested (was: wicked tests always in schedule state - tap worker required) added

#6 Updated by okurz 4 months ago

  • Blocked by action #52559: [network] test fails in t01_basic to ping the other node added

#7 Updated by asmorodskyi 3 months ago

openqaworker1 does not have dedicated devices for second NIC ( tap64,tap65 etc. ) investigating how they "disappear" from server setup

#8 Updated by okurz 3 months ago

Maybe we never had them. What I did now to add the devices to the bridge on both openqaworker1 as well as aarch64:

for i in {64..69} {128..133}; do echo OVS_BRIDGE_PORT_DEVICE_$i=\'tap$i\' ; done >> /etc/sysconfig/network/ifcfg-br1 && wicked ifup br1

I guess we can monitor https://openqa.opensuse.org/tests/983074 then.

https://openqa.opensuse.org/tests/983074#step/t08_setup_second_card/176 fails with " # Test died: script failed with : k7lmN Command line is not complete. Try option "help"
There is no argument to "wicked ifup" it seems

#9 Updated by okurz 3 months ago

  • Status changed from Workable to Feedback
  • Assignee changed from asmorodskyi to okurz

Since 17 days in https://openqa.opensuse.org/tests/986212 this is pretty stable "soft-failed" now. I moved wicked_basic_sut and wicked_basic_ref from the Development Tumbleweed job group to Tumbleweed

#10 Updated by okurz 2 months ago

  • Status changed from Feedback to Resolved

wicked_basic now stable and in the corresponding product validation job groups for both x86_64 and aarch64

Also available in: Atom PDF