Project

General

Profile

action #51479

Some jobs don't get all the %variables% properly expanded

Added by szarate about 1 year ago. Updated about 1 year ago.

Status:
Rejected
Priority:
High
Assignee:
Category:
Concrete Bugs
Target version:
Start date:
2019-05-15
Due date:
% Done:

0%

Estimated time:
Difficulty:
Duration:

Description

Looking at reported jobs:

It seems that the problems are related to a recent PR https://github.com/os-autoinst/openQA/pull/2057 that changed the behavior on how the variables are processed.

https://openqa.suse.de/tests/2894128 this job has the problem, if you look at the create_hdd_minimal_base+sdk test suite definition:

ADDONURL_SDK=ftp://openqa.suse.de/SLE-%VERSION%-SDK-POOL-%ARCH%-Build%BUILD_SDK%-Media1/
DESKTOP=textmode
DEV_IMAGE=1
HDDSIZEGB=50
INSTALLONLY=1
PATTERNS=base,minimal
PUBLISH_HDD_1=SLES-%VERSION%-%ARCH%-%BUILD%@%MACHINE%-minimal_with_sdk%BUILD_SDK%_installed.qcow2
PUBLISH_PFLASH_VARS=SLES-%VERSION%-%ARCH%-%BUILD%@%MACHINE%-minimal_with_sdk%BUILD_SDK%_installed-uefi-vars.qcow2
SEPARATE_HOME=0
WORKAROUND_MODULES=base,desktop,serverapp,script,sdk

Related issues

Is duplicate of openQA Project - action #20464: [scheduling] Job created with "jobs post" not expand specified MACHINE variableResolved2017-07-14

History

#1 Updated by szarate about 1 year ago

  • Subject changed from Some jobs don't get all the variables properly expanded to Some jobs don't get all the %variables% properly expanded
  • Priority changed from Normal to Urgent

#2 Updated by mgriessmeier about 1 year ago

  • Subject changed from Some jobs don't get all the %variables% properly expanded to Some jobs don't get all the variables properly expanded
  • Priority changed from Urgent to Immediate

#3 Updated by mgriessmeier about 1 year ago

  • Subject changed from Some jobs don't get all the variables properly expanded to Some jobs don't get all the %variables% properly expanded

#4 Updated by szarate about 1 year ago

  • Status changed from New to In Progress
  • Priority changed from Immediate to High

Currently Marius reverted the change:

git revert -m 1 8fcf53985e8085a9a63c62971e98ba88ee5d9971

So openQA it's hot patched. Just something to take into account

#5 Updated by szarate about 1 year ago

  • Related to action #20464: [scheduling] Job created with "jobs post" not expand specified MACHINE variable added

#6 Updated by szarate about 1 year ago

  • Related to deleted (action #20464: [scheduling] Job created with "jobs post" not expand specified MACHINE variable)

#7 Updated by szarate about 1 year ago

  • Is duplicate of action #20464: [scheduling] Job created with "jobs post" not expand specified MACHINE variable added

#8 Updated by szarate about 1 year ago

  • Status changed from In Progress to Rejected

Rejecting in favor of 20464

Also available in: Atom PDF