Project

General

Profile

action #50336

[sle][functional][u] registration::add_suseconnect_product should handle retries

Added by zluo over 3 years ago. Updated about 3 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
Enhancement to existing tests
Target version:
SUSE QA - Milestone 27
Start date:
2019-04-12
Due date:
% Done:

0%

Estimated time:
Difficulty:

Description

Observation

Currently for PackageHub there's bsc#1124318 that basically makes SUSEConnect to fail the first time but it would succeed on a second call

Acceptance criteria

  • AC1: Test is able to workaround with soft-fail bsc#1124318

Suggestions

  • reproduce test failure, accept current error output as indication for workaround, record soft failure and try again
  • refactor add_suseconnect_product so that it allows the user to properly specify whether or not errors are tolerated.
  • change the code to accept named parameters to accept syntax similar to suseconnect_product 'sle-module-legacy', retry_allow => 1, timeout => 900 (or a simple hash too)

Related issues

Related to openQA Tests - action #33082: [sle][functional][u] sysauth/sssd is not scheduled on osdResolved2019-04-17

Blocked by openQA Tests - action #54140: [sle][functional][u] test fails in sssd - issue with mkdir local directoryResolved2019-07-11

History

#1 Updated by SLindoMansilla over 3 years ago

  • Category set to New test
  • Priority changed from Normal to High

#2 Updated by szarate over 3 years ago

  • Subject changed from [sle][functional][u] registration::add_suseconnect_product needs to handle softfail to [sle][functional][u] registration::add_suseconnect_product should handle retrials
  • Description updated (diff)
  • Category deleted (New test)
  • Priority changed from High to Normal

#3 Updated by szarate over 3 years ago

  • Priority changed from Normal to High

#4 Updated by SLindoMansilla over 3 years ago

Since this will end up as a workaround for a known bug, please, don't forget to use record_soft_fail.

#5 Updated by szarate over 3 years ago

  • Category set to Enhancement to existing tests

#6 Updated by SLindoMansilla over 3 years ago

  • Related to action #33082: [sle][functional][u] sysauth/sssd is not scheduled on osd added

#7 Updated by SLindoMansilla over 3 years ago

  • Description updated (diff)

#8 Updated by okurz about 3 years ago

  • Subject changed from [sle][functional][u] registration::add_suseconnect_product should handle retrials to [sle][functional][u] registration::add_suseconnect_product should handle retries
  • Description updated (diff)
  • Status changed from New to Workable
  • Priority changed from High to Normal
  • Target version set to Milestone 26

QSF-u grooming: missed our chance for 15-SP1, not high.

#9 Updated by zluo about 3 years ago

  • Status changed from Workable to In Progress
  • Assignee set to zluo

take over

#10 Updated by zluo about 3 years ago

issue with sssd for sles 12 sp5: https://bugzilla.suse.com/show_bug.cgi?id=1137876

and other issue #54140

Since AC1: Test is able to workaround with soft-fail bsc#1124318 is related to sssd, it would be better to continue to work on this ticket till both above issues got fixed.

#11 Updated by zluo about 3 years ago

  • Blocked by action #54140: [sle][functional][u] test fails in sssd - issue with mkdir local directory added

#12 Updated by zluo about 3 years ago

  • Target version changed from Milestone 26 to Milestone 27

#13 Updated by zluo about 3 years ago

due to problem with boot_to_desktop on sles 15 I cannot test the changes in registration.pm related to sssd:

https://progress.opensuse.org/issues/54341

#14 Updated by zluo about 3 years ago

  • Status changed from In Progress to Feedback

#15 Updated by SLindoMansilla about 3 years ago

  • Status changed from Feedback to Workable

Feedback provided in PR, removing from feedback queue

#16 Updated by zluo about 3 years ago

  • Status changed from Workable to Feedback

PR updated.

#17 Updated by SLindoMansilla about 3 years ago

PR merged, waiting for verification on OSD

#19 Updated by zluo about 3 years ago

  • Status changed from Feedback to Resolved

above test result is green, without any screenshots! very strange.
but I found following test which shows PR is successful:

https://openqa.suse.de/tests/3136471#step/machinery/8

Also available in: Atom PDF