Project

General

Profile

Actions

action #50093

closed

[functional][y] test fails in partitioning_full_lvm - Undefined subroutine &main::wait_screen_change called at /usr/lib/os-autoinst/testapi.pm line 604

Added by mlin7442 about 5 years ago. Updated about 5 years ago.

Status:
Resolved
Priority:
High
Assignee:
Category:
Bugs in existing tests
Target version:
SUSE QA - Milestone 24
Start date:
2019-04-07
Due date:
2019-04-23
% Done:

0%

Estimated time:
Difficulty:

Description

Observation

openQA test in scenario opensuse-15.1-DVD-x86_64-lvm-full-encrypt@64bit fails in
partitioning_full_lvm

Don't know which change causes it, installation just jump out during addlv()

[2019-04-07T15:26:44.699 CEST] [debug] /var/lib/openqa/cache/openqa1-opensuse/tests/opensuse/tests/installation/partitioning_full_lvm.pm:28 called partition_setup::addlv
[2019-04-07T15:26:44.699 CEST] [debug] <<< testapi::send_key(key='alt-s', do_wait=0)
[2019-04-07T15:26:44.981 CEST] [debug] Undefined subroutine &main::wait_screen_change called at /usr/lib/os-autoinst/testapi.pm line 604.

Test suite description

Maintainer: riafarov poo#15926 (crypt-)LVM installations can take longer, especially on non-x86_64 architectures. Test suite creates encrypted lvm partition using expert partitioner and performs installation.

Reproducible

Fails since (at least) Build 444.1 (current job)

Expected result

Last good: 443.2 (or more recent)

Further details

Always latest result in this scenario: latest

Actions #1

Updated by mlin7442 about 5 years ago

  • Subject changed from test fails in partitioning_full_lvm - Undefined subroutine &main::wait_screen_change called at /usr/lib/os-autoinst/testapi.pm line 604 to [functional][y] test fails in partitioning_full_lvm - Undefined subroutine &main::wait_screen_change called at /usr/lib/os-autoinst/testapi.pm line 604
Actions #2

Updated by riafarov about 5 years ago

  • Assignee set to riafarov
  • Target version set to Milestone 24
Actions #3

Updated by riafarov about 5 years ago

  • Status changed from New to Feedback
Actions #4

Updated by riafarov about 5 years ago

  • Due date set to 2019-04-23
  • Priority changed from Normal to High

Seems that easy patch didn't work, need closer look into it.

Actions #6

Updated by riafarov about 5 years ago

PR merged, waiting for the deployment. For o3 will happen automatically, for osd need to wait, especially as we are in RC2 phase.

Actions #8

Updated by riafarov about 5 years ago

  • Status changed from Feedback to Resolved
Actions #9

Updated by okurz about 5 years ago

This is an autogenerated message for openQA integration by the openqa_review script:

This bug is still referenced in a failing openQA test: lvm-encrypt-separate-boot
https://openqa.suse.de/tests/2798098

Actions #10

Updated by JERiveraMoya about 5 years ago

the problem is still visible in GMS: https://openqa.suse.de/tests/2874177#step/partitioning_full_lvm/39
Should already be deployed in OSD? Otherwise we should reopen this ticket I guess...

Actions

Also available in: Atom PDF