action #49952

[sle][functional][y][rt][timeboxed:4h] test fails in kmp_modules - syntax error in one of the scripts

Added by JERiveraMoya 5 months ago. Updated 4 months ago.

Status:ResolvedStart date:03/04/2019
Priority:NormalDue date:23/04/2019
Assignee:JRivrain% Done:

0%

Category:Bugs in existing tests
Target version:SUSE QA tests - Milestone 24
Difficulty:
Duration: 15

Description

Observation

We focus on investigation as of now

openQA test in scenario sle-15-SP1-Installer-DVD-x86_64-rt-validation_extra_tests@64bit fails in
kmp_modules

It's failing one of the scripts processed with:
push @kernel_modules, grep { /.*\.ko/ } split("\n", script_output "rpm -ql $_") foreach (@kmp_rpms);

Test suite description

Validation tests for RT product

Reproducible

Fails since (at least) Build 204.1

Expected result

Last good: 200.1 (or more recent)

Further details

Always latest result in this scenario: latest

History

#1 Updated by riafarov 4 months ago

  • Subject changed from [sle][functional][y] test fails in kmp_modules - syntax error in one of the scripts to [sle][functional][y][rt] test fails in kmp_modules - syntax error in one of the scripts
  • Due date set to 23/04/2019
  • Target version set to Milestone 24

#2 Updated by riafarov 4 months ago

  • Subject changed from [sle][functional][y][rt] test fails in kmp_modules - syntax error in one of the scripts to [sle][functional][y][rt][timeboxed:4h] test fails in kmp_modules - syntax error in one of the scripts
  • Description updated (diff)
  • Status changed from New to Workable

#3 Updated by mloviska 4 months ago

I am not sure why and from where the curl part comes from.
Build211.2-rt-validation_extra_tests vs lost curl

#4 Updated by JRivrain 4 months ago

  • Assignee set to JRivrain

#5 Updated by JRivrain 4 months ago

mloviska wrote:

I am not sure why and from where the curl part comes from.
Build211.2-rt-validation_extra_tests vs lost curl

It seems like some code has changed, in os-autoinst probably. it is hard to tell since this behavior does not happen anymore. I am running some VRs, but I think we can simply conclude this was fixed already.

#6 Updated by JRivrain 4 months ago

  • Status changed from Workable to In Progress

#7 Updated by JRivrain 4 months ago

  • Status changed from In Progress to Feedback

The VRs I made confirm this doesn't happen anymore.

#8 Updated by riafarov 4 months ago

  • Status changed from Feedback to Resolved

Also available in: Atom PDF