Project

General

Profile

action #47333

coordination #47195: [sle][migration][functional][u][epic] check orphaned_packages_check.pm for SLE installation tests

[sle][Migration][SLE15SP2] automatic check in orphaned_packages_check.pm

Added by okurz over 3 years ago. Updated over 2 years ago.

Status:
Resolved
Priority:
High
Assignee:
Category:
Enhancement to existing tests
Target version:
-
Start date:
2019-02-11
Due date:
% Done:

40%

Estimated time:
6.00 h
Difficulty:

Description

Motivation

Please see parent ticket #47195 . This is a request from PrjM maritawerner: ATM orphaned_packages_check.pm require to manually check the output, is there a way to automate this somehow?


Related issues

Copied to openQA Tests - action #47336: [migration] orphaned_packages_check.pm - use for other products?Resolved2019-02-11

History

#1 Updated by okurz over 3 years ago

  • Copied to action #47336: [migration] orphaned_packages_check.pm - use for other products? added

#2 Updated by maritawerner over 2 years ago

I pinged the APAC 1 team to have a look at that tickets.

#3 Updated by leli over 2 years ago

  • Subject changed from [migration] automatic check in orphaned_packages_check.pm to [sle][Migration][SLE15SP2] automatic check in orphaned_packages_check.pm
  • Category changed from New test to Enhancement to existing tests
  • Estimated time set to 6.00 h

From e-mail with Marita:
[lemon] >

We can't do this automatic check since we haven't got the expected
orphaned packages list on different versions, before and after
migration, besides we need the instructions for the manual check.

[Oli]That's easy, there should be no orphaned packages neither before nor after
migration

#4 Updated by okurz over 2 years ago

hi, would it be ok as documented on https://progress.opensuse.org/projects/suseqa/ to use only lower case keywords in the subject line for consistency?

#5 Updated by zoecao over 2 years ago

  • Assignee set to zoecao

#6 Updated by okurz over 2 years ago

hi, please see my proposal https://github.com/os-autoinst/os-autoinst-distri-opensuse/pull/9148 for an automatic check based on the current existing openQA test module as I took over #47336 . I hope it is helpful for you when you want to apply the module more in migration tests.

#7 Updated by zoecao over 2 years ago

Ok, thank you for your help, Oliver!

#8 Updated by zoecao over 2 years ago

  • Status changed from New to In Progress
  • % Done changed from 0 to 40

#9 Updated by okurz over 2 years ago

https://github.com/os-autoinst/os-autoinst-distri-opensuse/pull/9148 is merged making orphaned_packages_check already automatic. in case I missed the test module being scheduled at the right point in the schedule feel free to add the existing test module in the right schedules accordingly.

https://github.com/os-autoinst/os-autoinst-distri-opensuse/pull/9186 created for the first regression.

#10 Updated by okurz over 2 years ago

  • Status changed from In Progress to Resolved
  • Assignee changed from zoecao to okurz

mentioned PRs were merged and basically fine. There were valid bugs reported by the issues found as well as improvements proposed for the test module already by others. Feel free to reopen the ticket and reassign if you plan further work.

Also available in: Atom PDF