Project

General

Profile

action #46583

[tools][dependency jobs][scheduling] Request to support reasonable START_AFTER on ipmi.

Added by xlai over 2 years ago. Updated over 2 years ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Category:
Feature requests
Target version:
-
Start date:
2019-01-24
Due date:
% Done:

0%

Estimated time:
Difficulty:

Description

Currently for the dependent jobs with START_AFTER relationship, eg A START_AFTER B, openqa scheduling can ensure that A is after B, but can not promise that:

  • A is just the next job of B(possible a job C(os installation) in between)
  • A and B run on the same worker

This is fine for jobs on qemu workers. However for ipmi jobs, the above two constraints are needed. For example, a quite common request on ipmi machines is that first a host installation is done, and then launch various kinds of tests. This is a good example that should use START_AFTER relationship from a common tool's view. However due to above limitations, we can not do it on openqa.

With more and more users on ipmi workers to test physical machines, eg sebastian's team , QAM team and sle-virt team, we strongly recommend to add support for the stricter START_AFTER on ipmi machines. Especially currently we kind of partially rely on it to improve the openqa test efficiency to get prepare for future parallel developing products tested the same time on openqa.

coolo, nicksinger, would you please help to evaluate whether this is a reasonable request? If yes, would you please share the plan for it? Look forward to your reply!


Related issues

Is duplicate of openQA Project - action #41066: Scheduling jobs for IPMI (bare metal) on the same worker (aka FOLLOW_TEST_DIRECTLY aka START_DIRECTLY_AFTER_TEST).Resolved2019-08-22

History

#1 Updated by coolo over 2 years ago

  • Is duplicate of action #41066: Scheduling jobs for IPMI (bare metal) on the same worker (aka FOLLOW_TEST_DIRECTLY aka START_DIRECTLY_AFTER_TEST). added

#2 Updated by coolo over 2 years ago

  • Status changed from New to Closed

Don't hold your breath

Also available in: Atom PDF