Project

General

Profile

coordination #43886

autoyast tests for confirming base license, skipping proposal screen, first boot wizard

Added by okurz over 2 years ago. Updated 6 months ago.

Status:
Rejected
Priority:
Normal
Assignee:
Target version:
Start date:
2018-08-23
Due date:
% Done:

0%

Estimated time:

Description

[16/11/2018 09:20:51] <okurz> imobach: http://w3.nue.suse.com/~okurz/ay.xml
[16/11/2018 09:22:40] <imobach> okurz: you need to specify the confirm under the general/mode section
[16/11/2018 09:23:00] <imobach> something like <general><mode><confirm config:type="boolean">true</confirm></mode></general>
[16/11/2018 10:49:58] <okurz> riafarov: was it always like this that we need to explicitly ask autoyast to keep the installer network configuration in place for the installed system?
[16/11/2018 10:52:54] <riafarov> okurz: https://www.suse.com/documentation/sles-12/singlehtml/book_autoyast/book_autoyast.html#CreateProfile.Network
[16/11/2018 10:53:07] <riafarov> okurz: it's true by default
[16/11/2018 10:54:48] <okurz> riafarov: I think the culprit lies in the following sentence "If all packages are installed during the first stage and the network is not needed early during the second one, setting keep_install_network to false will avoid copying the configuration." -> because I configured to not see the proposal screen I end up with no network configured :(
[16/11/2018 10:58:36] <riafarov> okurz: it's pretty much as mini.xml profile we test
[16/11/2018 10:59:00] <okurz> yes, should be. difference is for example the confirm option
[16/11/2018 10:59:01] <riafarov> okurz: so you are saying network doesn't get configured?
[16/11/2018 10:59:40] <okurz> riafarov: yes, if I set "confirm->false" then no network
[16/11/2018 11:00:09] <riafarov> okurz: seems to be a bug, could you upload logs?
[16/11/2018 11:00:29] <okurz> riafarov: it's not a bug, works exactly as documented even though not obvious
[16/11/2018 11:02:15] <riafarov> okurz: hard to say without logs, I would not expect any difference just because of confirmation page
[16/11/2018 11:02:50] <okurz> riafarov: how about the following, we create a profile like mini but without the line to keep the network and skip the proposal screen and see if network is up in openQA tests?
[16/11/2018 11:03:04] <imobach> riafarov: okurz: yes, perhaps we are doing something in the network proposal (which is skipped when the confirmation screen is shown); perhaps mchf can shed some light on it
[16/11/2018 11:05:50] <riafarov> okurz: hhmm, you've set <confirm_base_product_license to false too
[16/11/2018 11:05:55] <okurz> riafarov: I do not consider it a bug. it is even documented as such: Skipping the second stage – which you do by not asking for the proposal screen – can cause different configuration. In this case the missing network can be prevented by either the option you added, keep installer network, or explicitly configuring for e.g. dhcp network
[16/11/2018 11:06:00] <riafarov> okurz: is it shown?
[16/11/2018 11:06:21] <okurz> riafarov: confirm_base_product_license seems to have no effect. I just tried to get rid of the 10s timing out beta notification
[16/11/2018 11:06:26] <riafarov> okurz: I don't see a reason for second stage to be skipped
[16/11/2018 11:07:58] <riafarov> okurz:  I expect same behavior like here: https://openqa.suse.de/tests/2262400 but with license screen and no overview
[16/11/2018 11:09:19] <riafarov> okurz: so firstboot_enabled should enable screen where you should get option to do all the configuration
[16/11/2018 11:09:37] <okurz> riafarov: that's a different thing
[16/11/2018 11:11:54] <riafarov> okurz: it's not
[16/11/2018 11:12:00] <riafarov> https://www.suse.com/documentation/sles-12/singlehtml/book_autoyast/book_autoyast.html#CreateProfile.Firstboot
[16/11/2018 11:12:27] <okurz> riafarov: yes, runs after installation, not in 2nd-stage of installation
[16/11/2018 11:13:02] <riafarov> okurz: there it should be possible to configure network, I guess
[16/11/2018 11:14:43] <okurz> sure,could be. but my usecase is more like an admin roles out automatic work place setups, so network covered, then first boot asks for username and password or something. let me create some more specific tickets

Related issues

Related to openQA Tests - action #40184: [functional][y] new yast2 firstboot wizard testResolved2018-08-232019-04-09

History

#1 Updated by okurz over 2 years ago

  • Copied from action #40184: [functional][y] new yast2 firstboot wizard test added

#2 Updated by okurz over 2 years ago

  • Subject changed from [functional][y][autoyast] autoyast tests for confirming base license, skipping proposal screen, first boot wizard to [functional][y][epic][autoyast] autoyast tests for confirming base license, skipping proposal screen, first boot wizard

#3 Updated by okurz over 2 years ago

  • Copied from deleted (action #40184: [functional][y] new yast2 firstboot wizard test)

#4 Updated by okurz over 2 years ago

  • Related to action #40184: [functional][y] new yast2 firstboot wizard test added

#5 Updated by szarate 6 months ago

  • Tracker changed from action to coordination

#6 Updated by szarate 6 months ago

#7 Updated by riafarov 6 months ago

  • Project changed from openQA Tests to qe-yast
  • Subject changed from [functional][y][epic][autoyast] autoyast tests for confirming base license, skipping proposal screen, first boot wizard to autoyast tests for confirming base license, skipping proposal screen, first boot wizard
  • Category deleted (New test)
  • Status changed from New to Rejected
  • Assignee set to riafarov

Rejecting in favor of #69130 where this will be addressed.

Also available in: Atom PDF