Project

General

Profile

action #43847

[functional][tools][u] test fails in zypper_lifecycle - Possible missing keys on Grenache

Added by szarate over 2 years ago. Updated over 1 year ago.

Status:
Rejected
Priority:
Normal
Assignee:
-
Category:
Bugs in existing tests
Target version:
Start date:
2018-11-15
Due date:
% Done:

0%

Estimated time:
Difficulty:

Description

Observation

While looking at the screenshot there's clearly ipefail in the screen which already means that there's a missing key, what I fail to understand here, is the layer, since this is running on Grenache which is PowerVM but being used as a jumphost for s390 machines..

[2018-11-12T17:53:33.0491 CET] [debug] <<< testapi::type_string(string='(echo AwZR8; bash -eox pipefail /tmp/scriptAwZR8.sh ; echo SCRIPT_FINISHEDAwZR8-$?-) | tee /dev/ttysclp0
', max_interval=250, wait_screen_changes=0, wait_still_screen=0)
[2018-11-12T17:53:36.0117 CET] [debug] /var/lib/openqa/cache/tests/sle/tests/console/zypper_lifecycle.pm:25 called testapi::script_output
[2018-11-12T17:53:36.0117 CET] [debug] <<< testapi::wait_serial(regexp='SCRIPT_FINISHEDAwZR8-\\d+-', timeout=300, record_output=1)
[2018-11-12T17:58:37.0655 CET] [debug] >>> testapi::wait_serial: SCRIPT_FINISHEDAwZR8-\d+-: fail
[2018-11-12T17:58:37.0656 CET] [debug] script timeout: zypper lifecycle at /usr/lib/os-autoinst/testapi.pm line 960.

openQA test in scenario sle-15-SP1-Installer-DVD-s390x-wsm+dev_tools+textmode@s390x-kvm-sle12 fails in
zypper_lifecycle

Reproducible

Fails since (at least) Build 91.1 (current job)

Expected result

Last good: 88.6 (or more recent)

Further details

Always latest result in this scenario: latest

possible misstype ninjakeys


Related issues

Related to openQA Tests - coordination #43889: [qe-core][epic][functional][virtio][wayland] openQA makes spelling mistakesBlocked

History

#2 Updated by coolo over 2 years ago

This is not a missing key, this is a missing poem.

This is typed:
(echo AwZR8; bash -eox pipefail /tmp/scriptAwZR8.sh ; echo SCRIPT_FINISHEDAwZR8-$?-) | tee /dev/ttysclp0

and what you see is:
ipefail /tmp/scriptAwZR8.sh ; echo SCRIPT_FINISHEDAwZR8-$?-) | tee /dev/ttysclp0

To me it looks like the terminal didn't accept any keys for a considerable time.

#3 Updated by coolo over 2 years ago

I see no indication that this is power related. But you will need to run the same test on multiple machines to verify.

#4 Updated by okurz over 2 years ago

  • Subject changed from test fails in zypper_lifecycle - Possible missing keys on Grenache to [functional][u] test fails in zypper_lifecycle - Possible missing keys on Grenache
  • Target version set to Milestone 22

coolo, as you are assigned, do you plan to work on this ticket or wait for QSF-u?

#5 Updated by szarate over 2 years ago

  • Subject changed from [functional][u] test fails in zypper_lifecycle - Possible missing keys on Grenache to [functional][tools][u] test fails in zypper_lifecycle - Possible missing keys on Grenache
  • Description updated (diff)
  • Assignee deleted (coolo)

Unassigning coolo for the time being, I think it's also a generic thing... adding the ticket to the list of ninjakeys

#6 Updated by szarate over 2 years ago

  • Related to coordination #43889: [qe-core][epic][functional][virtio][wayland] openQA makes spelling mistakes added

#7 Updated by okurz over 2 years ago

This is an autogenerated message for openQA integration by the openqa_review script:

This bug is still referenced in a failing openQA test: default
https://openqa.suse.de/tests/2341226

#8 Updated by okurz over 2 years ago

This is an autogenerated message for openQA integration by the openqa_review script:

This bug is still referenced in a failing openQA test: wsm+dev_tools+textmode
https://openqa.suse.de/tests/2347238

#9 Updated by okurz over 2 years ago

  • Target version changed from Milestone 22 to future

#10 Updated by szarate over 1 year ago

  • Status changed from New to Rejected

Also available in: Atom PDF