action #43847

[functional][tools][u] test fails in zypper_lifecycle - Possible missing keys on Grenache

Added by szarate over 1 year ago. Updated about 1 year ago.

Status:NewStart date:15/11/2018
Priority:NormalDue date:
Assignee:-% Done:

0%

Category:Bugs in existing tests
Target version:QA - future
Difficulty:
Duration:

Description

Observation

While looking at the screenshot there's clearly ipefail in the screen which already means that there's a missing key, what I fail to understand here, is the layer, since this is running on Grenache which is PowerVM but being used as a jumphost for s390 machines..

[2018-11-12T17:53:33.0491 CET] [debug] <<< testapi::type_string(string='(echo AwZR8; bash -eox pipefail /tmp/scriptAwZR8.sh ; echo SCRIPT_FINISHEDAwZR8-$?-) | tee /dev/ttysclp0
', max_interval=250, wait_screen_changes=0, wait_still_screen=0)
[2018-11-12T17:53:36.0117 CET] [debug] /var/lib/openqa/cache/tests/sle/tests/console/zypper_lifecycle.pm:25 called testapi::script_output
[2018-11-12T17:53:36.0117 CET] [debug] <<< testapi::wait_serial(regexp='SCRIPT_FINISHEDAwZR8-\\d+-', timeout=300, record_output=1)
[2018-11-12T17:58:37.0655 CET] [debug] >>> testapi::wait_serial: SCRIPT_FINISHEDAwZR8-\d+-: fail
[2018-11-12T17:58:37.0656 CET] [debug] script timeout: zypper lifecycle at /usr/lib/os-autoinst/testapi.pm line 960.

openQA test in scenario sle-15-SP1-Installer-DVD-s390x-wsm+dev_tools+textmode@s390x-kvm-sle12 fails in
zypper_lifecycle

Reproducible

Fails since (at least) Build 91.1 (current job)

Expected result

Last good: 88.6 (or more recent)

Further details

Always latest result in this scenario: latest

possible misstype ninjakeys


Related issues

Related to openQA Tests - action #43889: [functional][u][virtio][wayland] test fails in ooffice - ... Blocked 16/11/2018

History

#2 Updated by coolo over 1 year ago

This is not a missing key, this is a missing poem.

This is typed:
(echo AwZR8; bash -eox pipefail /tmp/scriptAwZR8.sh ; echo SCRIPT_FINISHEDAwZR8-$?-) | tee /dev/ttysclp0

and what you see is:
ipefail /tmp/scriptAwZR8.sh ; echo SCRIPT_FINISHEDAwZR8-$?-) | tee /dev/ttysclp0

To me it looks like the terminal didn't accept any keys for a considerable time.

#3 Updated by coolo over 1 year ago

I see no indication that this is power related. But you will need to run the same test on multiple machines to verify.

#4 Updated by okurz over 1 year ago

  • Subject changed from test fails in zypper_lifecycle - Possible missing keys on Grenache to [functional][u] test fails in zypper_lifecycle - Possible missing keys on Grenache
  • Target version set to Milestone 22

coolo, as you are assigned, do you plan to work on this ticket or wait for QSF-u?

#5 Updated by szarate over 1 year ago

  • Subject changed from [functional][u] test fails in zypper_lifecycle - Possible missing keys on Grenache to [functional][tools][u] test fails in zypper_lifecycle - Possible missing keys on Grenache
  • Description updated (diff)
  • Assignee deleted (coolo)

Unassigning coolo for the time being, I think it's also a generic thing... adding the ticket to the list of ninjakeys

#6 Updated by szarate over 1 year ago

  • Related to action #43889: [functional][u][virtio][wayland] test fails in ooffice - openQA makes spelling mistakes added

#7 Updated by okurz about 1 year ago

This is an autogenerated message for openQA integration by the openqa_review script:

This bug is still referenced in a failing openQA test: default
https://openqa.suse.de/tests/2341226

#8 Updated by okurz about 1 year ago

This is an autogenerated message for openQA integration by the openqa_review script:

This bug is still referenced in a failing openQA test: wsm+dev_tools+textmode
https://openqa.suse.de/tests/2347238

#9 Updated by okurz about 1 year ago

  • Target version changed from Milestone 22 to future

Also available in: Atom PDF