Project

General

Profile

action #42488

coordination #42128: [functional][y][epic] Adjust partitioning tests to changes in storage-ng

[qam][functional][y][fast] test fails in partitioning_raid

Added by osukup almost 4 years ago. Updated almost 4 years ago.

Status:
Resolved
Priority:
Urgent
Assignee:
Category:
Bugs in existing tests
Target version:
SUSE QA - Milestone 20
Start date:
2018-10-15
Due date:
2018-10-23
% Done:

0%

Estimated time:
Difficulty:

Description

Observation

openQA test in scenario sle-15-Server-DVD-Incidents-Minimal-x86_64-qam-minimal-RAID1+sle15@64bit-smp fails in
partitioning_raid

Reproducible

Fails since (at least) Build :7911:kmod.1538309649

Expected result

Last good: :8985:zypper.1538995398 (or more recent)

Further details

Always latest result in this scenario: latest

History

#1 Updated by okurz almost 4 years ago

riafarov, mloviska, JERiveraMoya, could this be related to any of your recent changes?

#2 Updated by JERiveraMoya almost 4 years ago

I think what is happening is that $cmd{addpart} is not taking the old value: https://github.com/os-autoinst/os-autoinst-distri-opensuse/commit/76fe0dd98a78dd7842fc5f3ab9b5a7bc8f413767#diff-86a1ae5293ddebfe8ba9415cf180e5a5R52 in the previous test to partition_raid. mloviska, could you confirm it?
Nevertheless I had to fix the version in partition_raid to realize about that: PR - Fix version for sle15 GA in partition raid This is my local verification after adapting the version: http://dhcp42.suse.cz/tests/332#step/partitioning_raid/12 where is typing alt-r anyway because $cmd{addpart} was overridden.

#3 Updated by mloviska almost 4 years ago

@JERiveraMoya is right, it is because of the $cmd{addpart} shortcut has changed. I will fix it

#4 Updated by okurz almost 4 years ago

  • Subject changed from [QAM] test fails in partitioning_raid to [qam][functional][y][fast] test fails in partitioning_raid
  • Due date set to 2018-10-23
  • Assignee set to mloviska
  • Priority changed from Normal to Urgent
  • Target version set to Milestone 20

thx

#6 Updated by riafarov almost 4 years ago

  • Parent task set to #42128

#7 Updated by riafarov almost 4 years ago

  • Status changed from New to In Progress

#8 Updated by riafarov almost 4 years ago

  • Status changed from In Progress to Resolved

Also available in: Atom PDF