action #42452

openQA-in-openQA test fails in openqa_webui trying to access a TW snapshot repo on o3 that is already deleted and the test does not track the repo

Added by okurz over 1 year ago. Updated 4 months ago.

Status:BlockedStart date:14/10/2018
Priority:NormalDue date:
Assignee:okurz% Done:

0%

Category:Feature requests
Target version:-
Difficulty:
Duration:

Description

Observation

openQA test in scenario openqa-Tumbleweed-dev-x86_64-openqa_install+publish@64bit-2G fails in
openqa_webui

Reproducible

Fails since (at least) Build :TW.1772

Expected result

Last good: :TW.1771 (or more recent)

Suggestions

the repo of TW snapshot 20181011 is already deleted when trying to install packages from it. Maybe it is just as simple as specifying the repo in e.g. REPO_1=… so that openQA would track the job as dependant on the snapshot and not delete it that fast.

Further details

Always latest result in this scenario: latest


Related issues

Blocked by openQA Project - action #12180: [webui] Prevent tests to be triggered when required asset... New 31/05/2016

History

#1 Updated by SLindoMansilla over 1 year ago

  • Status changed from Workable to In Progress
  • Assignee set to SLindoMansilla

#2 Updated by SLindoMansilla over 1 year ago

Setting added to test suite openqa_install+publish:

#3 Updated by okurz over 1 year ago

I doubt this can work. Builds for the openQA-in-openQA tests are named like ":TW.1884" and not like 20181217

#4 Updated by SLindoMansilla over 1 year ago

Right, setting removed...

#5 Updated by SLindoMansilla over 1 year ago

  • Status changed from In Progress to Workable
  • Assignee deleted (SLindoMansilla)

#6 Updated by okurz over 1 year ago

There is a jenkins job triggering the tests, see http://jenkins.qa.suse.de/view/openQA-in-openQA/

https://gitlab.suse.de/openqa/scripts/blob/master/trigger-openqa_in_openqa is the trigger script where we could mention REPO_0 referencing the TW repo.

#7 Updated by okurz over 1 year ago

  • Target version changed from Milestone 21 to Milestone 25+

#8 Updated by mgriessmeier 11 months ago

  • Target version changed from Milestone 25+ to Milestone 25

#9 Updated by mgriessmeier 9 months ago

  • Status changed from Workable to Rejected
  • Assignee set to mgriessmeier

#10 Updated by okurz 9 months ago

  • Status changed from Rejected to Workable

can you explain why you reject this? I guess the issue is still valid, is it not?

#11 Updated by okurz 9 months ago

  • Assignee deleted (mgriessmeier)
  • Target version changed from Milestone 25 to future

discussed with @mgriessmeier in person: Issue still valid, could reappear at any time when someone e.g. triggers a slightly older test job and in case the corresponding Tumbleweed repo was already deleted. The main reason we use a snapshot qcow image is to have a convenient image including gnome which AFAIK we don't have available from JeOS or anything. So I can think of three alternatives:

  • Make sure the proper TW repos are tracked on o3
  • Replace the repos with published ones
  • use a different image that already has only published repos

#12 Updated by SLindoMansilla 8 months ago

  • Subject changed from [openqa][functional][u] openQA-in-openQA test fails in openqa_webui trying to access a TW snapshot repo on o3 that is already deleted and the test does not track the repo to [openqa][opensuse] openQA-in-openQA test fails in openqa_webui trying to access a TW snapshot repo on o3 that is already deleted and the test does not track the repo
  • Assignee set to okurz

We, u-team, prefer to not handle this extra product

#13 Updated by okurz 6 months ago

  • Blocked by action #12180: [webui] Prevent tests to be triggered when required assets are not present (anymore) added

#14 Updated by okurz 6 months ago

  • Project changed from openQA Tests to openQA Project
  • Subject changed from [openqa][opensuse] openQA-in-openQA test fails in openqa_webui trying to access a TW snapshot repo on o3 that is already deleted and the test does not track the repo to openQA-in-openQA test fails in openqa_webui trying to access a TW snapshot repo on o3 that is already deleted and the test does not track the repo
  • Category changed from Bugs in existing tests to Feature requests
  • Status changed from Workable to Blocked
  • Target version deleted (future)

Also available in: Atom PDF