action #40460

Improve reporting about apparmor compatibility with remote backends (was:Test run died because of unexpected console quit (select_console failed))

Added by waynechen55 over 1 year ago. Updated 3 months ago.

Status:WorkableStart date:31/08/2018
Priority:LowDue date:
Assignee:-% Done:

0%

Category:Feature requests
Target version:Ready
Difficulty:
Duration:

Description

Observation

I encounterd this error before. At that time, I can get over it by upgrade xterm-console and then re-install os-autoinst.
This time I did not perform the exact same sequence of operations as before, but still tried to resolve this issue by various method.
Unfortunately, this error persists and block me from continuing my test.

[2018-08-31T12:28:50.0975 CST] [debug] <<< testapi::select_console(testapi_console='sol', await_console=0)
/usr/lib/os-autoinst/consoles/vnc_base.pm:71:{
  'port' => 36780,
  'hostname' => 'localhost',
  'ikvm' => 0
}
[2018-08-31T12:28:51.0089 CST] [debug] Connected to Xvnc - PID 9001
icewm PID is 9013
xterm PID is 9015
IceWM: using /var/lib/empty/.icewm for private configuration files
Fontconfig error: Cannot load default config file
IceWM: Warning: Could not load font "sans-serif:size=10:bold".
IceWM: xft: fallback from 'sans-serif:size=10:bold'
…
IceWM: Could not load fallback Xft font.
Traceback (most recent call last):
  File "/usr/bin/xterm-console", line 31, in <module>
    with open("/sys/module/vt/parameters/default_{}".format(cname)) as f:
PermissionError: [Errno 13] Permission denied: '/sys/module/vt/parameters/default_red'

Acceptance criteria

  • AC1: There is clear feedback that the apparmor profiles are not compatible with remote backends

Suggestions

  • From within the worker, when the backend for a job is not qemu, try to conduct an operation which is only allowed with apparmor disabled, e.g. something with "ssh", report an obvious message if not
  • As an alternative: Add a check to the worker calling sudo /usr/sbin/aa-status | grep '/usr/share/openqa/script/worker' whenever the backend is not qemu. But research if we can achieve that without root permissions

History

#1 Updated by mlin7442 over 1 year ago

  • Assignee deleted (openSUSE-Team-at-SUSE)
  • Private changed from Yes to No

Why this is assigned to openSUSE-Team@SUSE? and also I made it to be public.

#2 Updated by waynechen55 over 1 year ago

This problem can be bypassed by disbale AppArmor as well.

#3 Updated by coolo over 1 year ago

  • Category set to Concrete Bugs
  • Priority changed from High to Low
  • Target version set to Ready

Right, remote backends are not supported with apparmor in strict mode. We could report this better

#4 Updated by okurz 4 months ago

  • Subject changed from Test run died because of unexpected console quit (select_console failed) to Improve reporting about apparmor compatibility with remote backends (was:Test run died because of unexpected console quit (select_console failed))
  • Description updated (diff)
  • Category changed from Concrete Bugs to Feature requests

I tried to improve the ticket description but I struggle with the acceptance criteria

#5 Updated by okurz 3 months ago

  • Description updated (diff)
  • Status changed from New to Workable

Also available in: Atom PDF